FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2018 PLD Team
$Revision: 1.37 $
Powered by voodoo magic.
Your IP: 54.159.30.26

apache-mod_geoip 9ae3eaa8-79c0-4623-bf8e-ba50d565f7f8

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/ac/amd64/FAIL/apache-mod_geoip,9ae3eaa8-79c0-4623-bf8e-ba50d565f7f8.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2012/05/21 11:42:31
Runtime:0:00:00.464719

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • prep
  • Executing(%prep): env -i PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/home/services/builder/bin HOME=/home/services/builder TMPDIR=/tmp/B.d0a44c /bin/sh -e /tmp/B.d0a44c/rpm-tmp.16838
  • build
  • Executing(%build): env -i PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/home/services/builder/bin HOME=/home/services/builder TMPDIR=/tmp/B.d0a44c /bin/sh -e /tmp/B.d0a44c/rpm-tmp.16838
  • error 3
  • mod_geoip.c:423: error: `GEOIP_NETSPEED_EDITION_REV1' undeclared (first use in this function)
  • error 4
  • mod_geoip.c:423: error: (Each undeclared identifier is reported only once
  • error 5
  • mod_geoip.c:423: error: for each function it appears in.)
  • error 6
  • mod_geoip.c:546: error: `GEOIP_CITY_EDITION_REV0_V6' undeclared (first use in this function)
  • error 7
  • mod_geoip.c:547: error: `GEOIP_CITY_EDITION_REV1_V6' undeclared (first use in this function)
  • error 8
  • apxs:Error: Command failed with rc=65536
  • error 9
  • error: Bad exit status from /tmp/B.d0a44c/rpm-tmp.16838 (%build)
  • error 10
  • RPM build errors:
  • error 11
  • error: No files produced.

Content:

checking if we should skip the build
started at: Mon May 21 11:42:06 2012
fetching http://ep09.pld-linux.org/~buildsrc/srpms/9ae3eaa8-79c0-4623-bf8e-ba50d565f7f8/apache-mod_geoip-1.2.7-1.src.rpm
fetched 16043 bytes, 125.2 K/s
installing srpm: apache-mod_geoip-1.2.7-1.src.rpm
apache-mod_geoip            ##################################################
Building target platforms: amd64-pld-linux
checking BuildConflict-ing packages
no BuildConflicts found
checking BR
rpm: error: Failed build dependencies:
rpm: 	/usr/sbin/apxs is needed by apache-mod_geoip-1.2.7-1.src
rpm: 	apache-devel >= 2.2 is needed by apache-mod_geoip-1.2.7-1.src
updating poldek cache...

Retrieving ac-i686-main::packages.ndir.md...
ac-i686-main is up to date

Retrieving ac-i686-updates::packages.ndir.md...
ac-i686-updates is up to date

Retrieving ac-main::packages.ndir.md...
ac-main is up to date

Retrieving ac-updates::packages.ndir.md...
ac-updates is up to date

Retrieving okas::packages.ndir.md...
okas is up to date
checking conflicting packages in BRed packages
poldek: Loading [pndir]okas...
poldek: Loading [dir]ready...
poldek: 200..400..600..800..1000..1200..1400..1600..1800..2000..2200..2400..2600..2800..3000..3200..3400..3586
poldek: Loading [pndir]ac-main...
poldek: Loading [pndir]ac-updates...
poldek: 23036 packages read
poldek: Removed 7805 duplicate packages from available set
poldek: notice: /usr/sbin/apxs: removed cap due to apache-devel-2.2.22-1 is marked
poldek: Processing dependencies...
poldek: apache-devel-2.2.22-1.amd64 marks apr-util-devel-1.3.12-2.amd64 (cap apr-util-devel >= 1:1.2)
poldek:  apr-util-devel-1.3.12-2.amd64 marks apr-devel-1.4.5-2.amd64 (cap apr-devel >= 1:1.3.0)
poldek: There are 3 packages to install (2 marked by dependencies):
poldek: I apache-devel-2.2.22-1.amd64
poldek: D apr-devel-1.4.5-2.amd64  apr-util-devel-1.3.12-2.amd64
poldek: This operation will use 1.3MB of disk space.
poldek: Need to get 292.4KB of archives.
poldek: Executing rpm --upgrade -vh --test --root /...
poldek: Preparing...                ##################################################
no conflicts found
checking BR
rpm: error: Failed build dependencies:
rpm: 	/usr/sbin/apxs is needed by apache-mod_geoip-1.2.7-1.src
rpm: 	apache-devel >= 2.2 is needed by apache-mod_geoip-1.2.7-1.src
installing BR: \/usr\/sbin\/apxs apache\-devel
Loading [pndir]okas...
Loading [dir]ready...
200..400..600..800..1000..1200..1400..1600..1800..2000..2200..2400..2600..2800..3000..3200..3400..3586
Loading [pndir]ac-main...
Loading [pndir]ac-updates...
23036 packages read
Removed 7805 duplicate packages from available set
notice: /usr/sbin/apxs: removed cap due to apache-devel-2.2.22-1 is marked
Processing dependencies...
apache-devel-2.2.22-1.amd64 marks apr-util-devel-1.3.12-2.amd64 (cap apr-util-devel >= 1:1.2)
 apr-util-devel-1.3.12-2.amd64 marks apr-devel-1.4.5-2.amd64 (cap apr-devel >= 1:1.3.0)
There are 3 packages to install (2 marked by dependencies):
I apache-devel-2.2.22-1.amd64
D apr-devel-1.4.5-2.amd64  apr-util-devel-1.3.12-2.amd64
This operation will use 1.3MB of disk space.
Need to get 292.4KB of archives. 
Executing rpm --upgrade -vh --root /...
Preparing...                ##################################################
apr-devel                   ##################################################
apr-util-devel              ##################################################
apache-devel                ##################################################
building RPM using: echo build-id: 9ae3eaa8-79c0-4623-bf8e-ba50d565f7f8; cd rpm/SPECS; TMPDIR=/tmp/B.d0a44c exec nice -n 19 rpmbuild -bb --define '_smp_mflags -j4'  --target amd64-pld-linux   apache-mod_geoip.spec
build-id: 9ae3eaa8-79c0-4623-bf8e-ba50d565f7f8
Building target platforms: amd64-pld-linux
Executing(%prep):  env -i PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/home/services/builder/bin HOME=/home/services/builder TMPDIR=/tmp/B.d0a44c  /bin/sh -e /tmp/B.d0a44c/rpm-tmp.16838
+ umask 022
+ cd /home/services/builder/rpm/BUILD
+ cd /home/services/builder/rpm/BUILD
+ rm -rf mod_geoip2_1.2.7
+ /bin/gzip -dc /home/services/builder/rpm/SOURCES/mod_geoip2_1.2.7.tar.gz
+ tar -xf -
+ STATUS=0
+ [ 0 -ne 0 ]
+ cd mod_geoip2_1.2.7
+ /bin/id -u
+ [ 182 = 0 ]
+ true .
+ /bin/chmod -Rf -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build):  env -i PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin:/home/services/builder/bin HOME=/home/services/builder TMPDIR=/tmp/B.d0a44c  /bin/sh -e /tmp/B.d0a44c/rpm-tmp.16838
+ umask 022
+ cd /home/services/builder/rpm/BUILD
+ cd mod_geoip2_1.2.7
+ /usr/sbin/apxs -Wc, -O2  -Wl,-lGeoIP -Wl,--as-needed  -c mod_geoip.c
Note: /usr/sbin/httpd.prefork not found or not executable.
/usr/share/apr/build-1/libtool --silent --mode=compile amd64-pld-linux-gcc -prefer-pic -O2  -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/apache  -I/usr/include/apr   -I/usr/include/apr-util -I/usr/include -I/usr/include/apr  -O2   -c -o mod_geoip.lo mod_geoip.c && touch mod_geoip.slo
mod_geoip.c: In function `geoip_header_parser':
mod_geoip.c:423: error: `GEOIP_NETSPEED_EDITION_REV1' undeclared (first use in this function)
mod_geoip.c:423: error: (Each undeclared identifier is reported only once
mod_geoip.c:423: error: for each function it appears in.)
mod_geoip.c:546: error: `GEOIP_CITY_EDITION_REV0_V6' undeclared (first use in this function)
mod_geoip.c:547: error: `GEOIP_CITY_EDITION_REV1_V6' undeclared (first use in this function)
apxs:Error: Command failed with rc=65536
.
error: Bad exit status from /tmp/B.d0a44c/rpm-tmp.16838 (%build)


RPM build errors:
    Bad exit status from /tmp/B.d0a44c/rpm-tmp.16838 (%build)
ended at: Mon May 21 11:42:30 2012, done in 0:00:00.464719
error: No files produced.
Begin-PLD-Builder-Info
Build-Time: user:19.31s sys:3.04s real:24.85s (faults io:1 non-io:743836)

End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]