FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2019 PLD Team
$Revision: 1.37 $
Powered by BOFH.
Your IP: 35.175.120.174

apcupsd 7bbb8052-5f1f-4e0b-9c00-4cfe2c36c77f

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/ac/ppc/FAIL/apcupsd,7bbb8052-5f1f-4e0b-9c00-4cfe2c36c77f.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2010/02/07 17:21:00
Runtime:00

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.43a833/rpm-tmp.89360
  • build
  • Executing(%build): /bin/sh -e /tmp/B.43a833/rpm-tmp.56780
  • error 3
  • configure: error: Missing required tool; need any one of: shutdown shutdown.bsd
  • error 4
  • error: Bad exit status from /tmp/B.43a833/rpm-tmp.56780 (%build)
  • error 5
  • RPM build errors:
  • error 6
  • error: No files produced.

Content:

checking if we should skip the build
started at: Sun Feb  7 18:10:09 2010
fetching http://src.ac.pld-linux.org/~buildsrc//srpms/7bbb8052-5f1f-4e0b-9c00-4cfe2c36c77f/apcupsd-3.14.8-1.src.rpm
fetched 1330371 bytes, 296.2 K/s
installing srpm: apcupsd-3.14.8-1.src.rpm
Building target platforms: ppc-pld-linux
checking BuildConflict-ing packages
no BuildConflicts found
checking BR
rpm: error: Failed build dependencies:
rpm: 	GConf2-devel >= 2.0 is needed by apcupsd-3.14.8-1.src
rpm: 	gd-devel is needed by apcupsd-3.14.8-1.src
rpm: 	gtk+2-devel >= 2:2.4.0 is needed by apcupsd-3.14.8-1.src
rpm: 	ncurses-ext-devel is needed by apcupsd-3.14.8-1.src
updating poldek cache...

ready is up to date

Retrieving ac-main::packages.ndir.md...
ac-main is up to date

Retrieving ac-updates::packages.ndir.md...
Retrieving ac-updates::packages.ndir.diff.toc.gz...
..............................done

Retrieving diff::packages.ndir.2010.02.05-07.56.54.gz...
..............................done
Retrieving diff::packages.ndir.dscr.2010.02.05-07.56.54.gz...
..............................done
Loading [pndir]ac-updates...
Applying packages.ndir.2010.02.05-07.56.54.gz...

Retrieving diff::packages.ndir.2010.02.07-14.51.28.gz...
..............................done
Retrieving diff::packages.ndir.dscr.2010.02.07-14.51.28.gz...
Applying packages.ndir.2010.02.07-14.51.28.gz...

Writing /root/.poldek-cache/[...]/packages.ndir.gz...
checking conflicting packages in BRed packages
poldek: Loading [pndir]ready...
poldek: Loading [pndir]ac-main...
poldek: Loading [pndir]ac-updates...
poldek: 18757 packages read
poldek: Removed 4054 duplicate packages from available set
poldek: Processing dependencies...
poldek: gd-devel-2.0.35-1 marks X11-devel-6.9.0-19 (cap XFree86-devel)
poldek:   X11-devel-6.9.0-19 marks fontconfig-devel-2.4.2-1 (cap fontconfig-devel >= 1:2.2.0)
poldek:     fontconfig-devel-2.4.2-1 marks freetype-devel-2.3.7-1 (cap freetype-devel >= 2.1.5)
poldek:       freetype-devel-2.3.7-1 marks zlib-devel-1.2.3.7-3 (cap zlib-devel)
poldek:         zlib-devel-1.2.3.7-3 marks zlib-1.2.3.7-3 (cap zlib = 1.2.3.7-3)
poldek:           zlib-1.2.3-3 obsoleted by zlib-1.2.3.7-3
poldek: gd-devel-2.0.35-1 marks libpng-devel-1.2.35-1 (cap libpng-devel)
poldek: gtk+2-devel-2.12.9-2 marks pango-devel-1.20.0-1 (cap pango-devel >= 1:1.18.3)
poldek:   pango-devel-1.20.0-1 marks cairo-devel-1.6.4-2 (cap cairo-devel >= 1.4.10)
poldek: GConf2-devel-2.14.0-6 marks libxml2-devel-2.7.2-1 (cap libxml2-devel >= 1:2.6.21)
poldek: There are 13 packages to install (9 marked by dependencies), 1 to remove:
poldek: I GConf2-devel-2.14.0-6, gd-devel-2.0.35-1, gtk+2-devel-2.12.9-2,
poldek: I ncurses-ext-devel-5.7-8
poldek: D X11-devel-6.9.0-19, cairo-devel-1.6.4-2, fontconfig-devel-2.4.2-1,
poldek: D freetype-devel-2.3.7-1, libpng-devel-1.2.35-1, libxml2-devel-2.7.2-1,
poldek: D pango-devel-1.20.0-1, zlib-1.2.3.7-3, zlib-devel-1.2.3.7-3
poldek: R zlib-1.2.3-3
poldek: Need to get 3.3MB of archives (3.2MB to download).
poldek: After unpacking 12.7MB will be used.
poldek: Retrieving ac-updates::freetype-devel-2.3.7-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::libxml2-devel-2.7.2-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::GConf2-devel-2.14.0-6.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::libpng-devel-1.2.35-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::cairo-devel-1.6.4-2.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::pango-devel-1.20.0-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::gtk+2-devel-2.12.9-2.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::gd-devel-2.0.35-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-updates::ncurses-ext-devel-5.7-8.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-main::fontconfig-devel-2.4.2-1.ppc.rpm...
poldek: ..............................done
poldek: Retrieving ac-main::X11-devel-6.9.0-19.ppc.rpm...
poldek: ..............................done
poldek: Executing rpm --upgrade -vh --test --root /...
poldek: Preparing...                ##################################################
no conflicts found
checking BR
rpm: error: Failed build dependencies:
rpm: 	GConf2-devel >= 2.0 is needed by apcupsd-3.14.8-1.src
rpm: 	gd-devel is needed by apcupsd-3.14.8-1.src
rpm: 	gtk+2-devel >= 2:2.4.0 is needed by apcupsd-3.14.8-1.src
rpm: 	ncurses-ext-devel is needed by apcupsd-3.14.8-1.src
installing BR: GConf2\-devel gd\-devel gtk\+2\-devel ncurses\-ext\-devel
Loading [pndir]ready...
Loading [pndir]ac-main...
Loading [pndir]ac-updates...
18757 packages read
Removed 4054 duplicate packages from available set
Processing dependencies...
GConf2-devel-2.14.0-6 marks libxml2-devel-2.7.2-1 (cap libxml2-devel >= 1:2.6.21)
  libxml2-devel-2.7.2-1 marks zlib-devel-1.2.3.7-3 (cap zlib-devel)
    zlib-devel-1.2.3.7-3 marks zlib-1.2.3.7-3 (cap zlib = 1.2.3.7-3)
      zlib-1.2.3-3 obsoleted by zlib-1.2.3.7-3
There are 4 packages to install (3 marked by dependencies), 1 to remove:
I GConf2-devel-2.14.0-6
D libxml2-devel-2.7.2-1, zlib-1.2.3.7-3, zlib-devel-1.2.3.7-3
R zlib-1.2.3-3
Need to get 724.4KB of archives. After unpacking 4.4MB will be used.
Executing rpm --upgrade -vh --root /...
Preparing...                ##################################################
zlib                        ##################################################
zlib-devel                  ##################################################
libxml2-devel               ##################################################
GConf2-devel                ##################################################
Installing set #2
Processing dependencies...
gtk+2-devel-2.12.9-2 marks X11-devel-6.9.0-19 (cap XFree86-devel)
  X11-devel-6.9.0-19 marks fontconfig-devel-2.4.2-1 (cap fontconfig-devel >= 1:2.2.0)
    fontconfig-devel-2.4.2-1 marks freetype-devel-2.3.7-1 (cap freetype-devel >= 2.1.5)
gtk+2-devel-2.12.9-2 marks pango-devel-1.20.0-1 (cap pango-devel >= 1:1.18.3)
  pango-devel-1.20.0-1 marks cairo-devel-1.6.4-2 (cap cairo-devel >= 1.4.10)
    cairo-devel-1.6.4-2 marks libpng-devel-1.2.35-1 (cap libpng-devel)
There are 7 packages to install (6 marked by dependencies):
I gtk+2-devel-2.12.9-2
D X11-devel-6.9.0-19, cairo-devel-1.6.4-2, fontconfig-devel-2.4.2-1, 
D freetype-devel-2.3.7-1, libpng-devel-1.2.35-1, pango-devel-1.20.0-1
Need to get 2.5MB of archives. After unpacking 8.1MB will be used.
Executing rpm --upgrade -vh --root /...
Preparing...                ##################################################
freetype-devel              ##################################################
fontconfig-devel            ##################################################
libpng-devel                ##################################################
X11-devel                   ##################################################
cairo-devel                 ##################################################
pango-devel                 ##################################################
gtk+2-devel                 ##################################################
Installing set #3
Processing dependencies...
There are 1 package to install:
I gd-devel-2.0.35-1
Need to get 21.1KB of archives. After unpacking 49.4KB will be used.
Executing rpm --upgrade -vh --root /...
Preparing...                ##################################################
gd-devel                    ##################################################
Installing set #4
Processing dependencies...
There are 1 package to install:
I ncurses-ext-devel-5.7-8
Need to get 97.1KB of archives. After unpacking 138.6KB will be used.
Executing rpm --upgrade -vh --root /...
Preparing...                ##################################################
ncurses-ext-devel           ##################################################
building RPM using: echo build-id: 7bbb8052-5f1f-4e0b-9c00-4cfe2c36c77f; cd rpm/SPECS; TMPDIR=/tmp/B.43a833 exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j1'  --target ppc-pld-linux   apcupsd.spec
build-id: 7bbb8052-5f1f-4e0b-9c00-4cfe2c36c77f
Building target platforms: ppc-pld-linux
Executing(%prep): /bin/sh -e /tmp/B.43a833/rpm-tmp.89360
+ umask 022
+ cd /home/services/builder/rpm/BUILD
+ cd /home/services/builder/rpm/BUILD
+ rm -rf apcupsd-3.14.8
+ /bin/gzip -dc /home/services/builder/rpm/SOURCES/apcupsd-3.14.8.tar.gz
+ tar -xf -
+ STATUS=0
+ [ 0 -ne 0 ]
+ cd apcupsd-3.14.8
+ /bin/id -u
+ [ 182 = 0 ]
+ true .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo Patch #0 (apcupsd-configure.patch):
Patch #0 (apcupsd-configure.patch):
+ patch -p1 -s
+ < /home/services/builder/rpm/SOURCES/apcupsd-configure.patch 
+ echo Patch #1 (apcupsd-pcnet-seconds.patch):
Patch #1 (apcupsd-pcnet-seconds.patch):
+ patch -p1 -s
+ < /home/services/builder/rpm/SOURCES/apcupsd-pcnet-seconds.patch 
+ install autoconf/configure.in .
+ install autoconf/aclocal.m4 .
+ install autoconf/config.h.in .
+ cp -f /usr/share/automake/config.sub autoconf
+ exit 0
Executing(%build): /bin/sh -e /tmp/B.43a833/rpm-tmp.56780
+ umask 022
+ cd /home/services/builder/rpm/BUILD
+ cd apcupsd-3.14.8
+ autoconf
+ ./configure LDFLAGS=-Wl,--as-needed  CFLAGS=-O2 -fsigned-char  CXXFLAGS=-O2 -fsigned-char  FFLAGS=-O2 -fsigned-char  FCFLAGS=-O2 -fsigned-char  CPPFLAGS= CC=ppc-pld-linux-gcc CXX=ppc-pld-linux-g++ --host=ppc-pld-linux --build=ppc-pld-linux --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc/apcupsd --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/lib --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --x-libraries=/usr/X11R6/lib --with-log-dir=/var/log --with-stat-dir=/var/lib/apcupsd --enable-cgi --with-cgi-bin=/home/services/httpd/cgi-bin --enable-test --enable-net --enable-gapcmon --enable-usb
checking for true... /bin/true
checking for false... /bin/false
checking build system type... powerpc-pld-linux-gnu
checking host system type... powerpc-pld-linux-gnu
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether ppc-pld-linux-g++ accepts -g... yes
checking for ppc-pld-linux-gcc... ppc-pld-linux-gcc
checking whether we are using the GNU C compiler... yes
checking whether ppc-pld-linux-gcc accepts -g... yes
checking for ppc-pld-linux-gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... ppc-pld-linux-gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking for mawk... mawk
checking for library containing strerror... none required
checking for shutdown... no
checking for shutdown.bsd... no
configure: error: Missing required tool; need any one of: shutdown shutdown.bsd
error: Bad exit status from /tmp/B.43a833/rpm-tmp.56780 (%build)


RPM build errors:
    Bad exit status from /tmp/B.43a833/rpm-tmp.56780 (%build)
ended at: Sun Feb  7 18:20:38 2010, done in 00h 02m 47s
error: No files produced.
Begin-PLD-Builder-Info
Build-Time: user:169.95s sys:163.25s real:651.44s (faults io:45 non-io:721887)

End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]