FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2018 PLD Team
$Revision: 1.37 $
Powered by /dev/null.
Your IP: 54.224.133.152

elektra 0e1f51be-ee69-4157-839f-32834e9c4a70

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/th/i686/FAIL/elektra,0e1f51be-ee69-4157-839f-32834e9c4a70.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2018/06/05 08:46:46
Runtime:0:00:09.203340

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792
  • build
  • Executing(%build): /bin/sh -e /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792
  • error 3
  • error: Bad exit status from /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792 (%build)
  • error 4
  • RPM build errors:
  • error 5
  • error: No files produced.

Content:

checking if we should skip the build
started at: Tue Jun  5 08:46:17 2018
killing old processes on a builder
sending signal 9 to pid -1
Killed
fetching https://srcbuilder.pld-linux.org/th//srpms/0e1f51be-ee69-4157-839f-32834e9c4a70/elektra-0.8.19-6.src.rpm
fetched 2704924 bytes, 3210.0 K/s
installing srpm: elektra-0.8.19-6.src.rpm
+ install -d /tmp/B.y_5z3g/BUILD /tmp/B.y_5z3g/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog elektra-0.8.19-6.src.rpm
* Tue Jun 05 2018 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/elektra.git;a=log;h=master
* Thu Nov 23 2017 Jan Rękorajski <baggins@pld-linux.org> e1a4df3
- fix typo in cmake config - rel 6 * Wed Oct 25 2017 Jan Rękorajski <baggins@pld-linux.org> 014c004
- rebuild with ruby 2.3 - release 5 (by relup.sh) + rpm -Uhv --nodeps --define '_topdir /tmp/B.y_5z3g' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' elektra-0.8.19-6.src.rpm Preparing... ################################################## elektra ################################################## + rm -f elektra-0.8.19-6.src.rpm + install -m 700 -d /tmp/B.y_5z3g/BUILD/tmp + TMPDIR=/tmp/B.y_5z3g/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.y_5z3g' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux --define 'prep exit 0' /tmp/B.y_5z3g/elektra.spec Building target platforms: i686-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: ronn is needed by elektra-0.8.19-6.src rpm: Building target platforms: i686-pld-linux updating poldek cache... ready is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-test::packages.ndir.md... Retrieving th-test::packages.ndir.diff.toc.gz... ..............................done Retrieving diff::packages.ndir.2018.06.04-08.04.02.gz... ..............................done Retrieving diff::packages.ndir.dscr.2018.06.04-08.04.02.gz... Loading [pndir]th-test... Applying packages.ndir.2018.06.04-08.04.02.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... Retrieving th-test::packages.ndir.md... Retrieving th-test::packages.ndir.diff.toc.gz... Retrieving diff::packages.ndir.2018.06.04-08.04.02.gz... ..............................done Retrieving diff::packages.ndir.dscr.2018.06.04-08.04.02.gz... Loading [pndir]th-test... Applying packages.ndir.2018.06.04-08.04.02.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 29195 packages read poldek: Removed 2301 duplicate packages from available set poldek: Processing dependencies... poldek: ronn-0.7.3-2.noarch marks ruby-ronn-0.7.3-2.noarch (cap ruby-ronn = 0.7.3-2) poldek: ruby-ronn-0.7.3-2.noarch marks ruby-hpricot-0.8.6-6.i686 (cap ruby-hpricot) poldek: ruby-ronn-0.7.3-2.noarch marks ruby-rdiscount-2.2.0.1-3.i686 (cap ruby-rdiscount) poldek: There are 4 packages to install (3 marked by dependencies): poldek: I ronn-0.7.3-2.noarch poldek: D ruby-hpricot-0.8.6-6.i686 ruby-rdiscount-2.2.0.1-3.i686 poldek: D ruby-ronn-0.7.3-2.noarch poldek: This operation will use 359.2KB of disk space. poldek: Need to get 139.1KB of archives. poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: Preparing... ################################################## no conflicts found checking BR rpm: error: Failed build dependencies: rpm: ronn is needed by elektra-0.8.19-6.src rpm: Building target platforms: i686-pld-linux installing BR: ronn + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' --upgrade ronn Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 29195 packages read Removed 2301 duplicate packages from available set Processing dependencies... ronn-0.7.3-2.noarch marks ruby-ronn-0.7.3-2.noarch (cap ruby-ronn = 0.7.3-2) ruby-ronn-0.7.3-2.noarch marks ruby-hpricot-0.8.6-6.i686 (cap ruby-hpricot) ruby-ronn-0.7.3-2.noarch marks ruby-rdiscount-2.2.0.1-3.i686 (cap ruby-rdiscount) There are 4 packages to install (3 marked by dependencies): I ronn-0.7.3-2.noarch D ruby-hpricot-0.8.6-6.i686 ruby-rdiscount-2.2.0.1-3.i686 D ruby-ronn-0.7.3-2.noarch This operation will use 359.2KB of disk space. Need to get 139.1KB of archives. Executing pm-command.sh --upgrade -vh --root / --define _check_dirname_deps 1... Preparing... ################################################## ruby-rdiscount ################################################## ruby-hpricot ################################################## ruby-ronn ################################################## ronn ################################################## building RPM using: set -ex; : build-id: 0e1f51be-ee69-4157-839f-32834e9c4a70; TMPDIR=/tmp/B.y_5z3g/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.y_5z3g' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux /tmp/B.y_5z3g/elektra.spec + : build-id: 0e1f51be-ee69-4157-839f-32834e9c4a70 + TMPDIR=/tmp/B.y_5z3g/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.y_5z3g' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux /tmp/B.y_5z3g/elektra.spec Building target platforms: i686-pld-linux Executing(%prep): /bin/sh -e /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792 + umask 022 + cd /tmp/B.y_5z3g/BUILD + cd /tmp/B.y_5z3g/BUILD + rm -rf elektra-0.8.19 + /usr/bin/gzip -dc /tmp/B.y_5z3g/elektra-0.8.19.tar.gz + /bin/tar -xf - + STATUS=0 + '[' 0 -ne 0 ']' + cd elektra-0.8.19 + /bin/id -u + '[' 1001 '=' 0 ']' + /bin/id -u + '[' 1001 '=' 0 ']' + /bin/chmod -Rf a+rX,u+w,g-w,o-w . + echo 'Patch #0 (elektra-zsh.patch):' Patch #0 (elektra-zsh.patch): + '[' -f /tmp/B.y_5z3g/elektra-zsh.patch ']' + /bin/cat /tmp/B.y_5z3g/elektra-zsh.patch + /usr/bin/patch -s -p1 + echo 'Patch #1 (elektra-no-markdown.patch):' Patch #1 (elektra-no-markdown.patch): + '[' -f /tmp/B.y_5z3g/elektra-no-markdown.patch ']' + /bin/cat /tmp/B.y_5z3g/elektra-no-markdown.patch + /usr/bin/patch -s -p1 + echo 'Patch #2 (elektra-no-deb.patch):' Patch #2 (elektra-no-deb.patch): + '[' -f /tmp/B.y_5z3g/elektra-no-deb.patch ']' + /bin/cat /tmp/B.y_5z3g/elektra-no-deb.patch + /usr/bin/patch -s -p1 + echo 'Patch #3 (cmake.patch):' Patch #3 (cmake.patch): + '[' -f /tmp/B.y_5z3g/cmake.patch ']' + /bin/cat /tmp/B.y_5z3g/cmake.patch + /usr/bin/patch -s -p1 + exit 0 Executing(%build): /bin/sh -e /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792 TMP=/home/users/builder/tmp HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/usr/local/bin:/usr/bin:/bin:/home/users/builder/bin TMPDIR=/tmp/B.y_5z3g/BUILD/tmp + umask 022 + cd /tmp/B.y_5z3g/BUILD + cd elektra-0.8.19 + install -d build + cd build + CC=i686-pld-linux-gcc CXX=i686-pld-linux-g++ CPPFLAGS= /usr/bin/cmake '-DCMAKE_VERBOSE_MAKEFILE=ON' '-DCMAKE_BUILD_TYPE=PLD' '-DCMAKE_INSTALL_BINDIR:PATH=/usr/bin' '-DCMAKE_INSTALL_SBINDIR:PATH=/usr/sbin' '-DCMAKE_INSTALL_LIBEXECDIR:PATH=/usr/libexec' '-DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc' '-DCMAKE_INSTALL_SHAREDSTATEDIRPATH:PATH=/var/lib' '-DCMAKE_INSTALL_LOCALSTATEDIRPATH:PATH=/var' '-DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib' '-DCMAKE_INSTALL_INCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_OLDINCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share' '-DCMAKE_INSTALL_DATADIR:PATH=/usr/share' '-DCMAKE_INSTALL_INFODIR:PATH=/usr/share/info' '-DCMAKE_INSTALL_LOCALEDIR:PATH=/usr/share/locale' '-DCMAKE_INSTALL_MANDIR:PATH=/usr/share/man' '-DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/doc' '-DCMAKE_INSTALL_PREFIX:PATH=/usr' '-DSYSCONF_INSTALL_DIR:PATH=/etc' '-DCMAKE_CXX_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_C_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_Fortran_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_EXE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_SHARED_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_MODULE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DBUILD_SHARED_LIBS:BOOL=ON' .. '-DBINDINGS=INTERCEPT;cpp;glib;gi_lua;gi_python;jna;swig_lua;swig_python2;swig_python;swig_ruby' '-DBUILD_FULL=OFF' '-DINSTALL_TESTING=FALSE' '-DPLUGINS=ALL' '-DTARGET_CMAKE_FOLDER=/usr/share/cmake/Modules' '-DTOOLS=kdb;race;qt-gui' '-DBUILD_STATIC=ON' -- The C compiler identification is GNU 7.3.0 -- The CXX compiler identification is GNU 7.3.0 -- Check for working C compiler: /usr/bin/i686-pld-linux-gcc -- Check for working C compiler: /usr/bin/i686-pld-linux-gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/i686-pld-linux-g++ -- Check for working CXX compiler: /usr/bin/i686-pld-linux-g++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done CMake Deprecation Warning at CMakeLists.txt:16 (cmake_policy): The OLD behavior for policy CMP0026 will be removed from a future version of CMake. The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD. -- Performing Test HAS_CXX_STD -- Performing Test HAS_CXX_STD - Success -- Performing Test LD_ACCEPTS_VERSION_SCRIPT -- Performing Test LD_ACCEPTS_VERSION_SCRIPT - Success -- GCC detected -- Performing Test HAS_CFLAG_MAYBE_UNINITIALIZED -- Performing Test HAS_CFLAG_MAYBE_UNINITIALIZED - Success -- C flags are -std=gnu99 -Wno-deprecated-declarations -Wno-long-long -pedantic -Wno-variadic-macros -Wall -Wextra -Wno-overlength-strings -Wsign-compare -Wfloat-equal -Wformat-security -Wshadow -Wcomments -Wtrigraphs -Wundef -Wuninitialized -Winit-self -Wmaybe-uninitialized -Wsign-compare -Wfloat-equal -Wformat-security -- CXX flags are -std=c++11 -Wno-deprecated-declarations -Wold-style-cast -Wstrict-null-sentinel -D_GLIBCXX_USE_NANOSLEEP -Wno-missing-field-initializers -Woverloaded-virtual -Wsign-promo -Wno-long-long -pedantic -Wno-variadic-macros -Wall -Wextra -Wno-overlength-strings -Wsign-compare -Wfloat-equal -Wformat-security -Wshadow -Wcomments -Wtrigraphs -Wundef -Wuninitialized -Winit-self -Wmaybe-uninitialized -- You are building Elektra 0.8.19 -- Detected PLD3.0-i686. Use make package to build packages (TBZ2). -- Found Doxygen: /usr/bin/doxygen (found version "1.8.8") found components: doxygen dot -- Found Perl: /usr/bin/perl (found version "5.26.2") -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.2") -- Looking for pthread.h -- Looking for pthread.h - found -- Looking for pthread_create -- Looking for pthread_create - not found -- Looking for pthread_create in pthreads -- Looking for pthread_create in pthreads - not found -- Looking for pthread_create in pthread -- Looking for pthread_create in pthread - found -- Found Threads: TRUE -- Looking for __GNU_LIBRARY__ -- Looking for __GNU_LIBRARY__ - found -- Found augeas: /usr/lib/libaugeas.so -- Found LibXml2: /usr/lib/libxml2.so (found version "2.9.8") -- Include Plugin augeas -- Include Plugin base64 -- Include Plugin blockresolver -- Include Plugin boolean -- Include Plugin c -- Include Plugin cachefilter -- Include Plugin ccode -- Include Plugin conditionals -- Include Plugin constants -- Include Plugin counter -- Checking for one of the modules 'openssl' -- Found libgcrypt: -lgcrypt -lgpg-error -- Checking for one of the modules 'botan-1.10;botan-1.9;botan-1.8;botan' -- Exclude Plugin crypto_botan because botan development files not found -- Include Plugin crypto_gcrypt -- Include Plugin crypto_openssl -- Include Plugin csvstorage -- Found CURL: /usr/lib/libcurl.so (found version "7.60.0") -- Include Plugin curlget -- Found D-Bus: /usr/lib/libdbus-1.so -- Include Plugin dbus -- Include Plugin desktop -- Include Plugin doc -- Include Plugin dpkg -- Include Plugin dump -- Include Plugin enum -- Include Plugin error -- Include Plugin fcrypt -- Looking for iconv -- Looking for iconv - found -- Found iconv library: -- Include Plugin filecheck -- Include Plugin fstab -- Found LibGit2: /usr/lib/libgit2.so -- Include Plugin gitresolver -- Include Plugin glob -- Include Plugin hexcode -- Include Plugin hidden -- Include Plugin hosts -- Include Plugin iconv -- Include Plugin ini -- Include Plugin iterate -- Found JNI: /usr/lib/jvm/java/jre/lib/i386/libjawt.so -- Looking for JNI_VERSION_1_8 -- Looking for JNI_VERSION_1_8 - found -- Include Plugin jni -- Found systemd-journal: /lib/libsystemd.so -- Include Plugin journald -- Include Plugin keytometa -- Include Plugin line -- Include Plugin lineendings -- Include Plugin list -- Include Plugin logchange CMake Warning at cmake/Modules/FindLua.cmake:131 (message): Lua executable not found Call Stack (most recent call first): cmake/Modules/FindLua.cmake:201 (verify_lua_executable_version) src/plugins/lua/CMakeLists.txt:3 (find_package) -- Found Lua: /usr/lib/liblua5.3.so;/usr/lib/libm.so (found suitable version "5.3.4", minimum required is "5.1") -- Found SWIG: /usr/bin/swig (found suitable version "3.0.12", minimum required is "3") -- Include Plugin lua -- Include Plugin mathcheck -- Include Plugin mozprefs -- Include Plugin network -- Include Plugin ni -- Include Plugin noresolver -- Include Plugin null -- Include Plugin passwd -- Include Plugin path -- Include Plugin profile -- Found PythonLibs: /usr/lib/libpython3.6m.so (found suitable version "3.6.5", minimum required is "3") -- Include Plugin python -- Found Python2Libs: /usr/lib/libpython2.7.so (found suitable version "2.7.15", minimum required is "2.7") -- Include Plugin python2 -- Include Plugin regexstore -- Include Plugin rename -- Include Plugin required -- Include Plugin resolver_fm_hpu_b -- Include Plugin resolver_fm_b_b -- Include Plugin resolver_fm_pb_b -- Include Plugin resolver_fm_hb_b -- Include Plugin resolver_fm_hp_b -- Include Plugin resolver_fm_ub_x -- Include Plugin resolver_fm_xb_x -- Include Plugin resolver_fm_xp_x -- Include Plugin resolver_fm_xhp_x -- Include Plugin resolver_fm_uhb_xb -- Include Plugin semlock -- Include Plugin shell -- Include Plugin simpleini -- Include Plugin simplespeclang -- Include Plugin spec -- Include Plugin struct -- Include Plugin sync -- Include Plugin syslog -- Boost version: 1.63.0 -- Include Plugin tcl -- Include Plugin template -- Include Plugin timeofday -- Include Plugin tracer -- Include Plugin type -- Include Plugin uname -- Include Plugin validation -- Include Plugin wresolver -- Include Plugin xmltool -- Found Yajl: /usr/lib/libyajl.so -- Include Plugin yajl -- Include Binding cpp -- Include Binding jna -- Found Java: /usr/lib/jvm/java/bin/java (found version "1.8.0_171") -- Found Python2Interp: /usr/bin/python2.7 (found suitable version "2.7.15", minimum required is "2.7") -- Include Binding swig_python2 CMake Deprecation Warning at /usr/share/cmake/Modules/UseSWIG.cmake:231 (message): SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead. Call Stack (most recent call first): src/bindings/swig/python2/CMakeLists.txt:34 (swig_add_module) -- Found PythonInterp: /usr/bin/python3 (found suitable version "3.6.5", minimum required is "3") -- Include Binding swig_python CMake Deprecation Warning at /usr/share/cmake/Modules/UseSWIG.cmake:231 (message): SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead. Call Stack (most recent call first): src/bindings/swig/python/CMakeLists.txt:33 (swig_add_module) CMake Warning at cmake/Modules/FindLua.cmake:131 (message): Lua executable not found Call Stack (most recent call first): cmake/Modules/FindLua.cmake:201 (verify_lua_executable_version) src/bindings/swig/lua/CMakeLists.txt:4 (find_package) -- Include Binding swig_lua CMake Deprecation Warning at /usr/share/cmake/Modules/UseSWIG.cmake:231 (message): SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead. Call Stack (most recent call first): src/bindings/swig/lua/CMakeLists.txt:22 (swig_add_module) CMake Warning at src/bindings/swig/lua/CMakeLists.txt:40 (message): Lua interpreter does not match Lua libraries version, needed for SWIG Lua bindings tests. Tests will not be executed. -- Found Ruby: /usr/bin/ruby (found version "2.4.4") -- Include Binding swig_ruby CMake Deprecation Warning at /usr/share/cmake/Modules/UseSWIG.cmake:231 (message): SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead. Call Stack (most recent call first): src/bindings/swig/ruby/CMakeLists.txt:56 (swig_add_module) -- Checking for module 'gobject-2.0>=2.36' -- Found gobject-2.0, version 2.56.1 -- Include Binding glib -- Checking for module 'gobject-introspection-1.0>=1.38' -- Found gobject-introspection-1.0, version 1.56.1 -- Include Binding gi_python CMake Deprecation Warning at src/bindings/gi/python/CMakeLists.txt:32 (message): GI bindings have been deprecated CMake Warning at cmake/Modules/FindLua.cmake:131 (message): Lua executable not found Call Stack (most recent call first): cmake/Modules/FindLua.cmake:201 (verify_lua_executable_version) src/bindings/gi/lua/CMakeLists.txt:33 (find_package) -- Exclude Binding gi_lua because Lua interpreter does not match Lua libraries version, needed for GObject Introspection Lua installation -- Include Binding intercept_fs -- Include Binding intercept_env -- Include Tool kdb -- Include Tool race -- Found LibRt: /usr/lib/librt.so -- Include Tool qt-gui CMake Warning (dev) at /usr/lib/cmake/Qt5/Qt5ModuleLocation.cmake:4 (set): Policy CMP0053 is not set: Simplify variable reference and escape sequence evaluation. Run "cmake --help-policy CMP0053" for policy details. Use the cmake_policy command to set the policy and suppress this warning. For input: '${_qt5_install_prefix}/Qt5@module@/Qt5@module@Config.cmake' the old evaluation rules produce: '/usr/lib/cmake/Qt5/Qt5Config.cmake' but the new evaluation rules produce: '/usr/lib/cmake/Qt5@module@/Qt5@module@Config.cmake' Using the old result for compatibility since the policy is not set. Call Stack (most recent call first): /usr/lib/cmake/Qt5/Qt5Config.cmake:25 (include) src/tools/qt-gui/CMakeLists.txt:7 (find_package) This warning is for project developers. Use -Wno-dev to suppress it. -- Looking for clearenv -- Looking for clearenv - found -- Looking for setenv -- Looking for setenv - found -- Looking for futimens -- Looking for futimens - found -- Looking for futimes -- Looking for futimes - found -- Looking for glob -- Looking for glob - found -- Looking for clock_gettime -- Looking for clock_gettime - found -- Looking for ctype.h -- Looking for ctype.h - found -- Looking for errno.h -- Looking for errno.h - found -- Looking for locale.h -- Looking for locale.h - found -- Looking for stdio.h -- Looking for stdio.h - found -- Looking for stdlib.h -- Looking for stdlib.h - found -- Looking for string.h -- Looking for string.h - found -- Looking for time.h -- Looking for time.h - found -- Looking for unistd.h -- Looking for unistd.h - found -- Looking for sys/types.h -- Looking for sys/types.h - found -- Looking for stdint.h -- Looking for stdint.h - found -- Looking for stddef.h -- Looking for stddef.h - found -- Check size of int -- Check size of int - done -- Check size of long -- Check size of long - done -- Check size of long long -- Check size of long long - done -- Check size of long double -- Check size of long double - done -- Check size of mode_t -- Check size of mode_t - done -- Check size of ((struct timeval*)0)->tv_usec -- Check size of ((struct timeval*)0)->tv_usec - done CMake Error at cmake/Modules/LibAddPlugin.cmake:185 (message): Internally inconsistency, plugin elektra-augeas got different values for variable ARG_LINK_LIBRARIES: '/usr/lib/libaugeas.so' != '/usr/lib/libaugeas.so;/usr/lib/libxml2.so' Call Stack (most recent call first): cmake/Modules/LibAddPlugin.cmake:241 (restore_variable) src/plugins/augeas/CMakeLists.txt:22 (add_plugin) src/plugins/CMakeLists.txt:14 (include) -- Configuring incomplete, errors occurred! See also "/tmp/B.y_5z3g/BUILD/elektra-0.8.19/build/CMakeFiles/CMakeOutput.log". See also "/tmp/B.y_5z3g/BUILD/elektra-0.8.19/build/CMakeFiles/CMakeError.log". error: Bad exit status from /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792 (%build) RPM build errors: Bad exit status from /tmp/B.y_5z3g/BUILD/tmp/rpm-tmp.82792 (%build) ended at: Tue Jun 5 08:46:46 2018, done in 0:00:09.203340 error: No files produced. + chmod -R u+rwX /tmp/B.y_5z3g/BUILD + rm -rf /tmp/B.y_5z3g/tmp /tmp/B.y_5z3g/BUILD + rm -rf /tmp/B.y_5z3g Begin-PLD-Builder-Info Build-Time: user:15.97s sys:3.35s real:29.26s (faults io:2 non-io:775453) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]