FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2018 PLD Team
$Revision: 1.37 $
Powered by /dev/null.
Your IP: 54.225.26.44

ruby-gnome2 aaa0541a-1a9d-439f-8725-a25c8daa659a

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/th/i686/FAIL/ruby-gnome2,aaa0541a-1a9d-439f-8725-a25c8daa659a.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2018/06/03 10:01:17

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • poldek: error: ruby-pkg-config-1.2.8-2.noarch: req ruby(abi) = 2.3 not found
  • error 3
  • poldek: error: ruby-rcairo-devel-1.15.10-1.i686: req /usr/include/ruby-2.3 not found
  • error 4
  • poldek: error: ruby-rcairo-1.15.10-1.i686: req /usr/lib/ruby/vendor_ruby/2.3 not found
  • error 5
  • poldek: error: ruby-rcairo-1.15.10-1.i686: req libruby.so.2.3 not found
  • error 6
  • poldek: error: ruby-rcairo-1.15.10-1.i686: req ruby(abi) = 2.3 not found
  • error 7
  • poldek: error: 5 unresolved dependencies
  • error 8
  • poldek: error: Failed dependencies:
  • error 9
  • error: ruby-rcairo-devel: no such package
  • error 10
  • error: ruby-rcairo: no such package
  • error 11
  • error: ruby-pkg-config: no such package
  • error 12
  • rpm: error: Failed build dependencies:
  • error 13
  • error: ruby-pkg-config-1.2.8-2.noarch: req ruby(abi) = 2.3 not found
  • error 14
  • error: ruby-rcairo-devel-1.15.10-1.i686: req /usr/include/ruby-2.3 not found
  • error 15
  • error: ruby-rcairo-1.15.10-1.i686: req /usr/lib/ruby/vendor_ruby/2.3 not found
  • error 16
  • error: ruby-rcairo-1.15.10-1.i686: req libruby.so.2.3 not found
  • error 17
  • error: ruby-rcairo-1.15.10-1.i686: req ruby(abi) = 2.3 not found
  • error 18
  • error: 5 unresolved dependencies
  • error 19
  • error: BR installation failed

Content:

checking if we should skip the build
started at: Sun Jun  3 10:01:01 2018
killing old processes on a builder
sending signal 9 to pid -1
Killed
fetching https://srcbuilder.pld-linux.org/th//srpms/aaa0541a-1a9d-439f-8725-a25c8daa659a/ruby-gnome2-3.1.9-2.src.rpm
fetched 2216757 bytes, 3341.3 K/s
installing srpm: ruby-gnome2-3.1.9-2.src.rpm
+ install -d /tmp/B.KWkSLd/BUILD /tmp/B.KWkSLd/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog ruby-gnome2-3.1.9-2.src.rpm
* Sun Jun 03 2018 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/ruby-gnome2.git;a=log;h=master
* Sun Nov 12 2017 Jan Rękorajski <baggins@pld-linux.org> f9a1953
- fix internal deps - rel 2 * Sat Nov 11 2017 Jan Rękorajski <baggins@pld-linux.org> 38627fa
- don't try to install rpms at build time - fix missing require in build scripts - updated packages and files - rel 1 * Thu Nov 09 2017 Jan Rękorajski <baggins@pld-linux.org> 026a91e
- update package list * Thu Nov 09 2017 Jan Rękorajski <baggins@pld-linux.org> cf7b474
- fetch 3.1.9 sources * Wed Oct 25 2017 Jan Rękorajski <baggins@pld-linux.org> 56cf2f9
- rebuild with ruby 2.3 - release 4 (by relup.sh) + rpm -Uhv --nodeps --define '_topdir /tmp/B.KWkSLd' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' ruby-gnome2-3.1.9-2.src.rpm Preparing... ################################################## ruby-gnome2 ################################################## + rm -f ruby-gnome2-3.1.9-2.src.rpm + install -m 700 -d /tmp/B.KWkSLd/BUILD/tmp + TMPDIR=/tmp/B.KWkSLd/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.KWkSLd' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux --define 'prep exit 0' /tmp/B.KWkSLd/ruby-gnome2.spec Building target platforms: i686-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: ruby-pkg-config is needed by ruby-gnome2-3.1.9-2.src rpm: ruby-rcairo-devel is needed by ruby-gnome2-3.1.9-2.src rpm: Building target platforms: i686-pld-linux updating poldek cache... ready is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-test::packages.ndir.md... th-test is up to date Retrieving th-test::packages.ndir.md... th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 28500 packages read poldek: Removed 1646 duplicate packages from available set poldek: Processing dependencies... poldek: error: ruby-pkg-config-1.2.8-2.noarch: req ruby(abi) = 2.3 not found poldek: error: ruby-rcairo-devel-1.15.10-1.i686: req /usr/include/ruby-2.3 not found poldek: ruby-rcairo-devel-1.15.10-1.i686 marks ruby-rcairo-1.15.10-1.i686 (cap ruby-rcairo = 1.15.10-1) poldek: error: ruby-rcairo-1.15.10-1.i686: req /usr/lib/ruby/vendor_ruby/2.3 not found poldek: error: ruby-rcairo-1.15.10-1.i686: req libruby.so.2.3 not found poldek: error: ruby-rcairo-1.15.10-1.i686: req ruby(abi) = 2.3 not found poldek: There are 3 packages to install (1 marked by dependencies): poldek: I ruby-pkg-config-1.2.8-2.noarch ruby-rcairo-devel-1.15.10-1.i686 poldek: D ruby-rcairo-1.15.10-1.i686 poldek: This operation will use 314.0KB of disk space. poldek: Need to get 99.8KB of archives (99.8KB to download). poldek: poldek: error: 5 unresolved dependencies poldek: Retrieving [1/3] th::ruby-pkg-config-1.2.8-2.noarch.rpm... poldek: ..............................done poldek: Retrieving [2/3] th::ruby-rcairo-1.15.10-1.i686.rpm... poldek: ..............................done poldek: Retrieving [3/3] th::ruby-rcairo-devel-1.15.10-1.i686.rpm... poldek: ..............................done poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: error: Failed dependencies: poldek: ruby(abi) = 2.3 is needed by ruby-pkg-config-1.2.8-2.noarch poldek: libruby.so.2.3 is needed by ruby-rcairo-1.15.10-1.i686 poldek: ruby(abi) = 2.3 is needed by ruby-rcairo-1.15.10-1.i686 poldek: /usr/lib/ruby/vendor_ruby/2.3 is needed by ruby-rcairo-1.15.10-1.i686 poldek: /usr/include/ruby-2.3 is needed by ruby-rcairo-devel-1.15.10-1.i686 uninstalling conflicting packages removing ruby-rcairo-devel error: ruby-rcairo-devel: no such package package ruby-rcairo-devel removal failed removing ruby-rcairo error: ruby-rcairo: no such package package ruby-rcairo removal failed removing ruby-pkg-config error: ruby-pkg-config: no such package package ruby-pkg-config removal failed checking BR rpm: error: Failed build dependencies: rpm: ruby-pkg-config is needed by ruby-gnome2-3.1.9-2.src rpm: ruby-rcairo-devel is needed by ruby-gnome2-3.1.9-2.src rpm: Building target platforms: i686-pld-linux installing BR: ruby\-rcairo\-devel ruby\-pkg\-config + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' --upgrade ruby-rcairo-devel ruby-pkg-config Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 28500 packages read Removed 1646 duplicate packages from available set Processing dependencies... error: ruby-pkg-config-1.2.8-2.noarch: req ruby(abi) = 2.3 not found error: ruby-rcairo-devel-1.15.10-1.i686: req /usr/include/ruby-2.3 not found ruby-rcairo-devel-1.15.10-1.i686 marks ruby-rcairo-1.15.10-1.i686 (cap ruby-rcairo = 1.15.10-1) error: ruby-rcairo-1.15.10-1.i686: req /usr/lib/ruby/vendor_ruby/2.3 not found error: ruby-rcairo-1.15.10-1.i686: req libruby.so.2.3 not found error: ruby-rcairo-1.15.10-1.i686: req ruby(abi) = 2.3 not found There are 3 packages to install (1 marked by dependencies): I ruby-pkg-config-1.2.8-2.noarch ruby-rcairo-devel-1.15.10-1.i686 D ruby-rcairo-1.15.10-1.i686 This operation will use 314.0KB of disk space. Need to get 99.8KB of archives. error: 5 unresolved dependencies error: BR installation failed + chmod -R u+rwX /tmp/B.KWkSLd/BUILD + rm -rf /tmp/B.KWkSLd/tmp /tmp/B.KWkSLd/BUILD + rm -rf /tmp/B.KWkSLd Begin-PLD-Builder-Info Build-Time: user:8.09s sys:1.17s real:16.11s (faults io:0 non-io:257877) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]