FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2018 PLD Team
$Revision: 1.37 $
Powered by sqlite3.
Your IP: 54.80.58.121

imapsync b330cb01-5c04-4739-b821-ea8b7eb2f8ea

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/th/x32/FAIL/imapsync,b330cb01-5c04-4739-b821-ea8b7eb2f8ea.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2018/07/10 10:12:08
Runtime:0:00:05.250398

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.10802
  • build
  • Executing(%build): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.65076
  • install
  • Executing(%install): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.86821
  • error 3
  • error: Bad exit status from /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.86821 (%install)
  • error 4
  • RPM build errors:
  • error 5
  • error: No files produced.

Content:

checking if we should skip the build
started at: Tue Jul 10 10:11:36 2018
killing old processes on a builder
sending signal 9 to pid -1
Killed
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/b330cb01-5c04-4739-b821-ea8b7eb2f8ea/imapsync-1.882-1.src.rpm
fetched 1563189 bytes, 2490.8 K/s
installing srpm: imapsync-1.882-1.src.rpm
+ install -d /tmp/B.gfKv4a/BUILD /tmp/B.gfKv4a/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog imapsync-1.882-1.src.rpm
* Tue Jul 10 2018 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/imapsync.git;a=log;h=auto/th/imapsync-1.882-1
* Tue Jul 10 2018 Arkadiusz Miƛkiewicz <arekm@maven.pl> 067e0ba
- up to 1.882 + rpm -Uhv --nodeps --define '_topdir /tmp/B.gfKv4a' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' imapsync-1.882-1.src.rpm Preparing... ################################################## imapsync ################################################## + rm -f imapsync-1.882-1.src.rpm + install -m 700 -d /tmp/B.gfKv4a/BUILD/tmp + TMPDIR=/tmp/B.gfKv4a/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.gfKv4a' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux --define 'prep exit 0' /tmp/B.gfKv4a/imapsync.spec Building target platforms: x32-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: cpanminus is needed by imapsync-1.882-1.src rpm: perl-Data-Uniqid is needed by imapsync-1.882-1.src rpm: perl-IO-Tee is needed by imapsync-1.882-1.src rpm: perl-PAR-Packer is needed by imapsync-1.882-1.src rpm: perl-Sys-MemInfo is needed by imapsync-1.882-1.src rpm: perl-Test-MockObject is needed by imapsync-1.882-1.src rpm: Building target platforms: x32-pld-linux updating poldek cache... ready is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-test::packages.ndir.md... th-test is up to date Retrieving th-test::packages.ndir.md... Retrieving th-test::packages.ndir.diff.toc.gz... Retrieving diff::packages.ndir.2018.07.10-07.43.01.gz... Retrieving diff::packages.ndir.dscr.2018.07.10-07.43.01.gz... Loading [pndir]th-test... Applying packages.ndir.2018.07.10-07.43.01.gz... Writing /root/tmp/poldek-cache-root/[...]/packages.ndir.gz... checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 28675 packages read poldek: Removed 5294 duplicate packages from available set poldek: Processing dependencies... poldek: cpanminus-1.7040-1.noarch marks perl-CPAN-DistnameInfo-0.12-1.noarch (cap perl-CPAN-DistnameInfo) poldek: cpanminus-1.7040-1.noarch marks perl-Parse-PMFile-0.36-1.noarch (cap perl-Parse-PMFile) poldek: cpanminus-1.7040-1.noarch marks perl-local-lib-1.008004-1.noarch (cap perl-local-lib) poldek: perl-PAR-Packer-1.045-1.x32 marks perl-Getopt-ArgvFile-1.11-1.noarch (cap perl(Getopt::ArgvFile)) poldek: perl-Test-MockObject-1.09-1.noarch marks perl-UNIVERSAL-can-1.15-1.noarch (cap perl(UNIVERSAL::can)) poldek: perl-Test-MockObject-1.09-1.noarch marks perl-UNIVERSAL-isa-1.03-1.noarch (cap perl(UNIVERSAL::isa)) poldek: There are 12 packages to install (6 marked by dependencies): poldek: I cpanminus-1.7040-1.noarch perl-Data-Uniqid-0.12-1.noarch poldek: I perl-IO-Tee-0.64-9.noarch perl-PAR-Packer-1.045-1.x32 poldek: I perl-Sys-MemInfo-0.99-1.x32 perl-Test-MockObject-1.09-1.noarch poldek: D perl-CPAN-DistnameInfo-0.12-1.noarch perl-Getopt-ArgvFile-1.11-1.noarch poldek: D perl-Parse-PMFile-0.36-1.noarch perl-UNIVERSAL-can-1.15-1.noarch poldek: D perl-UNIVERSAL-isa-1.03-1.noarch perl-local-lib-1.008004-1.noarch poldek: This operation will use 13.4MB of disk space. poldek: Need to get 4.8MB of archives (246.1KB to download). poldek: poldek: Retrieving [1/9] th::perl-CPAN-DistnameInfo-0.12-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [2/9] th::perl-Parse-PMFile-0.36-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [3/9] th::perl-local-lib-1.008004-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [4/9] th::cpanminus-1.7040-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [5/9] th::perl-Getopt-ArgvFile-1.11-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [6/9] th::perl-IO-Tee-0.64-9.noarch.rpm... poldek: ..............................done poldek: Retrieving [7/9] th::perl-UNIVERSAL-can-1.15-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [8/9] th::perl-UNIVERSAL-isa-1.03-1.noarch.rpm... poldek: ..............................done poldek: Retrieving [9/9] th::perl-Test-MockObject-1.09-1.noarch.rpm... poldek: ..............................done poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: Preparing... ################################################## no conflicts found checking BR rpm: error: Failed build dependencies: rpm: cpanminus is needed by imapsync-1.882-1.src rpm: perl-Data-Uniqid is needed by imapsync-1.882-1.src rpm: perl-IO-Tee is needed by imapsync-1.882-1.src rpm: perl-PAR-Packer is needed by imapsync-1.882-1.src rpm: perl-Sys-MemInfo is needed by imapsync-1.882-1.src rpm: perl-Test-MockObject is needed by imapsync-1.882-1.src rpm: Building target platforms: x32-pld-linux installing BR: cpanminus perl\-IO\-Tee perl\-Sys\-MemInfo perl\-Test\-MockObject perl\-PAR\-Packer perl\-Data\-Uniqid + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' --upgrade cpanminus perl-IO-Tee perl-Sys-MemInfo perl-Test-MockObject perl-PAR-Packer perl-Data-Uniqid Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 28675 packages read Removed 5294 duplicate packages from available set Processing dependencies... cpanminus-1.7040-1.noarch marks perl-CPAN-DistnameInfo-0.12-1.noarch (cap perl-CPAN-DistnameInfo) cpanminus-1.7040-1.noarch marks perl-Parse-PMFile-0.36-1.noarch (cap perl-Parse-PMFile) cpanminus-1.7040-1.noarch marks perl-local-lib-1.008004-1.noarch (cap perl-local-lib) There are 4 packages to install (3 marked by dependencies): I cpanminus-1.7040-1.noarch D perl-CPAN-DistnameInfo-0.12-1.noarch perl-Parse-PMFile-0.36-1.noarch D perl-local-lib-1.008004-1.noarch This operation will use 256.8KB of disk space. Need to get 155.9KB of archives. Executing pm-command.sh --upgrade -vh --root / --define _check_dirname_deps 1... Preparing... ################################################## cpanminus ################################################## perl-CPAN-DistnameInfo ################################################## perl-Parse-PMFile ################################################## perl-local-lib ################################################## Installing set #2 Processing dependencies... perl-PAR-Packer-1.045-1.x32 marks perl-Getopt-ArgvFile-1.11-1.noarch (cap perl(Getopt::ArgvFile)) perl-Test-MockObject-1.09-1.noarch marks perl-UNIVERSAL-can-1.15-1.noarch (cap perl(UNIVERSAL::can)) perl-Test-MockObject-1.09-1.noarch marks perl-UNIVERSAL-isa-1.03-1.noarch (cap perl(UNIVERSAL::isa)) There are 8 packages to install (3 marked by dependencies): I perl-Data-Uniqid-0.12-1.noarch perl-IO-Tee-0.64-9.noarch I perl-PAR-Packer-1.045-1.x32 perl-Sys-MemInfo-0.99-1.x32 I perl-Test-MockObject-1.09-1.noarch D perl-Getopt-ArgvFile-1.11-1.noarch perl-UNIVERSAL-can-1.15-1.noarch D perl-UNIVERSAL-isa-1.03-1.noarch This operation will use 13.2MB of disk space. Need to get 4.7MB of archives. Executing pm-command.sh --upgrade -vh --root / --define _check_dirname_deps 1... Preparing... ################################################## perl-UNIVERSAL-isa ################################################## perl-UNIVERSAL-can ################################################## perl-Getopt-ArgvFile ################################################## perl-Data-Uniqid ################################################## perl-IO-Tee ################################################## perl-PAR-Packer ################################################## perl-Sys-MemInfo ################################################## perl-Test-MockObject ################################################## building RPM using: set -ex; : build-id: b330cb01-5c04-4739-b821-ea8b7eb2f8ea; TMPDIR=/tmp/B.gfKv4a/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.gfKv4a' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux /tmp/B.gfKv4a/imapsync.spec + : build-id: b330cb01-5c04-4739-b821-ea8b7eb2f8ea + TMPDIR=/tmp/B.gfKv4a/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.gfKv4a' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux /tmp/B.gfKv4a/imapsync.spec Building target platforms: x32-pld-linux Executing(%prep): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.10802 + umask 022 + cd /tmp/B.gfKv4a/BUILD + cd /tmp/B.gfKv4a/BUILD + rm -rf imapsync-imapsync-1.882 + /usr/bin/gzip -dc /tmp/B.gfKv4a/imapsync-1.882.tar.gz + /bin/tar -xf - + STATUS=0 + '[' 0 -ne 0 ']' + cd imapsync-imapsync-1.882 + /bin/id -u + '[' 1000 '=' 0 ']' + /bin/id -u + '[' 1000 '=' 0 ']' + /bin/chmod -Rf a+rX,u+w,g-w,o-w . + exit 0 Executing(%build): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.65076 HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/usr/local/bin:/usr/bin:/bin TMPDIR=/tmp/B.gfKv4a/BUILD/tmp + umask 022 + cd /tmp/B.gfKv4a/BUILD + cd imapsync-imapsync-1.882 + /usr/bin/make -Otarget -j9 this is imapsync 1.882, You can do : make testp # it shows needed Perl modules from your distro or CPAN make install # as root All other goals are for the upstream developper make testf # run tests make testv # run tests verbosely make test_quick # few tests verbosely make W/test.bat # run --tests and W/test.bat on win32 make W/test_tests.bat # run --tests on win32 make W/test_testsdebug.bat # run --testsdebug on win32 make W/test2.bat # run W/test2.bat on win32 make W/test3.bat # run W/test3.bat on win32 make W/test_reg.bat # run W/test_reg.bat on win32 make W/test_exe.bat # run W/test_exe.bat on win32 make W/test_exe_tests.bat # run W/test_exe_tests.bat on win32 make W/test_exe_2.bat # run W/test_exe_2.bat on win32 make examples/sync_loop_windows.bat # run examples/sync_loop_windows.bat on win32 make win32_prereq # run W/install_modules.bat on win32 make win32_update_ssl # run W/install_module_ssl.bat on win32 make all make upload_tests # upload tests.sh make upload_index make upload_FAQ # upload FAQs and documentation make upload_X # upload online UI make upload_latest # upload latest imapsync and binaries (dev) make upload_cgi # upload latest imapsync online, after local and remote --tests success. make valid_index # check index.shtml for good syntax make upload_ks make imapsync.exe make bin # build mac & win & linux binaries make mac # build mac binary make win # build win binary make lin # build linux binary make publish make crit # run perlcritic on imapsync make prereq # Generates W/prereq.* make cl # Check links of index.shtml make cle # Check links of S/*.shtml make mactestsdebug # run ./imapsync --testsdebug on Mac make mactests # run ./imapsync --tests on Mac make mactestslive # run ./imapsync --testslive on Mac make ks2testsdebug # run ./imapsync --testsdebug on ks2 make ks2tests # run ./imapsync --tests on ks2 make ks2testslive # run ./imapsync --testslive on ks2 + exit 0 Executing(%install): /bin/sh -e /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.86821 HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/usr/local/bin:/usr/bin:/bin TMPDIR=/tmp/B.gfKv4a/BUILD/tmp + umask 022 + cd /tmp/B.gfKv4a/BUILD + /bin/rm '--interactive=never' -rf /tmp/B.gfKv4a/BUILD/tmp/imapsync-1.882-root-builder + /bin/mkdir -p /tmp/B.gfKv4a/BUILD/tmp/imapsync-1.882-root-builder + cd imapsync-imapsync-1.882 + rm -rf /tmp/B.gfKv4a/BUILD/tmp/imapsync-1.882-root-builder + install -d /tmp/B.gfKv4a/BUILD/tmp/imapsync-1.882-root-builder/usr/bin + /usr/bin/make -Otarget -j9 install 'DESTDIR=/tmp/B.gfKv4a/BUILD/tmp/imapsync-1.882-root-builder' sh INSTALL.d/prerequisites_imapsync $SHELL says /bin/bash $0 gives INSTALL.d/prerequisites_imapsync ps -ef gives builder 24141 24108 0 10:12 ? 00:00:00 sh INSTALL.d/prerequisites_imapsync Distributor ID: PLD Description: PLD Linux Release: 3.0 Codename: Th Linux naiad-pld 4.9.106-1 #1 SMP Wed Jun 6 09:29:27 CEST 2018 x86_64 Intel(R)_Xeon(R)_CPU___________E5440__@_2.83GHz PLD Linux Ok: Found Perl 5.26.2 Ok: Found make GNU Make 4.2.1 Ok: Found Perl module App::cpanminus Failure: Not found Perl module Authen::NTLM Ok: Found Perl module CGI Ok: Found Perl module Compress::Zlib Ok: Found Perl module Crypt::OpenSSL::RSA Ok: Found Perl module Data::Dumper Ok: Found Perl module Data::Uniqid Ok: Found Perl module Digest::HMAC Ok: Found Perl module Digest::HMAC_MD5 Ok: Found Perl module Digest::MD5 Ok: Found Perl module Dist::CheckConflicts Ok: Found Perl module Encode::Byte Ok: Found Perl module File::Copy::Recursive Ok: Found Perl module IO::Socket::INET Ok: Found Perl module IO::Socket::INET6 Ok: Found Perl module IO::Socket::SSL Ok: Found Perl module IO::Tee Ok: Found Perl module JSON Failure: Not found Perl module JSON::WebToken Failure: Not found Perl module JSON::WebToken::Crypt::RSA Ok: Found Perl module HTML::Entities Ok: Found Perl module LWP::UserAgent Ok: Found Perl module Mail::IMAPClient Ok: Found Perl module Module::Implementation Ok: Found Perl module Module::Runtime Ok: Found Perl module Module::ScanDeps Ok: Found Perl module Net::SSLeay Ok: Found Perl module Package::Stash Ok: Found Perl module Package::Stash::XS Ok: Found Perl module PAR::Packer Ok: Found Perl module Parse::RecDescent Ok: Found Perl module Pod::Usage Ok: Found Perl module Readonly Ok: Found Perl module Regexp::Common Ok: Found Perl module Sys::MemInfo Ok: Found Perl module Term::ReadKey Ok: Found Perl module Test::Fatal Ok: Found Perl module Test::Mock::Guard Ok: Found Perl module Test::MockObject Ok: Found Perl module Test::More Ok: Found Perl module Test::Pod Ok: Found Perl module Test::Requires Ok: Found Perl module Test::NoWarnings Ok: Found Perl module Test::Deep Ok: Found Perl module Test::Warn Ok: Found Perl module Try::Tiny Ok: Found Perl module Unicode::String Ok: Found Perl module URI::Escape What you have to do before using imapsync: Install Perl module Authen::NTLM Install Perl module JSON::WebToken Install Perl module JSON::WebToken::Crypt::RSA Here is a cpanm command to install missing Perl modules: cpanm "Authen::NTLM JSON::WebToken JSON::WebToken::Crypt::RSA" make: *** [Makefile:99: testp] Error 1 error: Bad exit status from /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.86821 (%install) RPM build errors: Bad exit status from /tmp/B.gfKv4a/BUILD/tmp/rpm-tmp.86821 (%install) ended at: Tue Jul 10 10:12:08 2018, done in 0:00:05.250398 error: No files produced. + chmod -R u+rwX /tmp/B.gfKv4a/BUILD + rm -rf /tmp/B.gfKv4a/tmp /tmp/B.gfKv4a/BUILD + rm -rf /tmp/B.gfKv4a Begin-PLD-Builder-Info Build-Time: user:18.15s sys:3.54s real:32.43s (faults io:8 non-io:458941) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]