FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by DWARF.
Your IP: 34.201.11.222

perl 334e8df9-6f64-42b7-adfd-15b77038d9b4

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x32/FAIL/perl,334e8df9-6f64-42b7-adfd-15b77038d9b4.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2021/02/23 18:19:01
Runtime:0:00:01.870775

Toc:

  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.uFjTbe/BUILD/tmp/rpm-tmp.OD2PhO
  • error 1
  • error: Bad exit status from /tmp/B.uFjTbe/BUILD/tmp/rpm-tmp.OD2PhO (%prep)
  • error 2
  • RPM build errors:
  • error 3
  • error: No files produced.

Content:

request from: baggins
checking if we should skip the build
started at: Tue Feb 23 18:18:56 2021
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/334e8df9-6f64-42b7-adfd-15b77038d9b4/perl-5.32.1-1.src.rpm
fetched 12770762 bytes, 16016.9 K/s
installing srpm: perl-5.32.1-1.src.rpm
+ install -d /tmp/B.uFjTbe/BUILD /tmp/B.uFjTbe/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog perl-5.32.1-1.src.rpm
* Tue Feb 23 2021 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/perl.git;a=log;h=master
* Fri Feb 19 2021 Arkadiusz Miśkiewicz <arekm@maven.pl> a0da97f
- runperl -MCGI would include system wide perl-CGI and we don't want that. PERL5LIB doesn't override built in paths, so we try to do that on our own * Fri Feb 19 2021 Arkadiusz Miśkiewicz <arekm@maven.pl> 402c35f
- up to 5.32.1 * Thu Jun 18 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> 4fec8c2
- up to 5.30.3; SECURITY fixes * Sat May 16 2020 Jan Rękorajski <baggins@pld-linux.org> b33bbb1
- move Compress and Compress::Raw::* to base package, they are required by IO::Compress::* - rel 3 * Mon Mar 23 2020 Jan Rękorajski <baggins@pld-linux.org> 03aca3f
- don't package Memoize::NDBM_File since we don't package NDBM_File - rel 2 * Sun Mar 15 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> cf65ab6
- up to 5.30.2 * Wed Jan 22 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> 3b9a6e3
- rel 2; R: perl-Encode due to Can't locate Encode.pm in @INC (you may need to install the Encode module) (@INC contains: /usr/local/lib/perl5/5.30.0/x86_64-pld-linux-thread-multi /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl/5.30.0/x86_64-pld-linux-thread-multi /usr/share/perl5/vendor_perl /usr/lib64/perl5/5.30.1/x86_64-pld-linux-thread-multi /usr/share/perl5/5.30.1) at /usr/share/perl5/5.30.1/Pod/Text.pm line 24. * Tue Jan 07 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> a23dc14
- up to 5.30.1 * Sun Nov 10 2019 Arkadiusz Miśkiewicz <arekm@maven.pl> 5b1c93a
- Locale::Codes is gone from core perl * Sat Nov 09 2019 Arkadiusz Miśkiewicz <arekm@maven.pl> a4f3534
- up to 5.30.0 * Thu May 16 2019 Elan Ruusamäe <glen@pld-linux.org> c74f259
- up to 5.28.2 * Fri Nov 30 2018 Adam Gołębiowski <adamg@pld-linux.org> b61cd06
- updated to 5.28.1, solves CVE-2018-18311, CVE-2018-18312 * Fri Aug 31 2018 Jan Rękorajski <baggins@pld-linux.org> 11b92a7
- release 5 (by relup.sh) * Fri Aug 31 2018 Jan Rękorajski <baggins@pld-linux.org> 95537ec
- more hacks to get Getopt::Long prov version right * Fri Aug 31 2018 Jan Rękorajski <baggins@pld-linux.org> 66fcbfb
- explicitly provide Getopt::Long * Fri Aug 31 2018 Jan Rękorajski <baggins@pld-linux.org> 18376c3
- fix Getopt::Long version detection - rel 4 * Thu Aug 30 2018 Jan Rękorajski <baggins@pld-linux.org> 91c3e77
- remove GDBM_file test that is not pertinent for gdbm 1.15+ - rel 3 * Wed Jul 04 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> 216ecee
- release 2 (by relup.sh) * Mon Jun 25 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> f5b778c
- up to 5.28.0 but test suite fails * Wed May 23 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> 0483b28
- up to 5.26.2 + rpm -Uhv --nodeps --define '_topdir /tmp/B.uFjTbe' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' perl-5.32.1-1.src.rpm Updating / installing... perl-1:5.32.1-1 ######################################## + rm -f perl-5.32.1-1.src.rpm + install -m 700 -d /tmp/B.uFjTbe/BUILD/tmp + TMPDIR=/tmp/B.uFjTbe/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.uFjTbe' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux --define 'prep exit 0' /tmp/B.uFjTbe/perl.spec warning: line 337: It's not recommended to have unversioned Obsoletes: Obsoletes: sperl warning: line 382: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib-devel warning: line 397: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-pod warning: line 530: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib warning: line 665: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-Encode-compat warning: Macro expanded in comment on line 713: %version macro. This hack works around it. warning: Could not canonicalize hostname: naiad Building target platforms: x32-pld-linux Building for target x32-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: warning: line 337: It's not recommended to have unversioned Obsoletes: Obsoletes: sperl rpm: warning: line 382: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib-devel rpm: warning: line 397: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-pod rpm: warning: line 530: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib rpm: warning: line 665: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-Encode-compat rpm: warning: Macro expanded in comment on line 713: %version macro. This hack works around it. rpm: rpm: warning: Could not canonicalize hostname: naiad rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux no BR needed building RPM using: set -ex; : build-id: 334e8df9-6f64-42b7-adfd-15b77038d9b4; TMPDIR=/tmp/B.uFjTbe/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.uFjTbe' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux /tmp/B.uFjTbe/perl.spec + : build-id: 334e8df9-6f64-42b7-adfd-15b77038d9b4 + TMPDIR=/tmp/B.uFjTbe/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.uFjTbe' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux /tmp/B.uFjTbe/perl.spec warning: line 337: It's not recommended to have unversioned Obsoletes: Obsoletes: sperl warning: line 382: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib-devel warning: line 397: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-pod warning: line 530: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib warning: line 665: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-Encode-compat warning: Macro expanded in comment on line 713: %version macro. This hack works around it. warning: Could not canonicalize hostname: naiad Building target platforms: x32-pld-linux Building for target x32-pld-linux Executing(%prep): /bin/sh -e /tmp/B.uFjTbe/BUILD/tmp/rpm-tmp.OD2PhO + umask 022 + cd /tmp/B.uFjTbe/BUILD + cd /tmp/B.uFjTbe/BUILD + rm -rf perl-5.32.1 + /usr/bin/xz -dc /tmp/B.uFjTbe/perl-5.32.1.tar.xz + /bin/tar -xof - + STATUS=0 + '[' 0 -ne 0 ']' + cd perl-5.32.1 + /bin/chmod -Rf a+rX,u+w,g-w,o-w . + echo 'Patch #2 (perl_580-errno_h-parsing.patch):' Patch #2 (perl_580-errno_h-parsing.patch): + </tmp/B.uFjTbe/perl_580-errno_h-parsing.patch + /usr/bin/patch -s -p1 '--fuzz=0' 1 out of 1 hunk FAILED -- saving rejects to file ext/Errno/Errno_pm.PL.rej error: Bad exit status from /tmp/B.uFjTbe/BUILD/tmp/rpm-tmp.OD2PhO (%prep) RPM build errors: line 337: It's not recommended to have unversioned Obsoletes: Obsoletes: sperl line 382: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib-devel line 397: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-pod line 530: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-lib line 665: It's not recommended to have unversioned Obsoletes: Obsoletes: perl-Encode-compat Macro expanded in comment on line 713: %version macro. This hack works around it. Could not canonicalize hostname: naiad Bad exit status from /tmp/B.uFjTbe/BUILD/tmp/rpm-tmp.OD2PhO (%prep) ended at: Tue Feb 23 18:19:01 2021, done in 0:00:01.870775 error: No files produced. + chmod -R u+rwX /tmp/B.uFjTbe/BUILD + rm -rf /tmp/B.uFjTbe/tmp /tmp/B.uFjTbe/BUILD + rm -rf /tmp/B.uFjTbe Begin-PLD-Builder-Info Build-Time: user:3.58s sys:1.80s real:5.64s (faults io:0 non-io:229983) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]