FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2017 PLD Team
$Revision: 1.37 $
Powered by foobarbaz.
Your IP: 54.158.212.93

hlint 453abd5a-f1d0-45cf-b204-efd121eba2a8

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/th/x86_64/FAIL/hlint,453abd5a-f1d0-45cf-b204-efd121eba2a8.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2017/07/19 15:01:23

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • poldek: error: ghc-ansi-terminal: no such package
  • error 3
  • poldek: error: ghc-cmdargs: no such package
  • error 4
  • poldek: error: ghc-extra: no such package
  • error 5
  • poldek: error: ghc-refact: no such package
  • error 6
  • rpm: error: Failed build dependencies:
  • error 7
  • error: ghc-ansi-terminal: no such package
  • error 8
  • error: ghc-cmdargs: no such package
  • error 9
  • error: ghc-extra: no such package
  • error 10
  • error: ghc-refact: no such package
  • error 11
  • error: BR installation failed

Content:

request from: baggins
checking if we should skip the build
started at: Wed Jul 19 15:01:11 2017
fetching https://srcbuilder.pld-linux.org/th//srpms/453abd5a-f1d0-45cf-b204-efd121eba2a8/hlint-1.9.36-1.src.rpm
fetched 105561 bytes, 207.1 K/s
installing srpm: hlint-1.9.36-1.src.rpm
mesg: ttyname failed: Inappropriate ioctl for device
+ install -d /tmp/B.hSczis/BUILD /tmp/B.hSczis/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog hlint-1.9.36-1.src.rpm
* Wed Jul 19 2017 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/hlint.git;a=log;h=master
* Sat Aug 13 2016 Jan Palus <atler@pld-linux.org> 617c811
- BR: ghc-cmdargs * Mon Aug 01 2016 Jan Palus <atler@pld-linux.org> dd2185c
- up to 1.9.36 + rpm -Uhv --nodeps --define '_topdir /tmp/B.hSczis' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' hlint-1.9.36-1.src.rpm Preparing... ################################################## hlint ################################################## + rm -f hlint-1.9.36-1.src.rpm mesg: ttyname failed: Inappropriate ioctl for device + install -m 700 -d /tmp/B.hSczis/BUILD/tmp mesg: ttyname failed: Inappropriate ioctl for device + TMPDIR=/tmp/B.hSczis/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.hSczis' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.hSczis/hlint.spec Building target platforms: x86_64-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: cpphs >= 1.20.1 is needed by hlint-1.9.36-1.src rpm: ghc-ansi-terminal >= 0.6.2 is needed by hlint-1.9.36-1.src rpm: ghc-cmdargs >= 0.10 is needed by hlint-1.9.36-1.src rpm: ghc-extra >= 1.4.9 is needed by hlint-1.9.36-1.src rpm: ghc-haskell-src-exts >= 1.18.0 is needed by hlint-1.9.36-1.src rpm: ghc-refact >= 0.3 is needed by hlint-1.9.36-1.src rpm: ghc-uniplate is needed by hlint-1.9.36-1.src rpm: Building target platforms: x86_64-pld-linux updating poldek cache... ready is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-test::packages.ndir.md... th-test is up to date Retrieving th-test::packages.ndir.md... th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 28626 packages read poldek: Removed 1689 duplicate packages from available set poldek: error: ghc-ansi-terminal: no such package poldek: error: ghc-cmdargs: no such package poldek: error: ghc-extra: no such package poldek: error: ghc-refact: no such package no conflicts found checking BR rpm: error: Failed build dependencies: rpm: cpphs >= 1.20.1 is needed by hlint-1.9.36-1.src rpm: ghc-ansi-terminal >= 0.6.2 is needed by hlint-1.9.36-1.src rpm: ghc-cmdargs >= 0.10 is needed by hlint-1.9.36-1.src rpm: ghc-extra >= 1.4.9 is needed by hlint-1.9.36-1.src rpm: ghc-haskell-src-exts >= 1.18.0 is needed by hlint-1.9.36-1.src rpm: ghc-refact >= 0.3 is needed by hlint-1.9.36-1.src rpm: ghc-uniplate is needed by hlint-1.9.36-1.src rpm: Building target platforms: x86_64-pld-linux installing BR: ghc\-refact ghc\-cmdargs ghc\-ansi\-terminal ghc\-haskell\-src\-exts ghc\-uniplate ghc\-extra cpphs + poldek --noask --caplookup -Q -v --upgrade ghc-refact ghc-cmdargs ghc-ansi-terminal ghc-haskell-src-exts ghc-uniplate ghc-extra cpphs Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 28626 packages read Removed 1689 duplicate packages from available set error: ghc-ansi-terminal: no such package error: ghc-cmdargs: no such package error: ghc-extra: no such package error: ghc-refact: no such package error: BR installation failed mesg: ttyname failed: Inappropriate ioctl for device + chmod -R u+rwX /tmp/B.hSczis/BUILD + rm -rf /tmp/B.hSczis/tmp /tmp/B.hSczis/BUILD mesg: ttyname failed: Inappropriate ioctl for device + rm -rf /tmp/B.hSczis Begin-PLD-Builder-Info Build-Time: user:5.61s sys:0.69s real:16.95s (faults io:0 non-io:215955) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]