FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by voodoo magic.
Your IP: 3.232.96.22

neovim c04ec5ca-1974-435f-9045-0bb4abb2fc8d

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/neovim,c04ec5ca-1974-435f-9045-0bb4abb2fc8d.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2021/01/10 15:08:17
Runtime:0:00:00.170441

Toc:

  • error 1
  • - disable LUA (error: lua-mpack: no such package)
  • error 2
  • rpm: error: Failed build dependencies:
  • error 3
  • rpm: error: Failed build dependencies:
  • error 4
  • error: Failed build dependencies:
  • error 5
  • error: No files produced.

Content:

checking if we should skip the build
started at: Sun Jan 10 15:07:56 2021
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/c04ec5ca-1974-435f-9045-0bb4abb2fc8d/neovim-0.3.8-1.src.rpm
fetched 9224722 bytes, 7641.6 K/s
installing srpm: neovim-0.3.8-1.src.rpm
+ install -d /tmp/B.m2VhlJ/BUILD /tmp/B.m2VhlJ/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog neovim-0.3.8-1.src.rpm
* Sun Jan 10 2021 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/neovim.git;a=log;h=master
* Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 1b20afa
- Rename bcond to prefer_lua, fix for x32 * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 58461eb
- Requires older libvterm-devel * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 1a0c55f
- Lua deps are available for lua 5.1 only * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 1ffaa60
- Lua can't be disabled, just lua flavor be changed * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> def4dbb
- build fixes for gcc-10 * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 8179654
- Apply desktop.patch * Fri Nov 06 2020 Elan Ruusamäe <glen@pld-linux.org> 8d564b1
- Up to 0.3.8 * Mon May 18 2020 Jan Rękorajski <baggins@pld-linux.org> f700a5e
- disable LUA (error: lua-mpack: no such package) + rpm -Uhv --nodeps --define '_topdir /tmp/B.m2VhlJ' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' neovim-0.3.8-1.src.rpm Preparing... ################################################## neovim ################################################## + rm -f neovim-0.3.8-1.src.rpm + install -m 700 -d /tmp/B.m2VhlJ/BUILD/tmp + TMPDIR=/tmp/B.m2VhlJ/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.m2VhlJ' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.m2VhlJ/neovim.spec Building target platforms: x86_64-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: libtermkey-devel is needed by neovim-0.3.8-1.src rpm: libvterm-devel < 0.1.3 is needed by neovim-0.3.8-1.src rpm: Building target platforms: x86_64-pld-linux updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date Retrieving diff::packages.ndir.2021.01.10-08.56.02.gz......................................done Loading [pndir]th-test... Applying packages.ndir.2021.01.10-08.56.02.gz... Retrieving diff::packages.ndir.2021.01.10-11.36.02.gz......................................done Applying packages.ndir.2021.01.10-11.36.02.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... Retrieving th-test::packages.ndir.diff.toc.gz..............................................done Loading [pndir]th-test... Applying packages.ndir.2021.01.10-09.51.02.gz... Retrieving diff::packages.ndir.2021.01.10-09.52.01.gz......................................done Applying packages.ndir.2021.01.10-09.52.01.gz... Applying packages.ndir.2021.01.10-12.10.01.gz... Applying packages.ndir.2021.01.10-12.11.02.gz... Retrieving diff::packages.ndir.2021.01.10-12.14.01.gz......................................done Applying packages.ndir.2021.01.10-12.14.01.gz... Retrieving diff::packages.ndir.2021.01.10-13.19.02.gz......................................done Applying packages.ndir.2021.01.10-13.19.02.gz... Applying packages.ndir.2021.01.10-13.43.01.gz... Retrieving diff::packages.ndir.2021.01.10-13.53.01.gz......................................done Applying packages.ndir.2021.01.10-13.53.01.gz... Retrieving diff::packages.ndir.2021.01.10-13.55.01.gz......................................done Applying packages.ndir.2021.01.10-13.55.01.gz... Retrieving diff::packages.ndir.2021.01.10-14.03.01.gz......................................done Applying packages.ndir.2021.01.10-14.03.01.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 29718 packages read poldek: Removed 886 duplicate packages from available set poldek: libvterm-devel-0.1.3-2.x86_64: equal version installed, skipped poldek: Processing dependencies... poldek: libtermkey-devel-0.18-2.x86_64 marks libtermkey-0.18-2.x86_64 (cap libtermkey = 0.18-2) poldek: There are 2 packages to install (1 marked by dependencies): poldek: A libtermkey-0.18-2.x86_64 libtermkey-devel-0.18-2.x86_64 poldek: This operation will use 71.8KB of disk space. poldek: Need to get 51.0KB of archives. poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: Preparing... ################################################## no conflicts found checking BR rpm: error: Failed build dependencies: rpm: libtermkey-devel is needed by neovim-0.3.8-1.src rpm: libvterm-devel < 0.1.3 is needed by neovim-0.3.8-1.src rpm: Building target platforms: x86_64-pld-linux installing BR: libvterm\-devel libtermkey\-devel + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' '--ignore=php73-*' '--ignore=php74-*' '--ignore=php80-*' --upgrade libvterm-devel libtermkey-devel Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 29718 packages read Removed 886 duplicate packages from available set libvterm-devel-0.1.3-2.x86_64: equal version installed, skipped Processing dependencies... libtermkey-devel-0.18-2.x86_64 marks libtermkey-0.18-2.x86_64 (cap libtermkey = 0.18-2) There are 2 packages to install (1 marked by dependencies): A libtermkey-0.18-2.x86_64 libtermkey-devel-0.18-2.x86_64 This operation will use 71.8KB of disk space. Need to get 51.0KB of archives. Executing pm-command.sh --upgrade -vh --root / --define _check_dirname_deps 1... Preparing... ################################################## libtermkey ################################################## libtermkey-devel ################################################## building RPM using: set -ex; : build-id: c04ec5ca-1974-435f-9045-0bb4abb2fc8d; TMPDIR=/tmp/B.m2VhlJ/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.m2VhlJ' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux /tmp/B.m2VhlJ/neovim.spec + : build-id: c04ec5ca-1974-435f-9045-0bb4abb2fc8d + TMPDIR=/tmp/B.m2VhlJ/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.m2VhlJ' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux /tmp/B.m2VhlJ/neovim.spec error: Failed build dependencies: libvterm-devel < 0.1.3 is needed by neovim-0.3.8-1.src Building target platforms: x86_64-pld-linux ended at: Sun Jan 10 15:08:17 2021, done in 0:00:00.170441 error: No files produced. + chmod -R u+rwX /tmp/B.m2VhlJ/BUILD + rm -rf /tmp/B.m2VhlJ/tmp /tmp/B.m2VhlJ/BUILD + rm -rf /tmp/B.m2VhlJ Begin-PLD-Builder-Info Build-Time: user:10.41s sys:1.82s real:21.18s (faults io:51147 non-io:333183) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]