FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2018 PLD Team
$Revision: 1.37 $
Powered by synergy.
Your IP: 54.147.142.16

ruby b71f0e74-81aa-4ef1-aac0-192b0431cddd

Status:Failed
Source URL:ftp://buildlogs.pld-linux.org/th/x86_64/FAIL/ruby,b71f0e74-81aa-4ef1-aac0-192b0431cddd.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2018/06/17 21:53:46

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • poldek: error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found
  • error 3
  • poldek: error: rpm-rubyprov-5.4.15-42.x86_64: req ruby-modules not found
  • error 4
  • poldek: error: 2 unresolved dependencies
  • error 5
  • poldek: error: Failed dependencies:
  • error 6
  • error: ruby-modules: no such package
  • error 7
  • rpm: error: Failed build dependencies:
  • error 8
  • error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found
  • error 9
  • error: 1 unresolved dependency
  • error 10
  • error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found
  • error 11
  • error: 1 unresolved dependency
  • error 12
  • error: BR installation failed

Content:

checking if we should skip the build
started at: Sun Jun 17 21:53:16 2018
killing old processes on a builder
mesg: ttyname failed: Inappropriate ioctl for device
sending signal 9 to pid -1
Killed
fetching https://srcbuilder.pld-linux.org/th//srpms/b71f0e74-81aa-4ef1-aac0-192b0431cddd/ruby-2.4.4-7.src.rpm
fetched 55749351 bytes, 6337.1 K/s
installing srpm: ruby-2.4.4-7.src.rpm
mesg: ttyname failed: Inappropriate ioctl for device
+ install -d /tmp/B.Rh2lHi/BUILD /tmp/B.Rh2lHi/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog ruby-2.4.4-7.src.rpm
* Sun Jun 17 2018 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/ruby.git;a=log;h=master
* Sun Jun 17 2018 Jakub Bogusz <qboosh@pld-linux.org> e0a31d1
- rel 7 (rebuild with gdbm 1.15) * Tue Jun 12 2018 Jakub Bogusz <qboosh@pld-linux.org> 01268b7
- rel 6 * Sun Jun 10 2018 Jakub Bogusz <qboosh@pld-linux.org> 50c9bd0
- -test-unit R: -power_assert - fix test-unit symlink * Fri Jun 08 2018 Jakub Bogusz <qboosh@pld-linux.org> 498ccbb
- kill /usr/bin/env from rdoc and ri * Fri Jun 08 2018 Jakub Bogusz <qboosh@pld-linux.org> a48b0cf
- updated -test-unit description, added remaining pl * Wed Jun 06 2018 Jan Rękorajski <baggins@pld-linux.org> e43cde0
- don't replace upstream rake script - rel 5 * Wed Jun 06 2018 Jan Rękorajski <baggins@pld-linux.org> 0de43f1
- fix rake executable permissions - rel 4 * Mon Jun 04 2018 Jan Rękorajski <baggins@pld-linux.org> e482243
- fix xmlrpc package files - rel 3 * Sun Jun 03 2018 Jan Rękorajski <baggins@pld-linux.org> cbcdaf7
- rebuild with ruby 2.4 - release 2 (by relup.sh) * Thu May 31 2018 Jan Rękorajski <baggins@pld-linux.org> 0e33fc0
- prep unicde data files * Wed May 30 2018 Jan Rękorajski <baggins@pld-linux.org> 28a41f4
- fetch unicode data * Wed May 30 2018 Jan Rękorajski <baggins@pld-linux.org> 67f2673
- updated to 2.4.4 * Wed May 23 2018 Jakub Bogusz <qboosh@pld-linux.org> 245a0d1
- adjusted rubygems_ver * Fri Apr 27 2018 Elan Ruusamäe <glen@pld-linux.org> f9cc3f3
- up to 2.3.7 * Thu Oct 26 2017 Elan Ruusamäe <glen@pld-linux.org> 68055c6
- ruby-devel R: gmp-devel * Mon Oct 23 2017 Jan Rękorajski <baggins@pld-linux.org> c846f21
- don't add empty patchlevel to ruby_version - rel 3 * Sun Oct 22 2017 Jan Rękorajski <baggins@pld-linux.org> 1648a12
- bigdecimal and io-console are not noarch - rel 2 * Sun Sep 17 2017 mis <mistoo@gmail.com> 7742b54
- up to 2.3.5 * Sun Aug 13 2017 Elan Ruusamäe <glen@pld-linux.org> 505dcb9
- macros cleanup * Sun Aug 13 2017 Elan Ruusamäe <glen@pld-linux.org> e52e77e
- Merge branch 'dev-2.3' + rpm -Uhv --nodeps --define '_topdir /tmp/B.Rh2lHi' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' ruby-2.4.4-7.src.rpm Preparing... ################################################## ruby ################################################## + rm -f ruby-2.4.4-7.src.rpm mesg: ttyname failed: Inappropriate ioctl for device + install -m 700 -d /tmp/B.Rh2lHi/BUILD/tmp mesg: ttyname failed: Inappropriate ioctl for device + TMPDIR=/tmp/B.Rh2lHi/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.Rh2lHi' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.Rh2lHi/ruby.spec Building target platforms: x86_64-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: rpm-rubyprov is needed by ruby-2.4.4-7.src rpm: ruby-modules is needed by ruby-2.4.4-7.src rpm: Building target platforms: x86_64-pld-linux updating poldek cache... ready is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th::packages.ndir.md... th is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-ready::packages.ndir.md... th-ready is up to date Retrieving th-test::packages.ndir.md... th-test is up to date Retrieving th-test::packages.ndir.md... Retrieving th-test::packages.ndir.diff.toc.gz... ..............................done Retrieving diff::packages.ndir.2018.06.17-11.51.01.gz... ..............................done Retrieving diff::packages.ndir.dscr.2018.06.17-11.51.01.gz... Loading [pndir]th-test... Applying packages.ndir.2018.06.17-11.51.01.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 28707 packages read poldek: Removed 1833 duplicate packages from available set poldek: Processing dependencies... poldek: error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found poldek: ruby-modules-2.4.4-6.x86_64 marks ruby-rubygems-2.6.14.1-2.4.4.6.noarch (cap rubygems) poldek: ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 (cap ruby-bigdecimal = 1.3.2-2.4.4.6) poldek: ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-io-console-0.4.6-2.4.4.6.x86_64 (cap ruby-io-console = 0.4.6-2.4.4.6) poldek: ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-psych-2.2.2-2.4.4.6.x86_64 (cap ruby-psych = 2.2.2-2.4.4.6) poldek: ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-rdoc-5.0.0-2.4.4.6.noarch (cap ruby-rdoc >= 5.0.0) poldek: ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-irb-0.9.6-2.4.4.6.noarch (cap ruby-irb >= 0.9.6) poldek: ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-json-2.0.4-2.4.4.6.x86_64 (cap ruby-json >= 2.0.4) poldek: error: rpm-rubyprov-5.4.15-42.x86_64: req ruby-modules not found poldek: There are 9 packages to install (7 marked by dependencies): poldek: I rpm-rubyprov-5.4.15-42.x86_64 ruby-modules-2.4.4-6.x86_64 poldek: D ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 poldek: D ruby-io-console-0.4.6-2.4.4.6.x86_64 ruby-irb-0.9.6-2.4.4.6.noarch poldek: D ruby-json-2.0.4-2.4.4.6.x86_64 ruby-psych-2.2.2-2.4.4.6.x86_64 poldek: D ruby-rdoc-5.0.0-2.4.4.6.noarch ruby-rubygems-2.6.14.1-2.4.4.6.noarch poldek: This operation will use 10.5MB of disk space. poldek: Need to get 2.3MB of archives (2.3MB to download). poldek: poldek: error: 2 unresolved dependencies poldek: Retrieving [1/9] th-test::ruby-bigdecimal-1.3.2-2.4.4.6.x86_64.rpm... poldek: ..............................done poldek: Retrieving [2/9] th-test::ruby-io-console-0.4.6-2.4.4.6.x86_64.rpm... poldek: ..............................done poldek: Retrieving [3/9] th-test::ruby-psych-2.2.2-2.4.4.6.x86_64.rpm... poldek: ..............................done poldek: Retrieving [4/9] th-test::ruby-json-2.0.4-2.4.4.6.x86_64.rpm... poldek: ..............................done poldek: Retrieving [5/9] th-test::ruby-modules-2.4.4-6.x86_64.rpm... poldek: ..............................done poldek: Retrieving [6/9] th-test::ruby-irb-0.9.6-2.4.4.6.noarch.rpm... poldek: ..............................done poldek: Retrieving [7/9] th-test::ruby-rdoc-5.0.0-2.4.4.6.noarch.rpm... poldek: ..............................done poldek: Retrieving [8/9] th-test::ruby-rubygems-2.6.14.1-2.4.4.6.noarch.rpm... poldek: ..............................done poldek: Retrieving [9/9] th::rpm-rubyprov-5.4.15-42.x86_64.rpm... poldek: ..............................done poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: error: Failed dependencies: poldek: libgdbm.so.4()(64bit) is needed by ruby-modules-2.4.4-6.x86_64 uninstalling conflicting packages removing ruby-modules error: ruby-modules: no such package package ruby-modules removal failed checking BR rpm: error: Failed build dependencies: rpm: rpm-rubyprov is needed by ruby-2.4.4-7.src rpm: ruby-modules is needed by ruby-2.4.4-7.src rpm: Building target platforms: x86_64-pld-linux installing BR: rpm\-rubyprov ruby\-modules + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' --upgrade rpm-rubyprov ruby-modules Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 28707 packages read Removed 1833 duplicate packages from available set Processing dependencies... error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found ruby-modules-2.4.4-6.x86_64 marks ruby-rubygems-2.6.14.1-2.4.4.6.noarch (cap rubygems) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 (cap ruby-bigdecimal = 1.3.2-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-io-console-0.4.6-2.4.4.6.x86_64 (cap ruby-io-console = 0.4.6-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-psych-2.2.2-2.4.4.6.x86_64 (cap ruby-psych = 2.2.2-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-rdoc-5.0.0-2.4.4.6.noarch (cap ruby-rdoc >= 5.0.0) ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-irb-0.9.6-2.4.4.6.noarch (cap ruby-irb >= 0.9.6) ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-json-2.0.4-2.4.4.6.x86_64 (cap ruby-json >= 2.0.4) There are 8 packages to install (7 marked by dependencies): I ruby-modules-2.4.4-6.x86_64 D ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 D ruby-io-console-0.4.6-2.4.4.6.x86_64 ruby-irb-0.9.6-2.4.4.6.noarch D ruby-json-2.0.4-2.4.4.6.x86_64 ruby-psych-2.2.2-2.4.4.6.x86_64 D ruby-rdoc-5.0.0-2.4.4.6.noarch ruby-rubygems-2.6.14.1-2.4.4.6.noarch This operation will use 10.5MB of disk space. Need to get 2.3MB of archives. error: 1 unresolved dependency Installing set #2 Processing dependencies... rpm-rubyprov-5.4.15-42.x86_64 marks ruby-modules-2.4.4-6.x86_64 (cap ruby-modules) error: ruby-modules-2.4.4-6.x86_64: req libgdbm.so.4()(64bit) not found ruby-modules-2.4.4-6.x86_64 marks ruby-rubygems-2.6.14.1-2.4.4.6.noarch (cap rubygems) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 (cap ruby-bigdecimal = 1.3.2-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-io-console-0.4.6-2.4.4.6.x86_64 (cap ruby-io-console = 0.4.6-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-psych-2.2.2-2.4.4.6.x86_64 (cap ruby-psych = 2.2.2-2.4.4.6) ruby-rubygems-2.6.14.1-2.4.4.6.noarch marks ruby-rdoc-5.0.0-2.4.4.6.noarch (cap ruby-rdoc >= 5.0.0) ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-irb-0.9.6-2.4.4.6.noarch (cap ruby-irb >= 0.9.6) ruby-rdoc-5.0.0-2.4.4.6.noarch marks ruby-json-2.0.4-2.4.4.6.x86_64 (cap ruby-json >= 2.0.4) There are 9 packages to install (8 marked by dependencies): I rpm-rubyprov-5.4.15-42.x86_64 D ruby-bigdecimal-1.3.2-2.4.4.6.x86_64 D ruby-io-console-0.4.6-2.4.4.6.x86_64 ruby-irb-0.9.6-2.4.4.6.noarch D ruby-json-2.0.4-2.4.4.6.x86_64 ruby-modules-2.4.4-6.x86_64 D ruby-psych-2.2.2-2.4.4.6.x86_64 ruby-rdoc-5.0.0-2.4.4.6.noarch D ruby-rubygems-2.6.14.1-2.4.4.6.noarch This operation will use 10.5MB of disk space. Need to get 2.3MB of archives. error: 1 unresolved dependency error: BR installation failed mesg: ttyname failed: Inappropriate ioctl for device + chmod -R u+rwX /tmp/B.Rh2lHi/BUILD + rm -rf /tmp/B.Rh2lHi/tmp /tmp/B.Rh2lHi/BUILD mesg: ttyname failed: Inappropriate ioctl for device + rm -rf /tmp/B.Rh2lHi Begin-PLD-Builder-Info Build-Time: user:8.19s sys:1.47s real:29.96s (faults io:0 non-io:279606) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]