FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2020 PLD Team
$Revision: 1.37 $
Powered by penguin.
Your IP: 34.200.236.68

yp-tools 240ddfec-da7e-4e33-99f5-c5d813bfdf17

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/yp-tools,240ddfec-da7e-4e33-99f5-c5d813bfdf17.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2020/08/24 20:03:31

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • poldek: error: Failed dependencies:
  • error 3
  • error: conflicting packages uninstallation failed

Content:

checking if we should skip the build
started at: Mon Aug 24 20:02:26 2020
killing old processes on a builder
sending signal 9 to pid -1
Killed
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/240ddfec-da7e-4e33-99f5-c5d813bfdf17/yp-tools-4.2.3-1.src.rpm
fetched 223747 bytes, 538.4 K/s
installing srpm: yp-tools-4.2.3-1.src.rpm
+ install -d /tmp/B.c56uDU/BUILD /tmp/B.c56uDU/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog yp-tools-4.2.3-1.src.rpm
* Mon Aug 24 2020 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/yp-tools.git;a=log;h=master
* Sun Aug 23 2020 Jakub Bogusz <qboosh@pld-linux.org> 6d1f4fc
- updated to 4.2.3; use libtirpc+appropriate libnsl for IPv6 support + rpm -Uhv --nodeps --define '_topdir /tmp/B.c56uDU' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' yp-tools-4.2.3-1.src.rpm Preparing... ################################################## yp-tools ################################################## + rm -f yp-tools-4.2.3-1.src.rpm + install -m 700 -d /tmp/B.c56uDU/BUILD/tmp + TMPDIR=/tmp/B.c56uDU/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.c56uDU' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.c56uDU/yp-tools.spec Building target platforms: x86_64-pld-linux checking BuildConflict-ing packages no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: libnsl-devel >= 1.0.4 is needed by yp-tools-4.2.3-1.src rpm: Building target platforms: x86_64-pld-linux updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date Retrieving diff::packages.ndir.2020.08.23-18.13.16.gz......................................done Retrieving diff::packages.ndir.dscr.2020.08.23-18.13.16.gz.................................done Loading [pndir]th-test... Applying packages.ndir.2020.08.23-18.13.16.gz... Retrieving diff::packages.ndir.2020.08.24-17.09.03.gz......................................done Applying packages.ndir.2020.08.24-17.09.03.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... th-test: desynchronized index, trying to update whole index... Retrieving th-test::packages.ndir.gz.......................................................done Retrieving th-test::packages.ndir.dscr.gz..................................................done th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 30549 packages read poldek: Removed 2038 duplicate packages from available set poldek: Processing dependencies... poldek: libnsl-devel-1.3.0-1.x86_64 marks glibc-devel-2.32-2.x86_64 (cap glibc-devel >= 6:2.32) poldek: glibc-devel-2.31-5.x86_64 obsoleted by glibc-devel-2.32-2.x86_64 poldek: glibc-devel-2.32-2.x86_64 marks glibc-2.32-2.x86_64 (cap glibc = 6:2.32-2) poldek: glibc-2.31-5.x86_64 obsoleted by glibc-2.32-2.x86_64 poldek: glibc-2.32-2.x86_64 marks glibc-ld-2.32-2.x86_64 (cap glibc-ld = 6:2.32-2) poldek: glibc-ld-2.31-1.x86_64 obsoleted by glibc-ld-2.32-2.x86_64 poldek: glibc-2.32-2.x86_64 marks glibc-misc-2.32-2.x86_64 (cap glibc-misc >= 6:2.32-2) poldek: glibc-misc-2.31-5.x86_64 obsoleted by glibc-misc-2.32-2.x86_64 poldek: glibc-devel-2.32-2.x86_64 marks glibc-devel-utils-2.32-2.x86_64 (cap glibc-devel-utils = 6:2.32-2) poldek: glibc-devel-utils-2.31-5.x86_64 obsoleted by glibc-devel-utils-2.32-2.x86_64 poldek: glibc-devel-2.32-2.x86_64 marks glibc-headers-2.32-2.x86_64 (cap glibc-headers = 6:2.32-2) poldek: glibc-headers-2.31-5.x86_64 obsoleted by glibc-headers-2.32-2.x86_64 poldek: glibc-devel-2.32-2.x86_64 marks glibc-libcrypt-2.32-2.x86_64 (cap glibc-libcrypt(x86_64) = 6:2.32-2) poldek: glibc-libcrypt-2.31-5.x86_64 obsoleted by glibc-libcrypt-2.32-2.x86_64 poldek: libnsl-devel-1.3.0-1.x86_64 marks libnsl-1.3.0-1.x86_64 (cap libnsl = 1.3.0-1) poldek: There are 9 packages to install (8 marked by dependencies), 7 to remove: poldek: U glibc-(2.31-5 => 2.32-2).x86_64 glibc-devel-(2.31-5 => 2.32-2).x86_64 poldek: U glibc-devel-utils-(2.31-5 => 2.32-2).x86_64 poldek: U glibc-headers-(2.31-5 => 2.32-2).x86_64 poldek: U glibc-ld-(2.31-1 => 2.32-2).x86_64 poldek: U glibc-libcrypt-(2.31-5 => 2.32-2).x86_64 poldek: U glibc-misc-(2.31-5 => 2.32-2).x86_64 poldek: A libnsl-1.3.0-1.x86_64 libnsl-devel-1.3.0-1.x86_64 poldek: This operation will free 397.7KB of disk space. poldek: Need to get 3.9MB of archives. poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 1... poldek: error: Failed dependencies: poldek: /usr/include/rpcsvc is needed by libnsl-devel-1.3.0-1.x86_64 poldek: glibc-devel-utils = 6:2.31-5 is needed by (installed) glibc-devel-2.31-5.i686 poldek: glibc-devel-utils = 6:2.31-5 is needed by (installed) glibc-devel-2.31-5.x32 poldek: glibc-headers = 6:2.31-5 is needed by (installed) glibc-devel-2.31-5.i686 poldek: glibc-headers = 6:2.31-5 is needed by (installed) glibc-devel-2.31-5.x32 uninstalling conflicting packages cannot remove glibc-devel because it's required by rpm-build, that is crucial error: conflicting packages uninstallation failed + chmod -R u+rwX /tmp/B.c56uDU/BUILD + rm -rf /tmp/B.c56uDU/tmp /tmp/B.c56uDU/BUILD + rm -rf /tmp/B.c56uDU Begin-PLD-Builder-Info Build-Time: user:46.46s sys:10.34s real:65.15s (faults io:0 non-io:2556363) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]