FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2022 PLD Team
$Revision: 1.37 $
Powered by bogon.
Your IP: 44.201.96.43

ka5-ktp-auth-handler ba2bb5cb-2c51-4965-ad99-224e749533ac

Status:OK
Source URL:https://buildlogs.pld-linux.org/pld/th/i686/OK/ka5-ktp-auth-handler,ba2bb5cb-2c51-4965-ad99-224e749533ac.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2022/05/18 12:46:12
Runtime:0:00:25.837752

Toc:

  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.i2PZkz
  • build
  • Executing(%build): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.MovKqa
  • error 1
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 2
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 3
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 4
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 5
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 6
  • 58 | KSslError::Error validityToError(QCA::Validity validity) const;
  • error 7
  • 135 | KSslError::Error error = validityToError(validity);
  • error 8
  • /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:137:38: warning: ‘KSslError::KSslError(KSslError::Error, const QSslCertificate&)’ is deprecated: Since 5.63. Use KSslError(const QSslError &) [-Wdeprecated-declarations]
  • error 9
  • 126 | KSslError(KSslError::Error error = NoError, const QSslCertificate &cert = QSslCertificate());
  • error 10
  • /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:218:37: warning: ‘static QList<QList<KSslError::Error> > KSslInfoDialog::errorsFromString(const QString&)’ is deprecated: Since 5.65. use the QSslError variant [-Wdeprecated-declarations]
  • error 11
  • 104 | static QList<QList<KSslError::Error>> errorsFromString(const QString &s); // TODO KF6 remove
  • error 12
  • /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:218:53: warning: ‘static QList<QList<KSslError::Error> > KSslInfoDialog::errorsFromString(const QString&)’ is deprecated: Since 5.65. use the QSslError variant [-Wdeprecated-declarations]
  • error 13
  • 104 | static QList<QList<KSslError::Error>> errorsFromString(const QString &s); // TODO KF6 remove
  • error 14
  • /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:211:23: warning: ‘void KSslInfoDialog::setSslInfo(const QList<QSslCertificate>&, const QString&, const QString&, const QString&, const QString&, int, int, const QList<QList<KSslError::Error> >&)’ is deprecated: Since 5.64. use the QSslError variant [-Wdeprecated-declarations]
  • error 15
  • 224 | KSslError::Error TlsCertVerifierOp::validityToError(QCA::Validity validity) const
  • error 16
  • /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: In member function ‘KSslError::Error TlsCertVerifierOp::validityToError(QCA::Validity) const’:
  • error 17
  • 228 | return KSslError::NoError;
  • error 18
  • 230 | return KSslError::RejectedCertificate;
  • error 19
  • 232 | return KSslError::UntrustedCertificate;
  • error 20
  • 234 | return KSslError::CertificateSignatureFailed;
  • error 21
  • 236 | return KSslError::InvalidCertificateAuthorityCertificate;
  • error 22
  • 238 | return KSslError::InvalidCertificatePurpose;
  • error 23
  • 240 | return KSslError::SelfSignedCertificate;
  • error 24
  • 242 | return KSslError::RevokedCertificate;
  • error 25
  • 244 | return KSslError::PathLengthExceeded;
  • error 26
  • 247 | return KSslError::ExpiredCertificate;
  • error 27
  • 249 | return KSslError::UnknownError;
  • error 28
  • 252 | return KSslError::UnknownError;
  • install
  • Executing(%install): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.fFfWyH
  • files ka5-ktp-auth-handler
  • Processing files: ka5-ktp-auth-handler-22.04.1-1.i686
  • files ka5-ktp-auth-handler-debugsource
  • Processing files: ka5-ktp-auth-handler-debugsource-22.04.1-1.i686
  • files ka5-ktp-auth-handler-debuginfo
  • Processing files: ka5-ktp-auth-handler-debuginfo-22.04.1-1.i686
  • clean
  • Executing(%clean): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.n72gvX

Content:

request from: mrozowik
checking if we should skip the build
started at: Wed May 18 12:45:42 2022
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/ba2bb5cb-2c51-4965-ad99-224e749533ac/ka5-ktp-auth-handler-22.04.1-1.src.rpm
fetched 58956 bytes, 154.1 K/s
installing srpm: ka5-ktp-auth-handler-22.04.1-1.src.rpm
+ install -d /tmp/B.kj16uz3w/BUILD /tmp/B.kj16uz3w/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog ka5-ktp-auth-handler-22.04.1-1.src.rpm
* Wed May 18 2022 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/ka5-ktp-auth-handler.git;a=log;h=master
* Thu May 12 2022 Witold Filipczyk <witekfl@poczta.onet.pl> a0b39e6
- updated to 22.04.1 * Fri Apr 22 2022 Witold Filipczyk <witekfl@poczta.onet.pl> 1047ed7
- updated to 22.04.0 * Tue Apr 05 2022 Witold Filipczyk <witekfl@poczta.onet.pl> d7d7e3e
- bcond_with tests * Fri Mar 04 2022 Witold Filipczyk <witekfl@poczta.onet.pl> 46c1586
- updated to 21.12.3 * Thu Feb 03 2022 Witold Filipczyk <witekfl@poczta.onet.pl> a21d523
- updated to 21.12.2 * Fri Jan 07 2022 Witold Filipczyk <witekfl@poczta.onet.pl> 784a346
- updated to 21.12.1 * Fri Dec 10 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 273ade2
- updated to 21.12.0 * Fri Nov 05 2021 Witold Filipczyk <witekfl@poczta.onet.pl> facea65
- updated to 21.08.3 * Fri Oct 08 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 1ffeaff
- updated to 21.08.2 * Sun Sep 05 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 4eb2cd8
- updated to 21.08.1 * Thu Aug 19 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 6e4d6bc
- updated to 21.08.0 * Fri Aug 06 2021 Witold Filipczyk <witekfl@poczta.onet.pl> c5d74a5
- pl description * Fri Jul 09 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 3893040
- updated to 21.04.3 * Fri Jun 11 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 1d50dc8
- updated to 21.04.2 * Sat May 15 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 0fa3a37
- updated to 21.04.1 * Sat Apr 24 2021 Witold Filipczyk <witekfl@poczta.onet.pl> 9def150
- updated to 21.04.0 * Tue Mar 16 2021 Witold Filipczyk <witekfl@poczta.onet.pl> a28189e
- updated to 20.12.3 * Mon May 13 2019 Witold Filipczyk <witekfl@poczta.onet.pl> 4eb73b6
- updated to 19.04.1 - packaged docs - macro kframever * Sun Jan 13 2019 Witold Filipczyk <witekfl@poczta.onet.pl> 39950b8
- updated to 18.12.1; ninja * Mon Jan 07 2019 Witold Filipczyk <witekfl@poczta.onet.pl> 4132595
- updated to 18.12.0 + rpm -Uhv --nodeps --define '_topdir /tmp/B.kj16uz3w' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' ka5-ktp-auth-handler-22.04.1-1.src.rpm Updating / installing... ka5-ktp-auth-handler-22.04.1-1 ######################################## + rm -f ka5-ktp-auth-handler-22.04.1-1.src.rpm + install -m 700 -d /tmp/B.kj16uz3w/BUILD/tmp + TMPDIR=/tmp/B.kj16uz3w/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.kj16uz3w' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux --define 'prep exit 0' /tmp/B.kj16uz3w/ka5-ktp-auth-handler.spec warning: Could not canonicalize hostname: nereid Building target platforms: i686-pld-linux Building for target i686-pld-linux checking BuildConflict-ing packages rpm: warning: Could not canonicalize hostname: nereid rpm: Building target platforms: i686-pld-linux rpm: Building for target i686-pld-linux no BuildConflicts found checking BR rpm: warning: Could not canonicalize hostname: nereid rpm: Building target platforms: i686-pld-linux rpm: Building for target i686-pld-linux no BR needed building RPM using: set -ex; : build-id: ba2bb5cb-2c51-4965-ad99-224e749533ac; TMPDIR=/tmp/B.kj16uz3w/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '__jobs 9' --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.kj16uz3w' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux /tmp/B.kj16uz3w/ka5-ktp-auth-handler.spec + : build-id: ba2bb5cb-2c51-4965-ad99-224e749533ac + TMPDIR=/tmp/B.kj16uz3w/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '__jobs 9' --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.kj16uz3w' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target i686-pld-linux /tmp/B.kj16uz3w/ka5-ktp-auth-handler.spec warning: Could not canonicalize hostname: nereid Building target platforms: i686-pld-linux Building for target i686-pld-linux Executing(%prep): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.i2PZkz + umask 022 + cd /tmp/B.kj16uz3w/BUILD + cd /tmp/B.kj16uz3w/BUILD + rm -rf ktp-auth-handler-22.04.1 + /usr/bin/xz -dc /tmp/B.kj16uz3w/ktp-auth-handler-22.04.1.tar.xz + /bin/tar -xof - + STATUS=0 + '[' 0 -ne 0 ']' + cd ktp-auth-handler-22.04.1 + /bin/chmod -Rf a+rX,u+w,g-w,o-w . + RPM_EC=0 + jobs -p + exit 0 Executing(%build): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.MovKqa TMP=/home/users/builder/tmp HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/bin:/usr/bin:/usr/local/bin:/home/users/builder/bin TMPDIR=/tmp/B.kj16uz3w/BUILD/tmp + umask 022 + cd /tmp/B.kj16uz3w/BUILD + cd ktp-auth-handler-22.04.1 + install -d build + cd build + CC=i686-pld-linux-gcc CXX=i686-pld-linux-g++ CPPFLAGS='' /usr/bin/cmake '-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON' '-DCMAKE_BUILD_TYPE=PLD' '-DCMAKE_INSTALL_BINDIR:PATH=/usr/bin' '-DCMAKE_INSTALL_SBINDIR:PATH=/usr/sbin' '-DCMAKE_INSTALL_LIBEXECDIR:PATH=/usr/libexec' '-DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc' '-DCMAKE_INSTALL_SHAREDSTATEDIRPATH:PATH=/var/lib' '-DCMAKE_INSTALL_LOCALSTATEDIRPATH:PATH=/var' '-DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib' '-DCMAKE_INSTALL_INCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_OLDINCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share' '-DCMAKE_INSTALL_DATADIR:PATH=/usr/share' '-DCMAKE_INSTALL_INFODIR:PATH=/usr/share/info' '-DCMAKE_INSTALL_LOCALEDIR:PATH=/usr/share/locale' '-DCMAKE_INSTALL_MANDIR:PATH=/usr/share/man' '-DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/doc' '-DCMAKE_INSTALL_PREFIX:PATH=/usr' '-DSYSCONF_INSTALL_DIR:PATH=/etc' '-DCMAKE_CXX_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_C_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_Fortran_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_EXE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_SHARED_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_MODULE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DBUILD_SHARED_LIBS:BOOL=ON' -G Ninja '-DBUILD_TESTING=OFF' '-DHTML_INSTALL_DIR=/usr/share/doc/kde/HTML' '-DKDE_INSTALL_USE_QT_SYS_PATHS=ON' .. -- The C compiler identification is GNU 11.3.0 -- The CXX compiler identification is GNU 11.3.0 -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working C compiler: /usr/bin/i686-pld-linux-gcc - skipped -- Detecting C compile features -- Detecting C compile features - done -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/bin/i686-pld-linux-g++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Found KF5Wallet: /usr/lib/cmake/KF5Wallet/KF5WalletConfig.cmake (found version "5.94.0") -- Found KF5WidgetsAddons: /usr/lib/cmake/KF5WidgetsAddons/KF5WidgetsAddonsConfig.cmake (found version "5.94.0") -- Found Gettext: /usr/bin/msgmerge (found version "0.21") -- Found KF5I18n: /usr/lib/cmake/KF5I18n/KF5I18nConfig.cmake (found version "5.94.0") -- Found X11: /usr/include -- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so -- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found -- Looking for gethostbyname -- Looking for gethostbyname - found -- Looking for connect -- Looking for connect - found -- Looking for remove -- Looking for remove - found -- Looking for shmat -- Looking for shmat - found -- Looking for IceConnectionNumber in ICE -- Looking for IceConnectionNumber in ICE - found -- Found KF5KIO: /usr/lib/cmake/KF5KIO/KF5KIOConfig.cmake (found version "5.94.0") -- Found KF5: success (found suitable version "5.94.0", minimum required is "5.0") found components: Wallet WidgetsAddons I18n KIO ----------------------------------------------------------------------------- IMPORTANT: There is a runtime dependency on QCA-OSSL. This project will build, but will fail to run properly. Please ensure it is installed. If you are a packager you _must_ mark this as a dependency. ----------------------------------------------------------------------------- CMake Deprecation Warning at /usr/share/ECM/kde-modules/KDEInstallDirsCommon.cmake:133 (message): HTML_INSTALL_DIR is deprecated, use KDE_INSTALL_DOCBUNDLEDIR instead. Call Stack (most recent call first): /usr/share/ECM/kde-modules/KDEInstallDirsCommon.cmake:283 (_define_relative) /usr/share/ECM/kde-modules/KDEInstallDirs5.cmake:223 (include) /usr/share/ECM/kde-modules/KDEInstallDirs.cmake:15 (include) CMakeLists.txt:42 (include) CMake Deprecation Warning at /usr/share/ECM/kde-modules/KDEInstallDirsCommon.cmake:133 (message): SYSCONF_INSTALL_DIR is deprecated, use KDE_INSTALL_SYSCONFDIR instead. Call Stack (most recent call first): /usr/share/ECM/kde-modules/KDEInstallDirsCommon.cmake:198 (_define_relative) /usr/share/ECM/kde-modules/KDEInstallDirsCommon.cmake:360 (_define_absolute) /usr/share/ECM/kde-modules/KDEInstallDirs5.cmake:223 (include) /usr/share/ECM/kde-modules/KDEInstallDirs.cmake:15 (include) CMakeLists.txt:42 (include) -- Looking for __GLIBC__ -- Looking for __GLIBC__ - found -- Performing Test _OFFT_IS_64BIT -- Performing Test _OFFT_IS_64BIT - Failed -- Performing Test HAVE_DATE_TIME -- Performing Test HAVE_DATE_TIME - Success -- The following OPTIONAL packages have been found: * KF5Service (required version >= 5.93.0) * KF5JobWidgets (required version >= 5.93.0) * KF5Solid (required version >= 5.93.0) * KF5Auth (required version >= 5.93.0) * KF5Codecs (required version >= 5.93.0) * KF5Config (required version >= 5.93.0) * Freetype * PkgConfig * Fontconfig -- The following REQUIRED packages have been found: * ECM (required version >= 0.0.11) * Gettext * KF5I18n (required version >= 5.0) * KF5KIO (required version >= 5.0) * KF5 (required version >= 5.0) * Qt5DBus * Qt5Network * Qt5 * TelepathyQt5 (required version >= 0.9.8) * Qt5Gui (required version >= 5.15.2) * KF5Wallet * KTp * Qca-qt5 * KF5CoreAddons (required version >= 5.91.0) * AccountsQt5 (required version >= 1.13) * SignOnQt5 (required version >= 8.55) * KAccounts * Qt5Core -- The following RUNTIME packages have not been found: * Qca-qt5-ossl Runtime-only dependency on the OSSL plugin of QCA for authentication to work properly -- Configuring done -- Generating done CMake Warning: Manually-specified variables were not used by the project: CMAKE_Fortran_FLAGS_PLD CMAKE_INSTALL_DOCDIR CMAKE_INSTALL_LOCALSTATEDIRPATH CMAKE_INSTALL_OLDINCLUDEDIR CMAKE_INSTALL_SHAREDSTATEDIRPATH CMAKE_VERBOSE_MAKEFILE -- Build files have been written to: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build + LC_ALL=C.UTF-8 /usr/bin/ninja -v -j9 [1/17] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -DPYTHON_EXECUTABLE=/usr/bin/python3 -D_ki18n_pmap_compile_script=/usr/lib/cmake/KF5I18n/ts-pmap-compile.py -DCOPY_TO=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/locale -DPO_DIR=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/po -P /usr/lib/cmake/KF5I18n/build-tsfiles.cmake [2/17] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -DGETTEXT_MSGFMT_EXECUTABLE=/usr/bin/msgfmt -DCOPY_TO=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/locale -DPO_DIR=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/po -P /usr/lib/cmake/KF5I18n/build-pofiles.cmake [3/17] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -E cmake_autogen /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/CMakeFiles/ktp-auth-handler_autogen.dir/AutogenInfo.json PLD && /usr/bin/cmake -E touch /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/timestamp && /usr/bin/cmake -E cmake_transform_depfile Ninja gccdepfile /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/deps /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/CMakeFiles/d/9eb6ae2d125c148885c3fce74412137714fa38428c42d0a918923ce9a5dd5b34.d [4/17] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -DKDE_UIC_EXECUTABLE:FILEPATH=/usr/lib/qt5/bin/uic -DKDE_UIC_FILE:FILEPATH=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-prompt.ui -DKDE_UIC_H_FILE:FILEPATH=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ui_x-telepathy-password-prompt.h -DKDE_UIC_BASENAME:STRING=x-telepathy-password-prompt -P /usr/lib/cmake/KF5I18n/kf5i18nuic.cmake [5/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/types.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/types.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/types.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/types.cpp [6/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/ktp-auth-handler_autogen/mocs_compilation.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/ktp-auth-handler_autogen/mocs_compilation.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/ktp-auth-handler_autogen/mocs_compilation.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_conference-auth-observer.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:2: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../conference-auth-observer.h:38:10: warning: ‘virtual void ConferenceAuthObserver::observeChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const ChannelDispatchOperationPtr&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const Tp::AbstractClientObserver::ObserverInfo&)’ can be marked override [-Wsuggest-override] 38 | void observeChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_sasl-handler.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:5: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../sasl-handler.h:43:10: warning: ‘virtual bool SaslHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 43 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../sasl-handler.h:45:10: warning: ‘virtual void SaslHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 45 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:57:72: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 57 | void showSslDialog(const QCA::CertificateChain &chain, const QList<KSslError> &errors) const; | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:58:14: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:58:62: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-cert-verifier-op.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:6: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/moc_tls-handler.cpp:10, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/mocs_compilation.cpp:7: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-handler.h:42:10: warning: ‘virtual bool TlsHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 42 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/EWIEGA46WW/../../../tls-handler.h:44:10: warning: ‘virtual void TlsHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 44 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ [7/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-prompt.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-prompt.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-prompt.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-prompt.cpp /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-prompt.cpp: In constructor ‘XTelepathyPasswordPrompt::XTelepathyPasswordPrompt(const AccountPtr&, QWidget*)’: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-prompt.cpp:39:25: warning: ‘void KTitleWidget::setPixmap(const QPixmap&, KTitleWidget::ImageAlignment)’ is deprecated: Since 5.72. Use KTitleWidget::setIcon(const QIcon &, ImageAlignment) [-Wdeprecated-declarations] 39 | ui->title->setPixmap(QIcon::fromTheme(account->iconName()).pixmap(22, 22)); | ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ui_x-telepathy-password-prompt.h:24, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-prompt.cpp:20: /usr/include/KF5/KWidgetsAddons/ktitlewidget.h:207:10: note: declared here 207 | void setPixmap(const QPixmap &pixmap, ImageAlignment alignment = ImageRight); | ^~~~~~~~~ [8/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/sasl-handler.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/sasl-handler.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/sasl-handler.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.h:43:10: warning: ‘virtual bool SaslHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 43 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.h:45:10: warning: ‘virtual void SaslHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 45 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ [9/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/tls-handler.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/tls-handler.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/tls-handler.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:20: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.h:42:10: warning: ‘virtual bool TlsHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 42 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.h:44:10: warning: ‘virtual void TlsHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 44 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:57:72: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 57 | void showSslDialog(const QCA::CertificateChain &chain, const QList<KSslError> &errors) const; | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:58:14: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:58:62: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.cpp:22: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ [10/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-auth-operation.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-auth-operation.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-auth-operation.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.cpp In file included from /usr/include/signon-qt5/SignOn/authsession.h:38, from /usr/include/signon-qt5/SignOn/identity.h:40, from /usr/include/signon-qt5/SignOn/Identity:1, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.cpp:38: /usr/include/signon-qt5/SignOn/sessiondata.h: In member function ‘SignOn::SessionData& SignOn::SessionData::operator+=(const SignOn::SessionData&)’: /usr/include/signon-qt5/SignOn/sessiondata.h:124:21: warning: ‘QMap<K, V>& QMap<K, V>::unite(const QMap<K, V>&) [with Key = QString; T = QVariant]’ is deprecated: Use QMultiMap for maps storing multiple values with the same key. [-Wdeprecated-declarations] 124 | m_data.unite(other.m_data); | ~~~~~~~~~~~~^~~~~~~~~~~~~~ In file included from /usr/include/qt5/QtCore/qvariant.h:47, from /usr/include/qt5/QtCore/QVariantList:1, from /usr/include/telepathy-qt5/TelepathyQt/_gen/types.h:12, from /usr/include/telepathy-qt5/TelepathyQt/types.h:30, from /usr/include/telepathy-qt5/TelepathyQt/Types:8, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.h:23, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.cpp:23: /usr/include/qt5/QtCore/qmap.h:1378:15: note: declared here 1378 | QMap<Key, T> &QMap<Key, T>::unite(const QMap<Key, T> &other) | ^~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.cpp:23: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.h: In constructor ‘XTelepathyPasswordAuthOperation::XTelepathyPasswordAuthOperation(const AccountPtr&, int, Tp::Client::ChannelInterfaceSASLAuthenticationInterface*, bool)’: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.h:56:10: warning: ‘XTelepathyPasswordAuthOperation::m_canFinish’ will be initialized after [-Wreorder] 56 | bool m_canFinish; | ^~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.h:54:9: warning: ‘int XTelepathyPasswordAuthOperation::m_accountStorageId’ [-Wreorder] 54 | int m_accountStorageId; | ^~~~~~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-password-auth-operation.cpp:40:1: warning: when initialized here [-Wreorder] 40 | XTelepathyPasswordAuthOperation::XTelepathyPasswordAuthOperation( | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ [11/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/main.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/main.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/main.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/main.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/main.cpp:38: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.h:43:10: warning: ‘virtual bool SaslHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 43 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-handler.h:45:10: warning: ‘virtual void SaslHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 45 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/main.cpp:39: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.h:42:10: warning: ‘virtual bool TlsHandler::bypassApproval() const’ can be marked override [-Wsuggest-override] 42 | bool bypassApproval() const; | ^~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-handler.h:44:10: warning: ‘virtual void TlsHandler::handleChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const QDateTime&, const Tp::AbstractClientHandler::HandlerInfo&)’ can be marked override [-Wsuggest-override] 44 | void handleChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/main.cpp:40: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/conference-auth-observer.h:38:10: warning: ‘virtual void ConferenceAuthObserver::observeChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const ChannelDispatchOperationPtr&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const Tp::AbstractClientObserver::ObserverInfo&)’ can be marked override [-Wsuggest-override] 38 | void observeChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~~ [12/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/sasl-auth-op.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/sasl-auth-op.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/sasl-auth-op.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/sasl-auth-op.cpp [13/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/x-telepathy-sso-google-operation.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/x-telepathy-sso-google-operation.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/x-telepathy-sso-google-operation.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/x-telepathy-sso-google-operation.cpp [14/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/tls-cert-verifier-op.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/tls-cert-verifier-op.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/tls-cert-verifier-op.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:57:72: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 57 | void showSslDialog(const QCA::CertificateChain &chain, const QList<KSslError> &errors) const; | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:58:14: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:58:62: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 58 | KSslError::Error validityToError(QCA::Validity validity) const; | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: In member function ‘bool TlsCertVerifierOp::verifyCertChain(const QCA::CertificateChain&)’: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:131:11: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 131 | QList<KSslError> errors; | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:135:26: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 135 | KSslError::Error error = validityToError(validity); | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:137:38: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 137 | errors << KSslError(error); | ^ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:137:38: warning: ‘KSslError::KSslError(KSslError::Error, const QSslCertificate&)’ is deprecated: Since 5.63. Use KSslError(const QSslError &) [-Wdeprecated-declarations] 137 | errors << KSslError(error); | ^ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:126:5: note: declared here 126 | KSslError(KSslError::Error error = NoError, const QSslCertificate &cert = QSslCertificate()); | ^~~~~~~~~ In file included from /usr/include/qt5/QtCore/QtGlobal:1, from /usr/include/telepathy-qt5/TelepathyQt/_gen/types.h:7, from /usr/include/telepathy-qt5/TelepathyQt/types.h:30, from /usr/include/telepathy-qt5/TelepathyQt/Types:8, from /usr/include/telepathy-qt5/TelepathyQt/_gen/cli-account.h:12, from /usr/include/telepathy-qt5/TelepathyQt/account.h:30, from /usr/include/telepathy-qt5/TelepathyQt/Account:8, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:25, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:147:32: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 147 | Q_FOREACH(const KSslError &error, errors) { | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:187:26: warning: ‘void KSslCertificateRule::setIgnoredErrors(const QList<KSslError>&)’ is deprecated: Since 5.64. Use KSslCertificateRule::setIgnoredErrors(const QList<QSslError> &) [-Wdeprecated-declarations] 187 | rule.setIgnoredErrors(errors); | ~~~~~~~~~~~~~~~~~~~~~^~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:32: /usr/include/KF5/KIOCore/ksslcertificatemanager.h:57:10: note: declared here 57 | void setIgnoredErrors(const QList<KSslError> &errors); | ^~~~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: At global scope: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:193:87: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 193 | void TlsCertVerifierOp::showSslDialog(const QCA::CertificateChain &chain, const QList<KSslError> &errors) const | ^~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ In file included from /usr/include/qt5/QtCore/QtGlobal:1, from /usr/include/telepathy-qt5/TelepathyQt/_gen/types.h:7, from /usr/include/telepathy-qt5/TelepathyQt/types.h:30, from /usr/include/telepathy-qt5/TelepathyQt/Types:8, from /usr/include/telepathy-qt5/TelepathyQt/_gen/cli-account.h:12, from /usr/include/telepathy-qt5/TelepathyQt/account.h:30, from /usr/include/telepathy-qt5/TelepathyQt/Account:8, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:25, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: In member function ‘void TlsCertVerifierOp::showSslDialog(const QCA::CertificateChain&, const QList<KSslError>&) const’: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:196:33: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 196 | Q_FOREACH (const KSslError &error, errors) { | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:203:16: warning: ‘KSslCipher’ is deprecated: Since 5.65. Use QSslCipher [-Wdeprecated-declarations] 203 | KSslCipher cipher = QSslCipher(QLatin1String("TLS"), QSsl::TlsV1_0); | ^~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:72:74: note: declared here 72 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslCipher") KSslCipher | ^~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:218:37: warning: ‘static QList<QList<KSslError::Error> > KSslInfoDialog::errorsFromString(const QString&)’ is deprecated: Since 5.65. use the QSslError variant [-Wdeprecated-declarations] 218 | KSslInfoDialog::errorsFromString(errorStr)); | ^~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:33: /usr/include/KF5/KIOWidgets/ksslinfodialog.h:104:43: note: declared here 104 | static QList<QList<KSslError::Error>> errorsFromString(const QString &s); // TODO KF6 remove | ^~~~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:218:53: warning: ‘static QList<QList<KSslError::Error> > KSslInfoDialog::errorsFromString(const QString&)’ is deprecated: Since 5.65. use the QSslError variant [-Wdeprecated-declarations] 218 | KSslInfoDialog::errorsFromString(errorStr)); | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:33: /usr/include/KF5/KIOWidgets/ksslinfodialog.h:104:43: note: declared here 104 | static QList<QList<KSslError::Error>> errorsFromString(const QString &s); // TODO KF6 remove | ^~~~~~~~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:211:23: warning: ‘void KSslInfoDialog::setSslInfo(const QList<QSslCertificate>&, const QString&, const QString&, const QString&, const QString&, int, int, const QList<QList<KSslError::Error> >&)’ is deprecated: Since 5.64. use the QSslError variant [-Wdeprecated-declarations] 211 | dialog->setSslInfo(qchain, | ~~~~~~~~~~~~~~~~~~^~~~~~~~ 212 | QString(), // we don't know the IP | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 213 | m_hostname, // the URL | ~~~~~~~~~~~~~~~~~~~~~~ 214 | QLatin1String("TLS"), | ~~~~~~~~~~~~~~~~~~~~~ 215 | sslCipher, | ~~~~~~~~~~ 216 | cipher.usedBits(), | ~~~~~~~~~~~~~~~~~~ 217 | cipher.supportedBits(), | ~~~~~~~~~~~~~~~~~~~~~~~ 218 | KSslInfoDialog::errorsFromString(errorStr)); | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:33: /usr/include/KF5/KIOWidgets/ksslinfodialog.h:65:10: note: declared here 65 | void setSslInfo(const QList<QSslCertificate> &certificateChain, | ^~~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: At global scope: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:224:77: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 224 | KSslError::Error TlsCertVerifierOp::validityToError(QCA::Validity validity) const | ^~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp: In member function ‘KSslError::Error TlsCertVerifierOp::validityToError(QCA::Validity) const’: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:228:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 228 | return KSslError::NoError; | ^~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:230:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 230 | return KSslError::RejectedCertificate; | ^~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:232:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 232 | return KSslError::UntrustedCertificate; | ^~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:234:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 234 | return KSslError::CertificateSignatureFailed; | ^~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:236:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 236 | return KSslError::InvalidCertificateAuthorityCertificate; | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:238:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 238 | return KSslError::InvalidCertificatePurpose; | ^~~~~~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:240:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 240 | return KSslError::SelfSignedCertificate; | ^~~~~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:242:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 242 | return KSslError::RevokedCertificate; | ^~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:244:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 244 | return KSslError::PathLengthExceeded; | ^~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:247:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 247 | return KSslError::ExpiredCertificate; | ^~~~~~~~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:249:31: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 249 | return KSslError::UnknownError; | ^~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:252:23: warning: ‘KSslError’ is deprecated: Since 5.65. Use QSslError [-Wdeprecated-declarations] 252 | return KSslError::UnknownError; | ^~~~~~~~~~~~ In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.h:36, from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/tls-cert-verifier-op.cpp:21: /usr/include/KF5/KIOCore/ktcpsocket.h:103:73: note: declared here 103 | class KIOCORE_EXPORT KIOCORE_DEPRECATED_VERSION(5, 65, "Use QSslError") KSslError | ^~~~~~~~~ [15/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/conference-auth-observer.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/conference-auth-observer.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/conference-auth-observer.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/conference-auth-observer.cpp In file included from /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/conference-auth-observer.cpp:20: /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/conference-auth-observer.h:38:10: warning: ‘virtual void ConferenceAuthObserver::observeChannels(const Tp::MethodInvocationContextPtr<>&, const AccountPtr&, const ConnectionPtr&, const QList<Tp::SharedPtr<Tp::Channel> >&, const ChannelDispatchOperationPtr&, const QList<Tp::SharedPtr<Tp::ChannelRequest> >&, const Tp::AbstractClientObserver::ObserverInfo&)’ can be marked override [-Wsuggest-override] 38 | void observeChannels(const Tp::MethodInvocationContextPtr<> &context, | ^~~~~~~~~~~~~~~ [16/17] /usr/bin/i686-pld-linux-g++ -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 -I/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/ktp-auth-handler_autogen/include -I/usr/include/signon-qt5 -isystem /usr/include/accounts-qt5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtDBus -isystem /usr/include/qt5/QtCore -isystem /usr/lib/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KWallet -isystem /usr/include/KF5 -isystem /usr/include/qt5/QtGui -isystem /usr/include/telepathy-qt5 -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/Qca-qt5/QtCrypto -isystem /usr/include/KAccounts -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KIO -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfig -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KIOGui -isystem /usr/include/KF5/KWindowSystem -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/Solid -isystem /usr/include/KF5/KCompletion -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -std=gnu++11 -MD -MT CMakeFiles/ktp-auth-handler.dir/conference-auth-op.cpp.o -MF CMakeFiles/ktp-auth-handler.dir/conference-auth-op.cpp.o.d -o CMakeFiles/ktp-auth-handler.dir/conference-auth-op.cpp.o -c /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/conference-auth-op.cpp [17/17] : && /usr/bin/i686-pld-linux-g++ -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Werror=init-self -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fomit-frame-pointer -march=i686 -fasynchronous-unwind-tables -mtune=pentium4 -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -DQT_NO_DEBUG -Wl,--enable-new-dtags -Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc CMakeFiles/ktp-auth-handler.dir/ktp-auth-handler_autogen/mocs_compilation.cpp.o CMakeFiles/ktp-auth-handler.dir/main.cpp.o CMakeFiles/ktp-auth-handler.dir/sasl-handler.cpp.o CMakeFiles/ktp-auth-handler.dir/sasl-auth-op.cpp.o CMakeFiles/ktp-auth-handler.dir/tls-cert-verifier-op.cpp.o CMakeFiles/ktp-auth-handler.dir/tls-handler.cpp.o CMakeFiles/ktp-auth-handler.dir/types.cpp.o CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-auth-operation.cpp.o CMakeFiles/ktp-auth-handler.dir/x-telepathy-password-prompt.cpp.o CMakeFiles/ktp-auth-handler.dir/x-telepathy-sso-google-operation.cpp.o CMakeFiles/ktp-auth-handler.dir/conference-auth-op.cpp.o CMakeFiles/ktp-auth-handler.dir/conference-auth-observer.cpp.o -o ktp-auth-handler /usr/lib/libKTpCommonInternals.so.22.04.1 /usr/lib/libqca-qt5.so.2.3.4 /usr/lib/libaccounts-qt5.so /usr/lib/libsignon-qt5.so /usr/lib/libkaccounts.so.22.04.1 /usr/lib/libKF5Wallet.so.5.94.0 /usr/lib/libKF5KIOWidgets.so.5.94.0 /usr/lib/libKF5KIOGui.so.5.94.0 /usr/lib/libKF5KIOCore.so.5.94.0 /usr/lib/libQt5Concurrent.so.5.15.4 /usr/lib/libKF5Service.so.5.94.0 /usr/lib/libKF5JobWidgets.so.5.94.0 /usr/lib/libKF5Solid.so.5.94.0 /usr/lib/libKF5Completion.so.5.94.0 /usr/lib/libKF5WindowSystem.so.5.94.0 /usr/lib/libX11.so /usr/lib/libKF5WidgetsAddons.so.5.94.0 /usr/lib/libKF5ConfigCore.so.5.94.0 /usr/lib/libQt5Widgets.so.5.15.4 /usr/lib/libtelepathy-qt5.so.0.0.9.8 /usr/lib/libQt5DBus.so.5.15.4 /usr/lib/libQt5Network.so.5.15.4 -fPIC /usr/lib/libaccounts-qt5.so /usr/lib/libKF5I18n.so.5.94.0 /usr/lib/libQt5Xml.so.5.15.4 /usr/lib/libKF5CoreAddons.so.5.94.0 /usr/lib/libQt5Gui.so.5.15.4 /usr/lib/libQt5Core.so.5.15.4 && : + RPM_EC=0 + jobs -p + exit 0 Executing(%install): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.fFfWyH TMP=/home/users/builder/tmp HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/bin:/usr/bin:/usr/local/bin:/home/users/builder/bin TMPDIR=/tmp/B.kj16uz3w/BUILD/tmp + umask 022 + cd /tmp/B.kj16uz3w/BUILD + /bin/rm '--interactive=never' -rf /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder + /bin/mkdir -p /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder + cd ktp-auth-handler-22.04.1 + rm -rf /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder + LC_ALL=C.UTF-8 DESTDIR=/tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder /usr/bin/ninja install -v -j9 -C build ninja: Entering directory `build' [1/3] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -DPYTHON_EXECUTABLE=/usr/bin/python3 -D_ki18n_pmap_compile_script=/usr/lib/cmake/KF5I18n/ts-pmap-compile.py -DCOPY_TO=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/locale -DPO_DIR=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/po -P /usr/lib/cmake/KF5I18n/build-tsfiles.cmake [2/3] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -DGETTEXT_MSGFMT_EXECUTABLE=/usr/bin/msgfmt -DCOPY_TO=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build/locale -DPO_DIR=/tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/po -P /usr/lib/cmake/KF5I18n/build-pofiles.cmake [2/3] cd /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1/build && /usr/bin/cmake -P cmake_install.cmake -- Install configuration: "PLD" -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/libexec/ktp-auth-handler -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.SASLHandler.service -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.ConfAuthObserver.service -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.TLSHandler.service -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/telepathy/clients/KTp.SASLHandler.client -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/telepathy/clients/KTp.TLSHandler.client -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/telepathy/clients/KTp.ConfAuthObserver.client -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ar -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ar/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ar/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/bs -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/bs/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/bs/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca@valencia -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca@valencia/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ca@valencia/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/cs -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/cs/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/cs/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/da -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/da/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/da/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/de -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/de/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/de/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/el -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/el/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/el/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/en_GB -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/en_GB/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/en_GB/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/es -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/es/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/es/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/et -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/et/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/et/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/eu -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/eu/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/eu/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fi -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fi/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fi/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fr -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fr/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/fr/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ga -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ga/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ga/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/gl -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/gl/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/gl/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hi -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hi/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hi/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hu -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hu/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/hu/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ia -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ia/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ia/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/it -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/it/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/it/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ja -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ja/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ja/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/kk -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/kk/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/kk/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/km -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/km/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/km/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ko -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ko/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ko/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/lt -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/lt/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/lt/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/mr -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/mr/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/mr/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nb -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nb/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nb/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nds -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nds/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nds/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nl -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nl/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nl/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nn -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nn/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/nn/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pl -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pl/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pl/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt_BR -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt_BR/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/pt_BR/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ro -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ro/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ro/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ru -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ru/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ru/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sk -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sk/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sk/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sl -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sl/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sl/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sr -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sr/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sr/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sv -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sv/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/sv/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/tr -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/tr/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/tr/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ug -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ug/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/ug/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/uk -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/uk/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/uk/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/vi -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/vi/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/vi/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_CN -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_CN/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_CN/LC_MESSAGES/ktp-auth-handler.mo -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_TW -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_TW/LC_MESSAGES -- Installing: /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/share/locale/zh_TW/LC_MESSAGES/ktp-auth-handler.mo + /usr/lib/rpm/find-lang.sh /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder ktp-auth-handler --all-name --with-kde find-lang.sh: Enabling with all names find-lang.sh: Enabling with KDE find-lang.sh/1.40: find-lang 'ktp-auth-handler' > ktp-auth-handler.lang + /usr/lib/rpm/find-debuginfo.sh -j8 --build-id-seed 22.04.1-1 --unique-debug-suffix -22.04.1-1.i686 --unique-debug-src-base ka5-ktp-auth-handler-22.04.1-1.i686 -S debugsourcefiles.list /tmp/B.kj16uz3w/BUILD/ktp-auth-handler-22.04.1 extracting debug info from /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder/usr/libexec/ktp-auth-handler 229 blocks + __spec_install_post_strip + set +x Stripping 1 ELF executables...DONE + __spec_install_post_chrpath + set +x Remove RPATH/RUNPATH from 1 executable binaries and shared object files. + __spec_install_post_compress_modules + set +x + __spec_install_post_check_so + set +x Searching for shared objects with unresolved symbols... DONE + __spec_install_post_check_tmpfiles + set +x Checking /var/run <-> tmpfiles.d completeness... DONE + __spec_install_post_check_shebangs + set +x Checking script shebangs... DONE + __spec_install_post_compress_docs + set +x + __spec_install_post_py_hardlink + set +x Processing files: ka5-ktp-auth-handler-22.04.1-1.i686 Provides: ka5-ktp-auth-handler = 22.04.1-1 ka5-ktp-auth-handler(x86-32) = 22.04.1-1 Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 Requires: libKF5ConfigCore.so.5 libKF5CoreAddons.so.5 libKF5I18n.so.5 libKF5KIOCore.so.5 libKF5KIOWidgets.so.5 libKF5WidgetsAddons.so.5 libKTpCommonInternals.so.9 libQt5Core.so.5 libQt5Core.so.5(Qt_5) libQt5Core.so.5(Qt_5.15) libQt5DBus.so.5 libQt5DBus.so.5(Qt_5) libQt5Gui.so.5 libQt5Gui.so.5(Qt_5) libQt5Network.so.5 libQt5Network.so.5(Qt_5) libQt5Widgets.so.5 libQt5Widgets.so.5(Qt_5) libaccounts-qt5.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.34) libc.so.6(GLIBC_2.4) libkaccounts.so.2 libqca-qt5.so.2 libsignon-qt5.so.1 libstdc++.so.6 libstdc++.so.6(CXXABI_1.3) libstdc++.so.6(GLIBCXX_3.4) libtelepathy-qt5.so.0 rtld(GNU_HASH) Processing files: ka5-ktp-auth-handler-debugsource-22.04.1-1.i686 Provides: ka5-ktp-auth-handler-debugsource = 22.04.1-1 ka5-ktp-auth-handler-debugsource(x86-32) = 22.04.1-1 Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 Processing files: ka5-ktp-auth-handler-debuginfo-22.04.1-1.i686 Provides: ka5-ktp-auth-handler-debuginfo = 22.04.1-1 ka5-ktp-auth-handler-debuginfo(x86-32) = 22.04.1-1 Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 Recommends: ka5-ktp-auth-handler-debugsource(x86-32) = 22.04.1-1 Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder warning: Installed (but unpackaged) file(s) found: /usr/share/locale/ja/LC_MESSAGES/ktp-auth-handler.mo Wrote: /tmp/B.kj16uz3w/RPMS/ka5-ktp-auth-handler-debugsource-22.04.1-1.i686.rpm Wrote: /tmp/B.kj16uz3w/RPMS/ka5-ktp-auth-handler-22.04.1-1.i686.rpm Wrote: /tmp/B.kj16uz3w/RPMS/ka5-ktp-auth-handler-debuginfo-22.04.1-1.i686.rpm Executing(%clean): /bin/sh -e /tmp/B.kj16uz3w/BUILD/tmp/rpm-tmp.n72gvX + umask 022 + cd /tmp/B.kj16uz3w/BUILD + cd ktp-auth-handler-22.04.1 + rm -rf /tmp/B.kj16uz3w/BUILD/tmp/ka5-ktp-auth-handler-22.04.1-i686-root-builder + RPM_EC=0 + jobs -p + exit 0 ended at: Wed May 18 12:46:09 2022, done in 0:00:25.837752 + chmod -R u+rwX /tmp/B.kj16uz3w/BUILD + rm -rf /tmp/B.kj16uz3w/tmp /tmp/B.kj16uz3w/BUILD copy rpm files to cache_dir: /spools/ready Creating pndir index of /spools/ready/ (type=dir)... Loading [pndir]previous /spools/ready/packages.ndir.gz... Loading [dir]/spools/ready/... 200..400..600..800..1000..1200..1400..1600..1800..1891 Writing /spools/ready/packages.ndir.gz... Begin-PLD-Builder-Info upgrading packages End-PLD-Builder-Info + rm -rf /tmp/B.kj16uz3w Begin-PLD-Builder-Info Build-Time: user:110.39s sys:8.85s real:30.07s (faults io:50 non-io:1457800) Files queued for ftp: 3528309 ka5-ktp-auth-handler-debuginfo-22.04.1-1.i686.rpm 91797 ka5-ktp-auth-handler-22.04.1-1.i686.rpm 29277 ka5-ktp-auth-handler-debugsource-22.04.1-1.i686.rpm 226 ka5-ktp-auth-handler-22.04.1-1.src.rpm.uploadinfo warning: Installed (but unpackaged) file(s) found: /usr/share/locale/ja/LC_MESSAGES/ktp-auth-handler.mo End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]