FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2024 PLD Team
$Revision: 1.37 $
Powered by KDE.
Your IP: 3.239.76.25

freetype 64174f30-dea6-4a0d-a59a-21ab6a693e66

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x32/FAIL/freetype,64174f30-dea6-4a0d-a59a-21ab6a693e66.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2023/11/26 09:54:09

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • error 3
  • poldek: error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlicommon.la) not found
  • error 4
  • poldek: error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlidec.la) not found
  • error 5
  • poldek: error: harfbuzz-devel-8.3.0-1.x32: req pkgconfig(freetype2) >= 12.0.6 not found
  • error 6
  • poldek: error: 3 unresolved dependencies
  • error 7
  • poldek: error: Failed dependencies:
  • error 8
  • error: freetype-devel: no such package
  • error 9
  • rpm: error: Failed build dependencies:
  • error 10
  • error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlicommon.la) not found
  • error 11
  • error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlidec.la) not found
  • error 12
  • error: harfbuzz-devel-8.3.0-1.x32: req pkgconfig(freetype2) >= 12.0.6 not found
  • error 13
  • error: 3 unresolved dependencies
  • error 14
  • error: BR installation failed

Content:

checking if we should skip the build
started at: Sun Nov 26 09:53:59 2023
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/64174f30-dea6-4a0d-a59a-21ab6a693e66/freetype-2.13.2-2.src.rpm
fetched 5036509 bytes, 9994.4 K/s
installing srpm: freetype-2.13.2-2.src.rpm
+ install -d /tmp/B.klu_9_hx/BUILD /tmp/B.klu_9_hx/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog freetype-2.13.2-2.src.rpm
* Sun Nov 26 2023 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/freetype.git;a=log;h=master
* Sun Nov 26 2023 Jakub Bogusz <qboosh@pld-linux.org> 6e1991c
- release 2 (rebuild with brotli without libbrotlidec.la) * Sat Aug 26 2023 Jan Palus <atler@pld-linux.org> 15d6a91
- up to 2.13.2 * Sat Jun 24 2023 Jan Palus <atler@pld-linux.org> ec62729
- up to 2.13.1 * Thu Feb 09 2023 Jan Palus <atler@pld-linux.org> d9b7334
- up to 2.13.0 * Wed May 04 2022 Jan Palus <atler@pld-linux.org> 2740e24
- up to 2.12.1 * Sat Apr 02 2022 Jan Palus <jpalus@fastmail.com> e7e84fa
- rpm version for noarch subpackage * Sat Apr 02 2022 Jan Palus <jpalus@fastmail.com> 091ad2b
- up to 2.12.0 * Sun Dec 05 2021 Jakub Bogusz <qboosh@pld-linux.org> 8eb15c2
- updated to 2.11.1 * Tue Jul 20 2021 Jan Palus <atler@pld-linux.org> 2d27cfc
- up to 2.11.0 * Sun Feb 28 2021 Jan Rękorajski <baggins@pld-linux.org> d86c191
- unconditional noarch subpackages * Tue Oct 20 2020 Jan Palus <atler@pld-linux.org> 1c42c73
- up to 2.10.4 (fixes CVE-2020-15999) * Sun Oct 11 2020 Jan Palus <atler@pld-linux.org> 4ef0e2d
- up to 2.10.3 * Sat May 09 2020 Jakub Bogusz <qboosh@pld-linux.org> 545dd93
- updated harfbuzz version, requires libbrotli now (for WOFF2) * Sat May 09 2020 Jan Palus <atler@pld-linux.org> 66b30f6
- up to 2.10.2 * Tue Jul 02 2019 Jakub Bogusz <qboosh@pld-linux.org> 99c80ee
- release 2 * Tue Jul 02 2019 Jakub Bogusz <qboosh@pld-linux.org> 15a0db7
- updated ft2demos-includes patch * Tue Jul 02 2019 Adam Gołębiowski <adamg@pld-linux.org> 7e514e9
- updated to 2.10.1 * Mon Mar 25 2019 Jakub Bogusz <qboosh@pld-linux.org> 177829a
- updated harfbuzz version * Sun Mar 17 2019 Jan Palus <atler@pld-linux.org> 2cd2939
- missing patch update * Sun Mar 17 2019 Jan Palus <atler@pld-linux.org> 410d8e2
- use reference docs provided in tarball until docwriter is packaged; rel 1 + rpm -Uhv --nodeps --define '_topdir /tmp/B.klu_9_hx' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --without x11 freetype-2.13.2-2.src.rpm Updating / installing... freetype-1:2.13.2-2 ######################################## + rm -f freetype-2.13.2-2.src.rpm + install -m 700 -d /tmp/B.klu_9_hx/BUILD/tmp + TMPDIR=/tmp/B.klu_9_hx/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.klu_9_hx' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --without x11 --target x32-pld-linux --define 'prep exit 0' /tmp/B.klu_9_hx/freetype.spec warning: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 warning: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel warning: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static warning: Macro expanded in comment on line 219: %{_libdir} through *.la Building target platforms: x32-pld-linux Building for target x32-pld-linux RPM build warnings: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static Macro expanded in comment on line 219: %{_libdir} through *.la checking BuildConflict-ing packages rpm: warning: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: warning: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: warning: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static rpm: error: Failed build dependencies: rpm: harfbuzz-devel >= 2.0.0 is needed by freetype-1:2.13.2-2.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux rpm: rpm: RPM build warnings: rpm: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static no BuildConflicts found checking BR rpm: warning: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: warning: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: warning: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static rpm: error: Failed build dependencies: rpm: harfbuzz-devel >= 2.0.0 is needed by freetype-1:2.13.2-2.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux rpm: rpm: RPM build warnings: rpm: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date th-test is up to date th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 31124 packages read poldek: Removed 2581 duplicate packages from available set poldek: Processing dependencies... poldek: harfbuzz-devel-8.3.0-1.x32 marks freetype-devel-2.13.2-1.x32 (cap freetype-devel >= 1:2.11) poldek: error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlicommon.la) not found poldek: error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlidec.la) not found poldek: error: harfbuzz-devel-8.3.0-1.x32: req pkgconfig(freetype2) >= 12.0.6 not found poldek: There are 2 packages to install (1 marked by dependencies): poldek: A freetype-devel-2.13.2-1.x32 harfbuzz-devel-8.3.0-1.x32 poldek: This operation will use 2.5MB of disk space. poldek: harfbuzz-devel-8.3.0-1.x32.rpm: digests OK poldek: freetype-devel-2.13.2-1.x32.rpm: digests OK poldek: Need to get 305.6KB of archives. poldek: error: 3 unresolved dependencies poldek: harfbuzz-devel-8.3.0-1.x32.rpm: digests OK poldek: freetype-devel-2.13.2-1.x32.rpm: digests OK poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 0... poldek: warning: /root/.cache/poldek/ftp_ftp1.pld-linux.org.dists.th.ready.x32.RPMS/harfbuzz-devel-8.3.0-1.x32.rpm: Header V4 DSA/SHA1 Signature, key ID e4f1bc2d: NOKEY poldek: error: Failed dependencies: poldek: libtool(/usr/libx32/libbrotlicommon.la) is needed by freetype-devel-1:2.13.2-1.x32 poldek: libtool(/usr/libx32/libbrotlidec.la) is needed by freetype-devel-1:2.13.2-1.x32 uninstalling conflicting packages removing freetype-devel error: freetype-devel: no such package package freetype-devel removal failed checking BR rpm: warning: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: warning: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: warning: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static rpm: error: Failed build dependencies: rpm: harfbuzz-devel >= 2.0.0 is needed by freetype-1:2.13.2-2.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux rpm: rpm: RPM build warnings: rpm: line 58: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2 rpm: line 130: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-devel rpm: line 179: It's not recommended to have unversioned Obsoletes: Obsoletes: freetype2-static installing BR: harfbuzz\-devel + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' '--ignore=php73-*' '--ignore=php74-*' '--ignore=php80-*' '--ignore=php81-*' '--ignore=php82-*' --upgrade harfbuzz-devel Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 31124 packages read Removed 2581 duplicate packages from available set Processing dependencies... harfbuzz-devel-8.3.0-1.x32 marks freetype-devel-2.13.2-1.x32 (cap freetype-devel >= 1:2.11) error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlicommon.la) not found error: freetype-devel-2.13.2-1.x32: req libtool(/usr/libx32/libbrotlidec.la) not found error: harfbuzz-devel-8.3.0-1.x32: req pkgconfig(freetype2) >= 12.0.6 not found There are 2 packages to install (1 marked by dependencies): A freetype-devel-2.13.2-1.x32 harfbuzz-devel-8.3.0-1.x32 This operation will use 2.5MB of disk space. harfbuzz-devel-8.3.0-1.x32.rpm: digests OK freetype-devel-2.13.2-1.x32.rpm: digests OK Need to get 305.6KB of archives. error: 3 unresolved dependencies error: BR installation failed + chmod -R u+rwX /tmp/B.klu_9_hx/BUILD + rm -rf /tmp/B.klu_9_hx/tmp /tmp/B.klu_9_hx/BUILD + rm -rf /tmp/B.klu_9_hx Begin-PLD-Builder-Info Build-Time: user:5.41s sys:2.24s real:9.88s (faults io:0 non-io:318607) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]