FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2022 PLD Team
$Revision: 1.37 $
Powered by Real Programmer.
Your IP: 34.229.119.176

rust ef51c452-619b-487c-b9aa-445c60c0b1c3

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x32/FAIL/rust,ef51c452-619b-487c-b9aa-445c60c0b1c3.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2022/09/27 00:18:00

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • error 3
  • poldek: error: curl-devel(x86-64): no such package
  • error 4
  • poldek: error: libgit2-devel(x86-64): no such package
  • error 5
  • poldek: error: xz-devel(x86-64): no such package
  • error 6
  • poldek: error: zlib-devel(x86-64): no such package
  • error 7
  • rpm: error: Failed build dependencies:
  • error 8
  • error: curl-devel(x86-64): no such package
  • error 9
  • error: libgit2-devel(x86-64): no such package
  • error 10
  • error: xz-devel(x86-64): no such package
  • error 11
  • error: zlib-devel(x86-64): no such package
  • error 12
  • error: BR installation failed

Content:

request from: atler
checking if we should skip the build
started at: Tue Sep 27 00:16:56 2022
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/ef51c452-619b-487c-b9aa-445c60c0b1c3/rust-1.64.0-1.src.rpm
fetched 1161591523 bytes, 28598.2 K/s
installing srpm: rust-1.64.0-1.src.rpm
+ install -d /tmp/B.xh1nobke/BUILD /tmp/B.xh1nobke/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog rust-1.64.0-1.src.rpm
* Mon Sep 26 2022 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/rust.git;a=log;h=master
* Sun Sep 25 2022 Jan Palus <atler@pld-linux.org> f397d93
- up to 1.64.0 * Fri Aug 12 2022 Jan Palus <atler@pld-linux.org> 961e36e
- up to 1.63.0 * Tue Jul 19 2022 Jan Palus <atler@pld-linux.org> 6ee75d5
- up to 1.62.1 * Sat Jul 02 2022 Jan Palus <atler@pld-linux.org> 79a067d
- BR: xz-devel * Fri Jul 01 2022 Jan Palus <atler@pld-linux.org> 98f7667
- up to 1.62.0 * Tue Jun 28 2022 Jan Palus <atler@pld-linux.org> 8745efa
- bump required system libgit2 version; rel 2 * Tue May 31 2022 Jan Palus <atler@pld-linux.org> 595dfba
- up to 1.61.0 * Fri Apr 08 2022 Jan Palus <atler@pld-linux.org> 61cdf6a
- up to 1.60.0 * Thu Feb 24 2022 Jan Palus <atler@pld-linux.org> 511647d
- up to 1.59.0 * Tue Jan 25 2022 Jan Rękorajski <baggins@pld-linux.org> 417178e
- requires gcc-multilib-64 on x32 for proper cross compiling, rel 4 * Tue Jan 25 2022 Jan Palus <atler@pld-linux.org> 13ab053
- define cc/cxx/ar also during install * Sun Jan 23 2022 Jan Palus <atler@pld-linux.org> f78840a
- bin dir also not available on x32; rel 3 * Sat Jan 22 2022 Jan Palus <atler@pld-linux.org> df90c04
- no rust-llvm-dwp on x32; rel 2 * Thu Jan 20 2022 Jan Palus <atler@pld-linux.org> 5c688b5
- up to 1.58.1 (fixes CVE-2022-21658) * Wed Jan 19 2022 Jan Palus <atler@pld-linux.org> aea1d26
- up to 1.58.0 * Mon Jan 10 2022 Jan Palus <atler@pld-linux.org> 6c4856c
- build tier 2 target "thumbv7neon" on armv7hnl * Mon Jan 10 2022 Jan Palus <atler@pld-linux.org> 62473c9
- add support for building multiple targets * Mon Jan 10 2022 Jan Palus <atler@pld-linux.org> 863a59f
- explicitly set cc/cxx/ar * Tue Dec 28 2021 Jakub Bogusz <qboosh@pld-linux.org> 1736a04
- package rust-demangler and rust-llvm-dwp * Sat Dec 04 2021 Jan Palus <atler@pld-linux.org> e65d284
- use python3 for invoking build scripts + rpm -Uhv --nodeps --define '_topdir /tmp/B.xh1nobke' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' rust-1.64.0-1.src.rpm Updating / installing... rust-1.64.0-1 ######################################## + rm -f rust-1.64.0-1.src.rpm + install -m 700 -d /tmp/B.xh1nobke/BUILD/tmp + TMPDIR=/tmp/B.xh1nobke/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.xh1nobke' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x32-pld-linux --define 'prep exit 0' /tmp/B.xh1nobke/rust.spec warning: Macro expanded in comment on line 380: %{__rm} -r src/jemalloc Building target platforms: x32-pld-linux Building for target x32-pld-linux RPM build warnings: Macro expanded in comment on line 380: %{__rm} -r src/jemalloc checking BuildConflict-ing packages rpm: error: Failed build dependencies: rpm: curl-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: libgit2-devel(x86-64) >= 1.4.0 is needed by rust-1.64.0-1.x32 rpm: xz-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: zlib-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux no BuildConflicts found checking BR rpm: error: Failed build dependencies: rpm: curl-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: libgit2-devel(x86-64) >= 1.4.0 is needed by rust-1.64.0-1.x32 rpm: xz-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: zlib-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date Retrieving diff::packages.ndir.2022.09.25-20.23.02.gz......................................done Retrieving diff::packages.ndir.dscr.2022.09.25-20.23.02.gz.................................done Loading [pndir]th-test... Applying packages.ndir.2022.09.25-20.23.02.gz... Retrieving diff::packages.ndir.2022.09.26-21.51.09.gz......................................done Applying packages.ndir.2022.09.26-21.51.09.gz... Applying packages.ndir.2022.09.26-21.53.02.gz... Writing /root/.cache/poldek/[...]/packages.ndir.gz... Retrieving diff::packages.ndir.2022.09.25-20.23.03.gz......................................done Loading [pndir]th-test... Applying packages.ndir.2022.09.25-20.23.03.gz... Retrieving diff::packages.ndir.2022.09.26-21.56.02.gz......................................done Applying packages.ndir.2022.09.26-21.56.02.gz... Writing /root/.cache/poldek/[...]/packages.ndir.gz... checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 30955 packages read poldek: Removed 3474 duplicate packages from available set poldek: error: curl-devel(x86-64): no such package poldek: error: libgit2-devel(x86-64): no such package poldek: error: xz-devel(x86-64): no such package poldek: error: zlib-devel(x86-64): no such package no conflicts found checking BR rpm: error: Failed build dependencies: rpm: curl-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: libgit2-devel(x86-64) >= 1.4.0 is needed by rust-1.64.0-1.x32 rpm: xz-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: zlib-devel(x86-64) is needed by rust-1.64.0-1.x32 rpm: Building target platforms: x32-pld-linux rpm: Building for target x32-pld-linux installing BR: curl\-devel\(x86\-64\) libgit2\-devel\(x86\-64\) xz\-devel\(x86\-64\) zlib\-devel\(x86\-64\) + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' '--ignore=php73-*' '--ignore=php74-*' '--ignore=php80-*' '--ignore=php81-*' --upgrade 'curl-devel(x86-64)' 'libgit2-devel(x86-64)' 'xz-devel(x86-64)' 'zlib-devel(x86-64)' Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 30955 packages read Removed 3474 duplicate packages from available set error: curl-devel(x86-64): no such package error: libgit2-devel(x86-64): no such package error: xz-devel(x86-64): no such package error: zlib-devel(x86-64): no such package error: BR installation failed + chmod -R u+rwX /tmp/B.xh1nobke/BUILD + rm -rf /tmp/B.xh1nobke/tmp /tmp/B.xh1nobke/BUILD + rm -rf /tmp/B.xh1nobke Begin-PLD-Builder-Info Build-Time: user:14.98s sys:4.87s real:63.73s (faults io:0 non-io:256286) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]