FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by PDP-11.
Your IP: 3.239.7.207

kicad 16e1bd33-9446-4481-94fc-f901edabe133

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/kicad,16e1bd33-9446-4481-94fc-f901edabe133.bz2
text/plain URL:View!
full text:View!
rpm -qa of builder:View!
Date:2021/05/16 10:18:28
Runtime:0:03:03.691304

Toc:

  • error 1
  • error: Bad exit status from /tmp/B.jBG5Ie/BUILD/tmp/rpm-tmp.wl9ky7 (%build)
  • error 2
  • RPM build errors:
  • error 3
  • error: No files produced.

Content:

make[1]: Nothing to be done for 'all'.
/usr/bin/cmake -E cmake_progress_start /tmp/B.jBG5Ie/BUILD/kicad-5.1.10/kicad-i18n-5.1.10/build/CMakeFiles 0
+ cd ../..
+ mkdir build
+ cd build
+ CC=x86_64-pld-linux-gcc CXX=x86_64-pld-linux-g++ CPPFLAGS='' /usr/bin/cmake -Wno-dev '-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON' '-DCMAKE_BUILD_TYPE=PLD' '-DCMAKE_INSTALL_BINDIR:PATH=/usr/bin' '-DCMAKE_INSTALL_SBINDIR:PATH=/usr/sbin' '-DCMAKE_INSTALL_LIBEXECDIR:PATH=/usr/libexec' '-DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc' '-DCMAKE_INSTALL_SHAREDSTATEDIRPATH:PATH=/var/lib' '-DCMAKE_INSTALL_LOCALSTATEDIRPATH:PATH=/var' '-DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib64' '-DCMAKE_INSTALL_INCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_OLDINCLUDEDIR:PATH=/usr/include' '-DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share' '-DCMAKE_INSTALL_DATADIR:PATH=/usr/share' '-DCMAKE_INSTALL_INFODIR:PATH=/usr/share/info' '-DCMAKE_INSTALL_LOCALEDIR:PATH=/usr/share/locale' '-DCMAKE_INSTALL_MANDIR:PATH=/usr/share/man' '-DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/doc' '-DCMAKE_INSTALL_PREFIX:PATH=/usr' '-DSYSCONF_INSTALL_DIR:PATH=/etc' '-DCMAKE_CXX_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2  -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_C_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2  -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_Fortran_FLAGS_PLD=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2  -DNDEBUG -DQT_NO_DEBUG' '-DCMAKE_EXE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_SHARED_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DCMAKE_MODULE_LINKER_FLAGS_PLD=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' '-DLIB_SUFFIX=64' '-DBUILD_SHARED_LIBS:BOOL=ON' .. '-DKICAD_BUILD_VERSION=5.1.10-1' '-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk2-unicode-config' '-DKICAD_SCRIPTING=ON' '-DKICAD_SCRIPTING_MODULES=ON' '-DKICAD_SCRIPTING_WXPYTHON=ON' '-DKICAD_BUILD_QA_TESTS:BOOL=ON'
-- The C compiler identification is GNU 10.3.0
-- The CXX compiler identification is GNU 10.3.0
-- Check for working C compiler: /usr/bin/x86_64-pld-linux-gcc
-- Check for working C compiler: /usr/bin/x86_64-pld-linux-gcc - works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/x86_64-pld-linux-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pld-linux-g++ - works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- KiCad install dir: </usr>
-- Looking for malloc.h
-- Looking for malloc.h - found
-- Looking for iso646.h
-- Looking for iso646.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for strcasecmp
-- Looking for strcasecmp - found
-- Looking for strncasecmp
-- Looking for strncasecmp - found
-- Looking for strtok_r
-- Looking for strtok_r - found
-- Looking for malloc
-- Looking for malloc - found
-- Looking for math.h
-- Looking for math.h - found
-- Looking for C++ include cmath
-- Looking for C++ include cmath - found
-- Looking for asinh
-- Looking for asinh - found
-- Looking for acosh
-- Looking for acosh - found
-- Looking for atanh
-- Looking for atanh - found
-- Performing Test HAVE_CMATH_ISINF
-- Performing Test HAVE_CMATH_ISINF - Success
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- Looking for gettimeofday
-- Looking for gettimeofday - found
-- Looking for getc_unlocked
-- Looking for getc_unlocked - found
-- Performing Test COMPILER_SUPPORTS_WSUGGEST_OVERRIDE
-- Performing Test COMPILER_SUPPORTS_WSUGGEST_OVERRIDE - Success
-- Performing Test COMPILER_SUPPORTS_WVLA
-- Performing Test COMPILER_SUPPORTS_WVLA - Success
-- Performing Test COMPILER_SUPPORTS_WSHADOW
-- Performing Test COMPILER_SUPPORTS_WSHADOW - Success
-- Found OpenGL: /usr/lib64/libGL.so   
-- Found GLEW: /usr/include  
-- Check for installed GLEW -- found
-- Found GLM: /usr/include (found suitable version "0.9.9.8", minimum required is "0.9.5.1") 
-- Found CURL: /usr/lib64/libcurl.so (found version "7.76.1")  
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.2") 
-- Checking for module 'cairo'
--   Found cairo, version 1.16.0
-- Found Cairo: /usr/lib64/libcairo.so (found suitable version "1.16.0", minimum required is "1.12") 
-- Checking for module 'pixman-1'
--   Found pixman-1, version 0.40.0
-- Found Pixman: /usr/lib64/libpixman-1.so (found suitable version "0.40.0", minimum required is "0.30") 
-- Found Boost: /usr/include (found suitable version "1.73.0", minimum required is "1.54.0")  
-- Checking for module 'ngspice'
--   Found ngspice, version 34
-- Found ngspice: /usr/include  
CMake Error at /usr/lib64/oce-0.18/OCE-libraries.cmake:264 (message):
  The imported target "TKDraw" references the file

     "/usr/lib64/oce-0.18/libTKDraw.so.11.0.0"

  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained

     "/usr/lib64/oce-0.18/OCE-libraries.cmake"

  but not all the files it references.

Call Stack (most recent call first):
  /usr/lib64/oce-0.18/OCEConfig.cmake:23 (include)
  CMakeLists.txt:608 (find_package)


-- Configuring incomplete, errors occurred!
See also "/tmp/B.jBG5Ie/BUILD/kicad-5.1.10/build/CMakeFiles/CMakeOutput.log".
error: Bad exit status from /tmp/B.jBG5Ie/BUILD/tmp/rpm-tmp.wl9ky7 (%build)


RPM build errors:
    Macro expanded in comment on line 361: %{_datadir}/mimelnk/application/x-kicad-pcb.desktop

    Macro expanded in comment on line 362: %{_datadir}/mimelnk/application/x-kicad-project.desktop

    Macro expanded in comment on line 363: %{_datadir}/mimelnk/application/x-kicad-schematic.desktop

    Could not canonicalize hostname: ymir
    Bad exit status from /tmp/B.jBG5Ie/BUILD/tmp/rpm-tmp.wl9ky7 (%build)
ended at: Sun May 16 10:18:22 2021, done in 0:03:03.691304
error: No files produced.
+ chmod -R u+rwX /tmp/B.jBG5Ie/BUILD
+ rm -rf /tmp/B.jBG5Ie/tmp /tmp/B.jBG5Ie/BUILD
+ rm -rf /tmp/B.jBG5Ie
Begin-PLD-Builder-Info
Build-Time: user:419.97s sys:56.11s real:262.08s (faults io:580 non-io:5592099)

End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]