FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by ITS.
Your IP: 54.80.173.217

openchange bc3909a2-f82a-439a-a955-400b33e254b3

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/openchange,bc3909a2-f82a-439a-a955-400b33e254b3.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2021/11/14 18:42:30
Runtime:0:00:16.050050

Toc:

  • prep
  • Executing(%prep): /bin/sh -e /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.u8EcuK
  • build
  • Executing(%build): /bin/sh -e /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.2QEXG0
  • error 1
  • exchange.idl:4200: error: EcDoRpc: [out] argument 'size' is not a pointer or array, skip client functions
  • error 2
  • libmapi/IProfAdmin.c:756:49: error: 'CRED_AUTO_USE_KERBEROS' undeclared (first use in this function)
  • error 3
  • libmapi/IProfAdmin.c:780:35: error: 'CRED_MUST_USE_KERBEROS' undeclared (first use in this function)
  • error 4
  • libmapi/IProfAdmin.c:782:35: error: 'CRED_DONT_USE_KERBEROS' undeclared (first use in this function)
  • error 5
  • libmapi/IProfAdmin.c:797:17: error: too few arguments to function 'cli_credentials_set_kerberos_state'
  • error 6
  • error: Bad exit status from /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.2QEXG0 (%build)
  • error 7
  • RPM build errors:
  • error 8
  • error: No files produced.

Content:

request from: baggins
checking if we should skip the build
started at: Sun Nov 14 18:42:12 2021
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/bc3909a2-f82a-439a-a955-400b33e254b3/openchange-2.3-58.src.rpm
fetched 2123145 bytes, 5462.5 K/s
installing srpm: openchange-2.3-58.src.rpm
+ install -d /tmp/B.84f1oybb/BUILD /tmp/B.84f1oybb/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog openchange-2.3-58.src.rpm
* Sun Nov 14 2021 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/openchange.git;a=log;h=master
* Tue Jun 08 2021 Jakub Bogusz <qboosh@pld-linux.org> 8fae5c8
- release 58 * Thu May 06 2021 Jakub Bogusz <qboosh@pld-linux.org> 7c1401b
- release 57 (samba 4.13.8) * Fri Mar 26 2021 Jakub Bogusz <qboosh@pld-linux.org> 4d4287e
- release 56 * Fri Mar 26 2021 Jakub Bogusz <qboosh@pld-linux.org> 1b9a980
- rediffed * Fri Mar 26 2021 Jan Rękorajski <baggins@pld-linux.org> 068f555
- release 55 (by relup.sh) * Thu Mar 25 2021 Jakub Bogusz <qboosh@pld-linux.org> df1197a
- release 54 (samba 4.13.7) * Sun Mar 07 2021 Jan Rękorajski <baggins@pld-linux.org> aebab8f
- unconditional noarch subpackages * Sat Jan 09 2021 Jakub Bogusz <qboosh@pld-linux.org> 3799929
- updated noarch rule - fix build with autoconf 2.70 - release 53 (samba 4.13.3) * Tue Aug 18 2020 Jakub Bogusz <qboosh@pld-linux.org> 1b4425d
- release 51 (samba 4.12.6) * Sat May 23 2020 Jakub Bogusz <qboosh@pld-linux.org> b5f7e37
- added nanomsg patch (adjust for .pc file rename in nanomsg 1.0.0+) - release 51 (rebuild with samba 4.12.3) * Thu Apr 23 2020 Jan Rękorajski <baggins@pld-linux.org> 23b2855
- release 50 (by relup.sh) * Wed Apr 08 2020 Jan Rękorajski <baggins@pld-linux.org> d23f825
- fix building with samba 4.12 - rel 49 * Sat Mar 28 2020 Jan Rękorajski <baggins@pld-linux.org> 80627a7
- release 48 (by relup.sh) * Sun Feb 09 2020 Jan Rękorajski <baggins@pld-linux.org> 29dcaaf
- fix perl deps in nagios-plugin-openchange package - rel 47 * Sun Feb 09 2020 Jan Rękorajski <baggins@pld-linux.org> c70cf5e
- release 46 (by relup.sh) * Sat Jan 11 2020 Jakub Bogusz <qboosh@pld-linux.org> aa25485
- release 45 (rebuild with samba 4.11.4) * Sat Nov 02 2019 Jan Rękorajski <baggins@pld-linux.org> 224a9b8
- fix building with samba 4.11 - rel 44 * Thu Oct 17 2019 Jakub Bogusz <qboosh@pld-linux.org> 4db9cff
- release 43 (for samba 4.10.9) * Thu Oct 17 2019 Jakub Bogusz <qboosh@pld-linux.org> 4b49de4
- release 42 (for samba 4.10.8) * Wed Jul 24 2019 Jakub Bogusz <qboosh@pld-linux.org> 8d7bc76
- release 41 (samba 4.10.6) + rpm -Uhv --nodeps --define '_topdir /tmp/B.84f1oybb' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' openchange-2.3-58.src.rpm Updating / installing... openchange-2.3-58 ######################################## + rm -f openchange-2.3-58.src.rpm + install -m 700 -d /tmp/B.84f1oybb/BUILD/tmp + TMPDIR=/tmp/B.84f1oybb/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.84f1oybb' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.84f1oybb/openchange.spec warning: Macro expanded in comment on line 439: %{_libdir}/nagios/plugins/check_exchange.ldb warning: Could not canonicalize hostname: ymir Building target platforms: x86_64-pld-linux Building for target x86_64-pld-linux checking BuildConflict-ing packages rpm: warning: Macro expanded in comment on line 439: %{_libdir}/nagios/plugins/check_exchange.ldb rpm: rpm: warning: Could not canonicalize hostname: ymir rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux no BuildConflicts found checking BR rpm: warning: Macro expanded in comment on line 439: %{_libdir}/nagios/plugins/check_exchange.ldb rpm: rpm: warning: Could not canonicalize hostname: ymir rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux no BR needed building RPM using: set -ex; : build-id: bc3909a2-f82a-439a-a955-400b33e254b3; TMPDIR=/tmp/B.84f1oybb/BUILD/tmp exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.84f1oybb' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux /tmp/B.84f1oybb/openchange.spec + : build-id: bc3909a2-f82a-439a-a955-400b33e254b3 + TMPDIR=/tmp/B.84f1oybb/BUILD/tmp + exec nice -n 0 rpmbuild -bb --define '_smp_mflags -j9' --define '_make_opts -Otarget' --define '_pld_builder 1' --define '_topdir /tmp/B.84f1oybb' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux /tmp/B.84f1oybb/openchange.spec warning: Macro expanded in comment on line 439: %{_libdir}/nagios/plugins/check_exchange.ldb warning: Could not canonicalize hostname: ymir Building target platforms: x86_64-pld-linux Building for target x86_64-pld-linux Executing(%prep): /bin/sh -e /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.u8EcuK + umask 022 + cd /tmp/B.84f1oybb/BUILD + cd /tmp/B.84f1oybb/BUILD + rm -rf openchange-openchange-2.3-VULCAN + /bin/gzip -dc /tmp/B.84f1oybb/openchange-2.3-VULCAN.tar.gz + /bin/tar -xof - + STATUS=0 + '[' 0 -ne 0 ']' + cd openchange-openchange-2.3-VULCAN + /bin/chmod -Rf a+rX,u+w,g-w,o-w . + echo 'Patch #0 (disable-mapiproxy.patch):' Patch #0 (disable-mapiproxy.patch): + </tmp/B.84f1oybb/disable-mapiproxy.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #1 (openchange-link.patch):' Patch #1 (openchange-link.patch): + </tmp/B.84f1oybb/openchange-link.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #2 (flex2.6.patch):' Patch #2 (flex2.6.patch): + </tmp/B.84f1oybb/flex2.6.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #3 (samba-4.2.patch):' Patch #3 (samba-4.2.patch): + </tmp/B.84f1oybb/samba-4.2.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #4 (fix-connection-args.patch):' Patch #4 (fix-connection-args.patch): + </tmp/B.84f1oybb/fix-connection-args.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #5 (samba-4.4.patch):' Patch #5 (samba-4.4.patch): + </tmp/B.84f1oybb/samba-4.4.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #6 (openchange-covscan.patch):' Patch #6 (openchange-covscan.patch): + </tmp/B.84f1oybb/openchange-covscan.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #7 (openchange-samba-4.10-macros.patch):' Patch #7 (openchange-samba-4.10-macros.patch): + </tmp/B.84f1oybb/openchange-samba-4.10-macros.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #8 (openchange-libical.patch):' Patch #8 (openchange-libical.patch): + </tmp/B.84f1oybb/openchange-libical.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #9 (samba-4.11.patch):' Patch #9 (samba-4.11.patch): + </tmp/B.84f1oybb/samba-4.11.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #10 (samba-4.12.patch):' Patch #10 (samba-4.12.patch): + </tmp/B.84f1oybb/samba-4.12.patch + /usr/bin/patch -s -p1 '--fuzz=0' + echo 'Patch #11 (openchange-nanomsg.patch):' Patch #11 (openchange-nanomsg.patch): + </tmp/B.84f1oybb/openchange-nanomsg.patch + /usr/bin/patch -s -p1 '--fuzz=0' + /bin/sed -i -e $'s/^\t@\\(\\$(\\(PIDL\\|CC\\|CXX\\|MOC\\)\\)/\t\\1/' Makefile + RPM_EC=0 + jobs -p + exit 0 Executing(%build): /bin/sh -e /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.2QEXG0 TMP=/home/users/builder/tmp HOME=/home/users/builder PATH=/home/users/builder/GNUstep/Tools:/bin:/usr/bin:/usr/local/bin:/home/users/builder/bin TMPDIR=/tmp/B.84f1oybb/BUILD/tmp + umask 022 + cd /tmp/B.84f1oybb/BUILD + cd openchange-openchange-2.3-VULCAN + aclocal + autoconf configure.ac:6: warning: The macro `AC_CONFIG_HEADER' is obsolete. configure.ac:6: You should run autoupdate. ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from... configure.ac:6: the top level configure.ac:108: warning: The macro `AC_HELP_STRING' is obsolete. configure.ac:108: You should run autoupdate. ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from... ./lib/autoconf/general.m4:1553: AC_ARG_WITH is expanded from... configure.ac:108: the top level configure.ac:779: warning: The macro `AC_HELP_STRING' is obsolete. configure.ac:779: You should run autoupdate. ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from... configure.ac:779: the top level configure.ac:832: warning: The macro `AC_HELP_STRING' is obsolete. configure.ac:832: You should run autoupdate. ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from... configure.ac:832: the top level + autoheader + cp -f /usr/share/automake/compile /usr/share/automake/missing . + ./configure 'LDFLAGS=-Wl,--as-needed -Wl,--no-copy-dt-needed-entries -Wl,-z,relro -Wl,-z,combreloc ' 'CFLAGS=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 ' 'CXXFLAGS=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 ' 'FFLAGS=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 ' 'FCFLAGS=-O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 ' 'CPPFLAGS=' 'CC=x86_64-pld-linux-gcc' 'CXX=x86_64-pld-linux-g++' '--host=x86_64-pld-linux' '--build=x86_64-pld-linux' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--x-libraries=/usr/lib64' '--datadir=/usr/share/openchange' --enable-openchange-qt4 '--with-modulesdir=/usr/lib64/openchange/modules' checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for a race-free mkdir -p... /bin/mkdir -p checking for mawk... mawk checking whether make sets $(MAKE)... yes checking whether make supports nested variables... yes checking for x86_64-pld-linux-pkg-config... no checking for pkg-config... /usr/bin/pkg-config checking pkg-config is at least version 0.20... yes checking build system endianness... checking whether make supports the include directive... yes (GNU style) checking for x86_64-pld-linux-gcc... x86_64-pld-linux-gcc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether the compiler supports GNU C... yes checking whether x86_64-pld-linux-gcc accepts -g... yes checking for x86_64-pld-linux-gcc option to enable C11 features... none needed checking whether x86_64-pld-linux-gcc understands -c and -o together... yes checking dependency style of x86_64-pld-linux-gcc... none checking how to run the C preprocessor... x86_64-pld-linux-gcc -E checking for mysql_config... /usr/bin/mysql_config checking mysql cflags... -I/usr/include/mysql checking mysql libs... -L/usr/lib64 -lmysqlclient -lz -lm -latomic -lssl -lcrypto checking build system type... x86_64-pld-linux-gnu checking host system type... x86_64-pld-linux-gnu checking for samba 4... /usr checking for stdio.h... yes checking for stdlib.h... yes checking for string.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for strings.h... yes checking for sys/stat.h... yes checking for sys/types.h... yes checking for unistd.h... yes checking for sys/cdefs.h... yes checking for string.h... (cached) yes checking for sys/sockio.h... no checking for strcasestr... yes checking for comparison_fn_t... yes checking for x86_64-pld-linux-gcc... (cached) x86_64-pld-linux-gcc checking whether the compiler supports GNU C... (cached) yes checking whether x86_64-pld-linux-gcc accepts -g... (cached) yes checking for x86_64-pld-linux-gcc option to enable C11 features... (cached) none needed checking whether x86_64-pld-linux-gcc understands -c and -o together... (cached) yes checking dependency style of x86_64-pld-linux-gcc... (cached) none checking for nanomsg... yes checking whether we are really using the Sun C compiler... no checking whether we are really using the Intel C compiler... no checking for perl... /usr/bin/perl checking for pidl... /usr/bin/pidl checking for python... /usr/bin/python checking for python-config... /usr/bin/python-config checking python cflags... -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 checking python libs... -lpython2.7 -ldl -lm checking python library directory... ${prefix}/lib64/python2.7/site-packages checking for mysql_config... (cached) /usr/bin/mysql_config checking mysql cflags... -I/usr/include/mysql checking mysql libs... -L/usr/lib64 -lmysqlclient -lz -lm -latomic -lssl -lcrypto checking for libmemcached >= 1.0.18... yes checking for flex... flex checking for talloc... yes checking for dcerpc ndr samba-hostconfig samba-util tevent samba-credentials... yes checking for dcerpc_server samdb... yes checking for tdb... yes checking for ldb... yes checking for samba/version.h... yes configure: WARNING: The Samba4 version installed on your system doesn't meet OpenChange requirements (4.1.18 or 4.1.18-GIT-). checking for DCE/RPC server modules directory... /usr/lib64/samba/dcerpc_server checking for dlopen in -ldl... yes checking for pthread_mutex_init in -lpthread... yes checking whether the compiler supports GNU C++... yes checking whether x86_64-pld-linux-g++ accepts -g... yes checking for x86_64-pld-linux-g++ option to enable C++11 features... none needed checking dependency style of x86_64-pld-linux-g++... none checking C++ compiler availability... yes checking whether the compiler supports GNU C++... (cached) yes checking whether x86_64-pld-linux-g++ accepts -g... (cached) yes checking for x86_64-pld-linux-g++ option to enable C++11 features... (cached) none needed checking dependency style of x86_64-pld-linux-g++... (cached) none checking for bison... /usr/bin/bison checking for dcerpc_samr ndr_standard... yes checking for libical... yes checking for libical >= 0.46... yes checking for pcap-config... /usr/bin/pcap-config checking pcap cflags... -I/usr/include checking pcap libs... -lpcap checking for poptFreeContext in -lpopt... yes checking for magic_open in -lmagic... yes checking for gzopen in -lz... yes checking for doxygen... /usr/bin/doxygen checking for libsubunit... yes checking for QtCore >= 4.3.0 QtGui >= 4.3.0... yes checking that generated files are newer than configure... done configure: creating ./config.status config.status: creating config.mk config.status: creating libmapi.pc config.status: creating libmapiadmin.pc config.status: creating libocpf.pc config.status: creating mapiproxy/libmapiproxy.pc config.status: creating mapiproxy/libmapiserver.pc config.status: creating mapiproxy/libmapistore.pc config.status: creating libmapi++.pc config.status: creating Doxyfile config.status: creating libmapi++/Doxyfile config.status: creating libocpf/Doxyfile config.status: creating libmapiadmin/Doxyfile config.status: creating libmapi/Doxyfile config.status: creating mapiproxy/Doxyfile config.status: creating utils/mapitest/Doxyfile config.status: creating mapiproxy/libmapistore/Doxyfile config.status: creating config.h config.status: executing depfiles commands =============================================================== OpenChange Configuration (Please review) * OpenChange Libraries: - libmapi (C library): yes Thread support: yes (pthread) - libmapi++ (C++ library): yes - libmapiadmin: yes - libocpf: yes * OpenChange Server: - mapiproxy: no * OpenChange mapistore backends: - backends dependencies goes here * OpenChange Tools: - openchangeclient: yes - mapiprofile: yes - ocnotify: - openchangepfadmin: yes - exchange2mbox: yes - exchange2ical: yes - openchangemapidump: yes - schemaIDGUID: yes * Protocol Analysis: - mapipropsdump: yes - rpcextract: yes * Unit and functional testing - mapitest: no - mapitest (subunit): yes - openchange-testsuite: no - coverage tests: no * OpenChange Documentation: yes * OpenChange Bindings: - Qt4: yes * Installation prefix: /usr =============================================================== + /usr/bin/make -Otarget -j9 Creating the gen_ndr directory mkdir -p gen_ndr libmapi/conf/mparse.pl --parser=mapicodes --outputdir=libmapi/ libmapi/conf/mapi-codes Parsing libmapi/conf/mapi-codes Generating libmapi/mapicode.c Generating mapicodes_enum.h Generating exchange.h /usr/bin/pidl --outputdir=gen_ndr --header -- exchange.idl Compiling exchange.idl exchange.idl:1444: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1536: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1550: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1806: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2461: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2467: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2983: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3551: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3613: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3688: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4202: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4203: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4645: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4200: warning: [out] argument `size' not a pointer exchange.idl:4201: warning: [out] argument `offset' not a pointer Generating gen_ndr/ndr_exchange.h /usr/bin/pidl --outputdir=gen_ndr --ndr-parser -- exchange.idl Compiling exchange.idl exchange.idl:1444: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1536: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1550: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1806: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2461: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2467: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2983: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3551: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3613: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3688: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4202: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4203: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4645: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4200: warning: [out] argument `size' not a pointer exchange.idl:4201: warning: [out] argument `offset' not a pointer Generating property.h /usr/bin/pidl --outputdir=gen_ndr --header -- property.idl Compiling property.idl Generating gen_ndr/ndr_property.h /usr/bin/pidl --outputdir=gen_ndr --ndr-parser -- property.idl Compiling property.idl Generating asyncemsmdb.h /usr/bin/pidl --outputdir=gen_ndr --header -- asyncemsmdb.idl Compiling asyncemsmdb.idl Generating gen_ndr/ndr_asyncemsmdb.h /usr/bin/pidl --outputdir=gen_ndr --ndr-parser -- asyncemsmdb.idl Compiling asyncemsmdb.idl fatal: not a git repository (or any of the parent directories): .git ./script/mkversion.sh: 'libmapi/version.h' created for OpenChange libmapi("2.3 (Vulcan)") Generating gen_ndr/ndr_exchange_c.h /usr/bin/pidl --outputdir=gen_ndr --client -- exchange.idl Compiling exchange.idl exchange.idl:1444: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1536: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1550: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:1806: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2461: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2467: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2510: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:2983: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3551: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3613: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:3688: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4202: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4203: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4645: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead exchange.idl:4200: warning: [out] argument `size' not a pointer exchange.idl:4201: warning: [out] argument `offset' not a pointer exchange.idl:4200: error: EcDoRpc: [out] argument 'size' is not a pointer or array, skip client functions Generating gen_ndr/ndr_asyncemsmdb_c.h /usr/bin/pidl --outputdir=gen_ndr --client -- asyncemsmdb.idl Compiling asyncemsmdb.idl Compiling libmapi/emsmdb.c with -fPIC x86_64-pld-linux-gcc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -I. -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DHAVE_LITTLE_ENDIAN -Wall -fstrict-aliasing -Wp,-D_FORTIFY_SOURCE=2 -Wmissing-prototypes -Wstrict-prototypes -Wpointer-sign -DENABLE_ASSERTS -DDEFAULT_LDIF=\"/usr/share/openchange/setup/profiles\" -DMAPISTORE_LDIF=\"/usr/share/openchange/setup/mapistore\" -DOPENCHANGEDB_DATA_DIR=\"/usr/share/openchange/setup/openchangedb\" -DMAPISTORE_BACKEND_INSTALLDIR=\"/usr/lib64/mapistore_backends\" -DLZXPRESS_DATADIR=\"/usr/share/openchange/mapitest/lzxpress\" -DLZFU_DATADIR=\"/usr/share/openchange/mapitest/lzfu\" -DHAVE_ICAL_0_46=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -D_GNU_SOURCE=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -I/usr/include/samba-4.0 -fPIC -c libmapi/emsmdb.c -o libmapi/emsmdb.po Compiling libmapi/async_emsmdb.c with -fPIC x86_64-pld-linux-gcc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -I. -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DHAVE_LITTLE_ENDIAN -Wall -fstrict-aliasing -Wp,-D_FORTIFY_SOURCE=2 -Wmissing-prototypes -Wstrict-prototypes -Wpointer-sign -DENABLE_ASSERTS -DDEFAULT_LDIF=\"/usr/share/openchange/setup/profiles\" -DMAPISTORE_LDIF=\"/usr/share/openchange/setup/mapistore\" -DOPENCHANGEDB_DATA_DIR=\"/usr/share/openchange/setup/openchangedb\" -DMAPISTORE_BACKEND_INSTALLDIR=\"/usr/lib64/mapistore_backends\" -DLZXPRESS_DATADIR=\"/usr/share/openchange/mapitest/lzxpress\" -DLZFU_DATADIR=\"/usr/share/openchange/mapitest/lzfu\" -DHAVE_ICAL_0_46=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -D_GNU_SOURCE=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -I/usr/include/samba-4.0 -fPIC -c libmapi/async_emsmdb.c -o libmapi/async_emsmdb.po Compiling libmapi/IABContainer.c with -fPIC x86_64-pld-linux-gcc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -I. -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DHAVE_LITTLE_ENDIAN -Wall -fstrict-aliasing -Wp,-D_FORTIFY_SOURCE=2 -Wmissing-prototypes -Wstrict-prototypes -Wpointer-sign -DENABLE_ASSERTS -DDEFAULT_LDIF=\"/usr/share/openchange/setup/profiles\" -DMAPISTORE_LDIF=\"/usr/share/openchange/setup/mapistore\" -DOPENCHANGEDB_DATA_DIR=\"/usr/share/openchange/setup/openchangedb\" -DMAPISTORE_BACKEND_INSTALLDIR=\"/usr/lib64/mapistore_backends\" -DLZXPRESS_DATADIR=\"/usr/share/openchange/mapitest/lzxpress\" -DLZFU_DATADIR=\"/usr/share/openchange/mapitest/lzfu\" -DHAVE_ICAL_0_46=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -D_GNU_SOURCE=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -I/usr/include/samba-4.0 -fPIC -c libmapi/IABContainer.c -o libmapi/IABContainer.po Compiling libmapi/IProfAdmin.c with -fPIC x86_64-pld-linux-gcc -I/usr/include/python2.7 -I/usr/include/python2.7 -fno-strict-aliasing -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DNDEBUG -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -I. -O2 -fwrapv -pipe -Wformat -Werror=format-security -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector-strong --param=ssp-buffer-size=4 -Werror=trampolines -fPIC -march=x86-64 -mtune=generic -gdwarf-4 -fno-debug-types-section -fvar-tracking-assignments -g2 -DHAVE_LITTLE_ENDIAN -Wall -fstrict-aliasing -Wp,-D_FORTIFY_SOURCE=2 -Wmissing-prototypes -Wstrict-prototypes -Wpointer-sign -DENABLE_ASSERTS -DDEFAULT_LDIF=\"/usr/share/openchange/setup/profiles\" -DMAPISTORE_LDIF=\"/usr/share/openchange/setup/mapistore\" -DOPENCHANGEDB_DATA_DIR=\"/usr/share/openchange/setup/openchangedb\" -DMAPISTORE_BACKEND_INSTALLDIR=\"/usr/lib64/mapistore_backends\" -DLZXPRESS_DATADIR=\"/usr/share/openchange/mapitest/lzxpress\" -DLZFU_DATADIR=\"/usr/share/openchange/mapitest/lzfu\" -DHAVE_ICAL_0_46=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -D_GNU_SOURCE=1 -DHAVE_IMMEDIATE_STRUCTURES=1 -I/usr/include/samba-4.0 -fPIC -c libmapi/IProfAdmin.c -o libmapi/IProfAdmin.po libmapi/IProfAdmin.c: In function 'LoadProfile': libmapi/IProfAdmin.c:756:49: error: 'CRED_AUTO_USE_KERBEROS' undeclared (first use in this function) 756 | enum credentials_use_kerberos use_krb = CRED_AUTO_USE_KERBEROS; | ^~~~~~~~~~~~~~~~~~~~~~ libmapi/IProfAdmin.c:756:49: note: each undeclared identifier is reported only once for each function it appears in libmapi/IProfAdmin.c:780:35: error: 'CRED_MUST_USE_KERBEROS' undeclared (first use in this function) 780 | use_krb = CRED_MUST_USE_KERBEROS; | ^~~~~~~~~~~~~~~~~~~~~~ libmapi/IProfAdmin.c:782:35: error: 'CRED_DONT_USE_KERBEROS' undeclared (first use in this function) 782 | use_krb = CRED_DONT_USE_KERBEROS; | ^~~~~~~~~~~~~~~~~~~~~~ libmapi/IProfAdmin.c:797:17: error: too few arguments to function 'cli_credentials_set_kerberos_state' 797 | cli_credentials_set_kerberos_state(profile->credentials, use_krb); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from libmapi/IProfAdmin.c:23: /usr/include/samba-4.0/credentials.h:146:6: note: declared here 146 | bool cli_credentials_set_kerberos_state(struct cli_credentials *creds, | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ make: *** [Makefile:125: libmapi/IProfAdmin.po] Error 1 error: Bad exit status from /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.2QEXG0 (%build) RPM build errors: Macro expanded in comment on line 439: %{_libdir}/nagios/plugins/check_exchange.ldb Could not canonicalize hostname: ymir Bad exit status from /tmp/B.84f1oybb/BUILD/tmp/rpm-tmp.2QEXG0 (%build) ended at: Sun Nov 14 18:42:30 2021, done in 0:00:16.050050 error: No files produced. + chmod -R u+rwX /tmp/B.84f1oybb/BUILD + rm -rf /tmp/B.84f1oybb/tmp /tmp/B.84f1oybb/BUILD + rm -rf /tmp/B.84f1oybb Begin-PLD-Builder-Info Build-Time: user:15.43s sys:2.60s real:18.02s (faults io:1 non-io:651331) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]