FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by electricity.
Your IP: 35.175.107.77

ruby b537ee75-a00d-4804-8c83-58710284c9dd

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/ruby,b537ee75-a00d-4804-8c83-58710284c9dd.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2021/10/13 12:32:51

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • error 3
  • poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1()(64bit) not found
  • error 4
  • poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) not found
  • error 5
  • poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) not found
  • error 6
  • poldek: error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1()(64bit) not found
  • error 7
  • poldek: error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1(OPENSSL_1_1_0)(64bit) not found
  • error 8
  • poldek: error: 5 unresolved dependencies
  • error 9
  • poldek: error: Failed dependencies:
  • error 10
  • error: ruby-modules: no such package
  • error 11
  • rpm: error: Failed build dependencies:
  • error 12
  • error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1()(64bit) not found
  • error 13
  • error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) not found
  • error 14
  • error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) not found
  • error 15
  • error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1()(64bit) not found
  • error 16
  • error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1(OPENSSL_1_1_0)(64bit) not found
  • error 17
  • error: 5 unresolved dependencies
  • error 18
  • error: BR installation failed

Content:

request from: atler
checking if we should skip the build
started at: Wed Oct 13 12:32:36 2021
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/b537ee75-a00d-4804-8c83-58710284c9dd/ruby-2.6.8-2.src.rpm
fetched 53937324 bytes, 20839.1 K/s
installing srpm: ruby-2.6.8-2.src.rpm
+ install -d /tmp/B.vlk3ki67/BUILD /tmp/B.vlk3ki67/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog ruby-2.6.8-2.src.rpm
* Wed Oct 13 2021 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/ruby.git;a=log;h=master
* Wed Oct 13 2021 Jan Palus <atler@pld-linux.org> adc1d50
- don't define SSLV23_PADDING when building against openssl3; rel 2 * Thu Jul 08 2021 Jan Palus <atler@pld-linux.org> 0c1caf7
- up to 2.6.8 (fixes CVE-2021-31810 CVE-2021-32066 CVE-2021-31799) * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> 0988137
- updated source urls to https * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> 62184b6
- up to 2.6.7 (fixes CVE-2020-25613 CVE-2021-28965) * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> 0861e54
- fix build with bison >= 3.59 * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> f39e721
- fix build with autoconf 2.70 * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> b74e3e2
- dtrace bcond * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> fafe7e2
- fix rdoc version check * Tue Jun 15 2021 Jan Palus <atler@pld-linux.org> 44ad977
- rediff patches * Sun Feb 28 2021 Jan Rękorajski <baggins@pld-linux.org> 1f3fae5
- unconditional noarch subpackages * Tue Apr 21 2020 Jan Rękorajski <baggins@pld-linux.org> bfbb9b9
- really rebuild with libffi 3.3 - release 3 (by relup.sh) * Mon Apr 20 2020 Jan Rękorajski <baggins@pld-linux.org> b79301e
- rebuild with libffi 3.3 - release 2 (by relup.sh) * Fri Apr 03 2020 mis <mis@pld-linux.org> 8b94777
- up docs to 2.6.6 too * Thu Apr 02 2020 mis <mis@pld-linux.org> 7e8927c
- up to 2.6.6 (fixes CVE-2020-16255, CVE-2020-10933) * Sat Feb 08 2020 Jakub Bogusz <qboosh@pld-linux.org> b417ade
- completed packaging * Fri Feb 07 2020 Jakub Bogusz <qboosh@pld-linux.org> 221b704
- reverted version patch to use RUBY_LIB_VERSION_STYLE=2 (minor) - dropped rubygems patch (harmful now, causes requires cycle) * Sun Dec 22 2019 Jakub Bogusz <qboosh@pld-linux.org> 8ff43ce
- pl for -bundler * Thu Dec 19 2019 mis <mis@pld-linux.org> 2798ed3
- up to 2.6.5 * Sun Nov 24 2019 mis <mistoo@gmail.com> d2dd9b6
- up to 2.4.9 (CVE-2019-16255, CVE-2019-16254, CVE-2019-15845, CVE-2019-16201) * Thu Oct 17 2019 Arkadiusz Miśkiewicz <arekm@maven.pl> 511d943
- release 2 (by relup.sh) + rpm -Uhv --nodeps --define '_topdir /tmp/B.vlk3ki67' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --with bootstrap ruby-2.6.8-2.src.rpm Updating / installing... ruby-1:2.6.8-2 ######################################## + rm -f ruby-2.6.8-2.src.rpm + install -m 700 -d /tmp/B.vlk3ki67/BUILD/tmp + TMPDIR=/tmp/B.vlk3ki67/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.vlk3ki67' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --with bootstrap --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.vlk3ki67/ruby.spec warning: Macro expanded in comment on line 297: %{version},%{release} macros may not be used directly as they take last warning: line 438: It's not recommended to have unversioned Obsoletes: Obsoletes: ruby-json-rubyforge warning: Could not canonicalize hostname: ymir Building target platforms: x86_64-pld-linux Building for target x86_64-pld-linux checking BuildConflict-ing packages rpm: warning: Macro expanded in comment on line 297: %{version},%{release} macros may not be used directly as they take last rpm: rpm: warning: line 438: It's not recommended to have unversioned Obsoletes: Obsoletes: ruby-json-rubyforge rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: ruby >= 1:1.9 is needed by ruby-1:2.6.8-2.x86_64 rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux no BuildConflicts found checking BR rpm: warning: Macro expanded in comment on line 297: %{version},%{release} macros may not be used directly as they take last rpm: rpm: warning: line 438: It's not recommended to have unversioned Obsoletes: Obsoletes: ruby-json-rubyforge rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: ruby >= 1:1.9 is needed by ruby-1:2.6.8-2.x86_64 rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date Retrieving th-test::packages.ndir.diff.toc.gz..............................................done Loading [pndir]th-test... Applying packages.ndir.2021.10.13-10.16.01.gz... Retrieving diff::packages.ndir.2021.10.13-10.27.02.gz......................................done Applying packages.ndir.2021.10.13-10.27.02.gz... Writing /root/.poldek-cache/[...]/packages.ndir.gz... th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 32247 packages read poldek: Removed 2751 duplicate packages from available set poldek: Processing dependencies... poldek: ruby-2.6.8-1.x86_64 marks ruby-modules-2.6.8-1.x86_64 (cap ruby(abi) = 2.6) poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1()(64bit) not found poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) not found poldek: error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) not found poldek: error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1()(64bit) not found poldek: error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1(OPENSSL_1_1_0)(64bit) not found poldek: ruby-modules-2.6.8-1.x86_64 marks ruby-rubygems-3.0.3.1-2.6.8.1.noarch (cap rubygems >= 2.6) poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-bigdecimal-1.4.1-2.6.8.1.x86_64 (cap ruby-bigdecimal = 1.4.1-2.6.8.1) poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-io-console-0.4.7-2.6.8.1.x86_64 (cap ruby-io-console = 0.4.7-2.6.8.1) poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-psych-3.1.0-2.6.8.1.x86_64 (cap ruby-psych = 3.1.0-2.6.8.1) poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-rdoc-6.1.2.1-2.6.8.1.noarch (cap ruby-rdoc >= 6.1.2.1) poldek: ruby-rdoc-6.1.2.1-2.6.8.1.noarch marks ruby-irb-1.0.0-2.6.8.1.noarch (cap ruby-irb >= 1.0.0) poldek: ruby-rdoc-6.1.2.1-2.6.8.1.noarch marks ruby-json-2.1.0-2.6.8.1.x86_64 (cap ruby-json >= 2.1.0) poldek: There are 9 packages to install (8 marked by dependencies): poldek: A ruby-2.6.8-1.x86_64 ruby-bigdecimal-1.4.1-2.6.8.1.x86_64 poldek: A ruby-io-console-0.4.7-2.6.8.1.x86_64 ruby-irb-1.0.0-2.6.8.1.noarch poldek: A ruby-json-2.1.0-2.6.8.1.x86_64 ruby-modules-2.6.8-1.x86_64 poldek: A ruby-psych-3.1.0-2.6.8.1.x86_64 ruby-rdoc-6.1.2.1-2.6.8.1.noarch poldek: A ruby-rubygems-3.0.3.1-2.6.8.1.noarch poldek: This operation will use 15.7MB of disk space. poldek: ruby-2.6.8-1.x86_64.rpm: digests OK poldek: ruby-modules-2.6.8-1.x86_64.rpm: digests OK poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch.rpm: digests OK poldek: ruby-bigdecimal-1.4.1-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-io-console-0.4.7-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-psych-3.1.0-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-rdoc-6.1.2.1-2.6.8.1.noarch.rpm: digests OK poldek: ruby-irb-1.0.0-2.6.8.1.noarch.rpm: digests OK poldek: ruby-json-2.1.0-2.6.8.1.x86_64.rpm: digests OK poldek: Need to get 3.7MB of archives. poldek: error: 5 unresolved dependencies poldek: ruby-bigdecimal-1.4.1-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-io-console-0.4.7-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-psych-3.1.0-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-irb-1.0.0-2.6.8.1.noarch.rpm: digests OK poldek: ruby-json-2.1.0-2.6.8.1.x86_64.rpm: digests OK poldek: ruby-rdoc-6.1.2.1-2.6.8.1.noarch.rpm: digests OK poldek: ruby-rubygems-3.0.3.1-2.6.8.1.noarch.rpm: digests OK poldek: ruby-modules-2.6.8-1.x86_64.rpm: digests OK poldek: ruby-2.6.8-1.x86_64.rpm: digests OK poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 0... poldek: warning: /root/.poldek-cache/ftp_ep09.pld-linux.org.dists.th.PLD.x86.64.RPMS/ruby-bigdecimal-1.4.1-2.6.8.1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID e4f1bc2d: NOKEY poldek: error: Failed dependencies: poldek: libcrypto.so.1.1()(64bit) is needed by ruby-modules-1:2.6.8-1.x86_64 poldek: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) is needed by ruby-modules-1:2.6.8-1.x86_64 poldek: libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) is needed by ruby-modules-1:2.6.8-1.x86_64 poldek: libssl.so.1.1()(64bit) is needed by ruby-modules-1:2.6.8-1.x86_64 poldek: libssl.so.1.1(OPENSSL_1_1_0)(64bit) is needed by ruby-modules-1:2.6.8-1.x86_64 uninstalling conflicting packages removing ruby-modules error: ruby-modules: no such package package ruby-modules removal failed checking BR rpm: warning: Macro expanded in comment on line 297: %{version},%{release} macros may not be used directly as they take last rpm: rpm: warning: line 438: It's not recommended to have unversioned Obsoletes: Obsoletes: ruby-json-rubyforge rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: ruby >= 1:1.9 is needed by ruby-1:2.6.8-2.x86_64 rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux installing BR: ruby + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' '--ignore=php73-*' '--ignore=php74-*' '--ignore=php80-*' --upgrade ruby Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 32247 packages read Removed 2751 duplicate packages from available set Processing dependencies... ruby-2.6.8-1.x86_64 marks ruby-modules-2.6.8-1.x86_64 (cap ruby(abi) = 2.6) error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1()(64bit) not found error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) not found error: ruby-modules-2.6.8-1.x86_64: req libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) not found error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1()(64bit) not found error: ruby-modules-2.6.8-1.x86_64: req libssl.so.1.1(OPENSSL_1_1_0)(64bit) not found ruby-modules-2.6.8-1.x86_64 marks ruby-rubygems-3.0.3.1-2.6.8.1.noarch (cap rubygems >= 2.6) ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-bigdecimal-1.4.1-2.6.8.1.x86_64 (cap ruby-bigdecimal = 1.4.1-2.6.8.1) ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-io-console-0.4.7-2.6.8.1.x86_64 (cap ruby-io-console = 0.4.7-2.6.8.1) ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-psych-3.1.0-2.6.8.1.x86_64 (cap ruby-psych = 3.1.0-2.6.8.1) ruby-rubygems-3.0.3.1-2.6.8.1.noarch marks ruby-rdoc-6.1.2.1-2.6.8.1.noarch (cap ruby-rdoc >= 6.1.2.1) ruby-rdoc-6.1.2.1-2.6.8.1.noarch marks ruby-irb-1.0.0-2.6.8.1.noarch (cap ruby-irb >= 1.0.0) ruby-rdoc-6.1.2.1-2.6.8.1.noarch marks ruby-json-2.1.0-2.6.8.1.x86_64 (cap ruby-json >= 2.1.0) There are 9 packages to install (8 marked by dependencies): A ruby-2.6.8-1.x86_64 ruby-bigdecimal-1.4.1-2.6.8.1.x86_64 A ruby-io-console-0.4.7-2.6.8.1.x86_64 ruby-irb-1.0.0-2.6.8.1.noarch A ruby-json-2.1.0-2.6.8.1.x86_64 ruby-modules-2.6.8-1.x86_64 A ruby-psych-3.1.0-2.6.8.1.x86_64 ruby-rdoc-6.1.2.1-2.6.8.1.noarch A ruby-rubygems-3.0.3.1-2.6.8.1.noarch This operation will use 15.7MB of disk space. ruby-2.6.8-1.x86_64.rpm: digests OK ruby-modules-2.6.8-1.x86_64.rpm: digests OK ruby-rubygems-3.0.3.1-2.6.8.1.noarch.rpm: digests OK ruby-bigdecimal-1.4.1-2.6.8.1.x86_64.rpm: digests OK ruby-io-console-0.4.7-2.6.8.1.x86_64.rpm: digests OK ruby-psych-3.1.0-2.6.8.1.x86_64.rpm: digests OK ruby-rdoc-6.1.2.1-2.6.8.1.noarch.rpm: digests OK ruby-irb-1.0.0-2.6.8.1.noarch.rpm: digests OK ruby-json-2.1.0-2.6.8.1.x86_64.rpm: digests OK Need to get 3.7MB of archives. error: 5 unresolved dependencies error: BR installation failed + chmod -R u+rwX /tmp/B.vlk3ki67/BUILD + rm -rf /tmp/B.vlk3ki67/tmp /tmp/B.vlk3ki67/BUILD + rm -rf /tmp/B.vlk3ki67 Begin-PLD-Builder-Info Build-Time: user:6.60s sys:1.42s real:14.64s (faults io:14 non-io:341536) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]