FailedOk

th/SRPMS[OK]
th/x32[OK]
th/i686[OK]
th/x86_64[OK]

ac/SRPMS[OK]
ac/i386[OK]
ac/i586[OK]
ac/i686[OK]
ac/alpha[OK]
ac/amd64[OK]
ac/athlon[OK]
ac/ppc[OK]
ac/sparc[OK]
ac/sparc64[OK]

Advanced Search
main()
Powered by PLD Linux
(c) 2002-2021 PLD Team
$Revision: 1.37 $
Powered by ed.
Your IP: 34.207.247.69

tomcat 4ABBA5C9-59C6-4395-AE05-01B80F51215B

Status:Failed
Source URL:https://buildlogs.pld-linux.org/pld/th/x86_64/FAIL/tomcat,4ABBA5C9-59C6-4395-AE05-01B80F51215B.bz2
text/plain URL:View!
rpm -qa of builder:View!
Date:2021/11/24 10:25:56

Toc:

  • error 1
  • rpm: error: Failed build dependencies:
  • error 2
  • rpm: error: Failed build dependencies:
  • error 3
  • rpm: error: Failed build dependencies:
  • error 4
  • error: BR installation failed

Content:

request from: arekm
checking if we should skip the build
started at: Wed Nov 24 10:25:47 2021
killing old processes on a builder
sending signal 9 to pid -1
cleaning up /tmp
fetching https://srcbuilder.pld-linux.org/th//srpms/4ABBA5C9-59C6-4395-AE05-01B80F51215B/tomcat-7.0.109-1.src.rpm
fetched 5530539 bytes, 9859.4 K/s
installing srpm: tomcat-7.0.109-1.src.rpm
+ install -d /tmp/B.1es5mcov/BUILD /tmp/B.1es5mcov/RPMS
+ LC_ALL=en_US.UTF-8
+ rpm -qp --changelog tomcat-7.0.109-1.src.rpm
* Wed Nov 24 2021 PLD Linux Team <feedback@pld-linux.org>
- For complete changelog see: http://git.pld-linux.org/?p=packages/tomcat.git;a=log;h=auto/th/tomcat-7.0.109-1
* Wed Nov 24 2021 Arkadiusz Miśkiewicz <arekm@maven.pl> 0b16ffe
- Up to 7.0.109; 7.x series is EOL now * Wed Nov 24 2021 Arkadiusz Miśkiewicz <arekm@maven.pl> b31d692
- Rediff patches. * Tue Feb 02 2021 Arkadiusz Miśkiewicz <arekm@maven.pl> 3922285
- up to 7.0.107; EOL for 7.x series is at 31 March 2021 * Fri Sep 25 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> f7072f1
- up to 7.0.106 * Sat Feb 29 2020 Arkadiusz Miśkiewicz <arekm@maven.pl> 60f80b6
- up to 7.0.100; fixes CVE-2019-17563, CVE-2019-12418, CVE-2019-17569, CVE-2020-1935, CVE-2020-1938 (remote code execution) * Sat Jan 25 2020 Jan Rękorajski <baggins@pld-linux.org> aa44c06
- drop obsolete and outdated manual inclusion of rpm macros * Wed May 08 2019 Arkadiusz Miśkiewicz <arekm@maven.pl> 649a65f
- rel 2; typo fixed * Wed May 08 2019 Arkadiusz Miśkiewicz <arekm@maven.pl> d93791c
- up to 7.0.94 * Tue Oct 02 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> 37686c9
- up to 7.0.91 * Thu Jul 26 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> bdef47f
- up to 7.0.90; fixes CVE-2017-12617 * Thu May 31 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> 5ea8a73
- up to 7.0.88 * Tue Apr 10 2018 Arkadiusz Miśkiewicz <arekm@maven.pl> c0be134
- up to 7.0.85 * Wed Oct 04 2017 Arkadiusz Miśkiewicz <arekm@maven.pl> c5e04a6
- up to 7.0.82 * Wed Oct 04 2017 Arkadiusz Miśkiewicz <arekm@maven.pl> 916c011
- up to 7.0.81 * Wed Nov 23 2016 Arkadiusz Miśkiewicz <arekm@maven.pl> ec65f88
- up to 7.0.73 * Tue Oct 25 2016 Arkadiusz Miśkiewicz <arekm@maven.pl> a65fd03
- up to 7.0.72 * Tue Jul 19 2016 Arkadiusz Miśkiewicz <arekm@maven.pl> 0d6b705
- up to 7.0.70; add patch that fixes CVE-2016-5388 * Thu May 05 2016 Arkadiusz Miśkiewicz <arekm@maven.pl> d65ad7d
- up to 7.0.69 * Tue Dec 15 2015 Elan Ruusamäe <glen@delfi.ee> 097e6d1
- up to 7.0.67 * Sun Jul 26 2015 Elan Ruusamäe <glen@delfi.ee> 105a8ca
- Merge branch 'dev-7.0.55' + rpm -Uhv --nodeps --define '_topdir /tmp/B.1es5mcov' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' tomcat-7.0.109-1.src.rpm Updating / installing... tomcat-7.0.109-1 ######################################## + rm -f tomcat-7.0.109-1.src.rpm + install -m 700 -d /tmp/B.1es5mcov/BUILD/tmp + TMPDIR=/tmp/B.1es5mcov/BUILD/tmp + exec nice -n 0 rpmbuild -bp --short-circuit --nodeps --define '_topdir /tmp/B.1es5mcov' --define '_specdir %{_topdir}' --define '_sourcedir %{_specdir}' --define '_rpmdir %{_topdir}/RPMS' --define '_builddir %{_topdir}/BUILD' --target x86_64-pld-linux --define 'prep exit 0' /tmp/B.1es5mcov/tomcat.spec warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat warning: line 125: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-doc warning: line 126: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat-doc warning: line 127: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-doc warning: line 152: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-admin warning: line 234: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-jasper warning: line 235: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-jasper warning: line 251: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 warning: line 252: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 warning: line 253: It's not recommended to have unversioned Obsoletes: Obsoletes: java-servletapi5 warning: Could not canonicalize hostname: ymir Building target platforms: x86_64-pld-linux Building for target x86_64-pld-linux checking BuildConflict-ing packages rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 125: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-doc rpm: warning: line 126: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat-doc rpm: warning: line 127: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-doc rpm: warning: line 152: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-admin rpm: warning: line 234: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-jasper rpm: warning: line 235: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-jasper rpm: warning: line 251: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 252: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 253: It's not recommended to have unversioned Obsoletes: Obsoletes: java-servletapi5 rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: java(JSR109) is needed by tomcat-7.0.109-1.noarch rpm: java-avalon-logkit is needed by tomcat-7.0.109-1.noarch rpm: java-commons-daemon >= 1.0 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-dbcp-tomcat5 >= 0:1.1 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-pool-tomcat5 is needed by tomcat-7.0.109-1.noarch rpm: java-eclipse-jdt >= 4.4.2 is needed by tomcat-7.0.109-1.noarch rpm: java-geronimo-spec-jaxrpc is needed by tomcat-7.0.109-1.noarch rpm: java-jdbc-mysql is needed by tomcat-7.0.109-1.noarch rpm: java-mail is needed by tomcat-7.0.109-1.noarch rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux no BuildConflicts found checking BR rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 125: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-doc rpm: warning: line 126: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat-doc rpm: warning: line 127: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-doc rpm: warning: line 152: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-admin rpm: warning: line 234: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-jasper rpm: warning: line 235: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-jasper rpm: warning: line 251: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 252: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 253: It's not recommended to have unversioned Obsoletes: Obsoletes: java-servletapi5 rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: java(JSR109) is needed by tomcat-7.0.109-1.noarch rpm: java-avalon-logkit is needed by tomcat-7.0.109-1.noarch rpm: java-commons-daemon >= 1.0 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-dbcp-tomcat5 >= 0:1.1 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-pool-tomcat5 is needed by tomcat-7.0.109-1.noarch rpm: java-eclipse-jdt >= 4.4.2 is needed by tomcat-7.0.109-1.noarch rpm: java-geronimo-spec-jaxrpc is needed by tomcat-7.0.109-1.noarch rpm: java-jdbc-mysql is needed by tomcat-7.0.109-1.noarch rpm: java-mail is needed by tomcat-7.0.109-1.noarch rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux updating poldek cache... ready is up to date th is up to date th is up to date th-ready is up to date th-ready is up to date th-test is up to date th-test is up to date checking conflicting packages in BRed packages poldek: Loading [pndir]ready... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-test... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th-ready... poldek: Loading [pndir]th... poldek: Loading [pndir]th... poldek: 32852 packages read poldek: Removed 3275 duplicate packages from available set poldek: Processing dependencies... poldek: java-gnu-mail-1.1.2-3.noarch obsoleted by java-mail-1.4.4-1.noarch poldek: java-commons-daemon-1.0.15-2.x86_64 marks java-commons-collections-3.2.1-2.noarch (cap java-commons-collections >= 2.0) poldek: java-avalon-logkit-2.1-2.noarch marks java-servletapi-7.0.107-1.noarch (cap java(servlet)) poldek: java-avalon-logkit-2.1-2.noarch marks java-geronimo-jms-1.1.1-2.noarch (cap jms) poldek: There are 12 packages to install (3 marked by dependencies), 1 to remove: poldek: A java-avalon-logkit-2.1-2.noarch java-commons-collections-3.2.1-2.noarch poldek: A java-commons-daemon-1.0.15-2.x86_64 poldek: A java-commons-dbcp-tomcat5-1.4-1.noarch poldek: A java-commons-pool-tomcat5-1.5.7-2.noarch poldek: A java-eclipse-jdt-4.4.2-1.noarch java-geronimo-jms-1.1.1-2.noarch poldek: A java-geronimo-spec-jaxrpc-1.1-3.noarch java-jdbc-mysql-5.1.30-1.noarch poldek: A java-mail-1.4.4-1.noarch java-servletapi-7.0.107-1.noarch poldek: A java-wsdl4j-1.5.1-3.noarch poldek: R java-gnu-mail-1.1.2-3.noarch poldek: This operation will use 7.8MB of disk space. poldek: java-mail-1.4.4-1.noarch.rpm: digests OK poldek: java-commons-dbcp-tomcat5-1.4-1.noarch.rpm: digests OK poldek: java-commons-pool-tomcat5-1.5.7-2.noarch.rpm: digests OK poldek: java-jdbc-mysql-5.1.30-1.noarch.rpm: digests OK poldek: java-eclipse-jdt-4.4.2-1.noarch.rpm: digests OK poldek: java-commons-daemon-1.0.15-2.x86_64.rpm: digests OK poldek: java-avalon-logkit-2.1-2.noarch.rpm: digests OK poldek: java-geronimo-spec-jaxrpc-1.1-3.noarch.rpm: digests OK poldek: java-wsdl4j-1.5.1-3.noarch.rpm: digests OK poldek: java-commons-collections-3.2.1-2.noarch.rpm: digests OK poldek: java-servletapi-7.0.107-1.noarch.rpm: digests OK poldek: java-geronimo-jms-1.1.1-2.noarch.rpm: digests OK poldek: Need to get 7.6MB of archives. poldek: java-geronimo-jms-1.1.1-2.noarch.rpm: digests OK poldek: java-servletapi-7.0.107-1.noarch.rpm: digests OK poldek: java-avalon-logkit-2.1-2.noarch.rpm: digests OK poldek: java-commons-collections-3.2.1-2.noarch.rpm: digests OK poldek: java-commons-daemon-1.0.15-2.x86_64.rpm: digests OK poldek: java-commons-dbcp-tomcat5-1.4-1.noarch.rpm: digests OK poldek: java-commons-pool-tomcat5-1.5.7-2.noarch.rpm: digests OK poldek: java-eclipse-jdt-4.4.2-1.noarch.rpm: digests OK poldek: java-geronimo-spec-jaxrpc-1.1-3.noarch.rpm: digests OK poldek: java-jdbc-mysql-5.1.30-1.noarch.rpm: digests OK poldek: java-mail-1.4.4-1.noarch.rpm: digests OK poldek: java-wsdl4j-1.5.1-3.noarch.rpm: digests OK poldek: Executing pm-command.sh --upgrade -vh --test --root / --define _check_dirname_deps 0... poldek: warning: /root/.cache/poldek/ftp_ep09.pld-linux.org.dists.th.PLD.noarch.RPMS/java-geronimo-jms-1.1.1-2.noarch.rpm: Header V4 DSA/SHA1 Signature, key ID e4f1bc2d: NOKEY poldek: Verifying... ######################################## poldek: Preparing... ######################################## poldek: file /usr/share/java/mail.jar from install of java-mail-0:1.4.4-1.noarch conflicts with file from package java-gnu-mail-1.1.2-3.noarch no conflicts found checking BR rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 91: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat rpm: warning: line 92: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat rpm: warning: line 125: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-doc rpm: warning: line 126: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-tomcat-doc rpm: warning: line 127: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-doc rpm: warning: line 152: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-admin rpm: warning: line 234: It's not recommended to have unversioned Obsoletes: Obsoletes: apache-tomcat-jasper rpm: warning: line 235: It's not recommended to have unversioned Obsoletes: Obsoletes: tomcat-jasper rpm: warning: line 251: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 252: It's not recommended to have unversioned Obsoletes: Obsoletes: jakarta-servletapi5 rpm: warning: line 253: It's not recommended to have unversioned Obsoletes: Obsoletes: java-servletapi5 rpm: warning: Could not canonicalize hostname: ymir rpm: error: Failed build dependencies: rpm: java(JSR109) is needed by tomcat-7.0.109-1.noarch rpm: java-avalon-logkit is needed by tomcat-7.0.109-1.noarch rpm: java-commons-daemon >= 1.0 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-dbcp-tomcat5 >= 0:1.1 is needed by tomcat-7.0.109-1.noarch rpm: java-commons-pool-tomcat5 is needed by tomcat-7.0.109-1.noarch rpm: java-eclipse-jdt >= 4.4.2 is needed by tomcat-7.0.109-1.noarch rpm: java-geronimo-spec-jaxrpc is needed by tomcat-7.0.109-1.noarch rpm: java-jdbc-mysql is needed by tomcat-7.0.109-1.noarch rpm: java-mail is needed by tomcat-7.0.109-1.noarch rpm: Building target platforms: x86_64-pld-linux rpm: Building for target x86_64-pld-linux installing BR: java\(JSR109\) java\-avalon\-logkit java\-commons\-daemon java\-commons\-dbcp\-tomcat5 java\-commons\-pool\-tomcat5 java\-eclipse\-jdt java\-geronimo\-spec\-jaxrpc java\-jdbc\-mysql java\-mail + poldek --noask --caplookup -Q -v '--ignore=hhvm-*' '--ignore=php4-*' '--ignore=php52-*' '--ignore=php54-*' '--ignore=php55-*' '--ignore=php56-*' '--ignore=php70-*' '--ignore=php71-*' '--ignore=php72-*' '--ignore=php73-*' '--ignore=php74-*' '--ignore=php80-*' --upgrade 'java(JSR109)' java-avalon-logkit java-commons-daemon java-commons-dbcp-tomcat5 java-commons-pool-tomcat5 java-eclipse-jdt java-geronimo-spec-jaxrpc java-jdbc-mysql java-mail Loading [pndir]ready... Loading [pndir]th-test... Loading [pndir]th-test... Loading [pndir]th-ready... Loading [pndir]th-ready... Loading [pndir]th... Loading [pndir]th... 32852 packages read Removed 3275 duplicate packages from available set Processing dependencies... java-gnu-mail-1.1.2-3.noarch obsoleted by java-mail-1.4.4-1.noarch java-avalon-logkit-2.1-2.noarch marks java-servletapi-7.0.107-1.noarch (cap java(servlet)) java-avalon-logkit-2.1-2.noarch marks java-geronimo-jms-1.1.1-2.noarch (cap jms) java-commons-daemon-1.0.15-2.x86_64 marks java-commons-collections-3.2.1-2.noarch (cap java-commons-collections >= 2.0) There are 12 packages to install (3 marked by dependencies), 1 to remove: A java-avalon-logkit-2.1-2.noarch java-commons-collections-3.2.1-2.noarch A java-commons-daemon-1.0.15-2.x86_64 A java-commons-dbcp-tomcat5-1.4-1.noarch A java-commons-pool-tomcat5-1.5.7-2.noarch A java-eclipse-jdt-4.4.2-1.noarch java-geronimo-jms-1.1.1-2.noarch A java-geronimo-spec-jaxrpc-1.1-3.noarch java-jdbc-mysql-5.1.30-1.noarch A java-mail-1.4.4-1.noarch java-servletapi-7.0.107-1.noarch A java-wsdl4j-1.5.1-3.noarch R java-gnu-mail-1.1.2-3.noarch This operation will use 7.8MB of disk space. java-mail-1.4.4-1.noarch.rpm: digests OK java-avalon-logkit-2.1-2.noarch.rpm: digests OK java-commons-daemon-1.0.15-2.x86_64.rpm: digests OK java-commons-dbcp-tomcat5-1.4-1.noarch.rpm: digests OK java-commons-pool-tomcat5-1.5.7-2.noarch.rpm: digests OK java-eclipse-jdt-4.4.2-1.noarch.rpm: digests OK java-geronimo-spec-jaxrpc-1.1-3.noarch.rpm: digests OK java-jdbc-mysql-5.1.30-1.noarch.rpm: digests OK java-wsdl4j-1.5.1-3.noarch.rpm: digests OK java-servletapi-7.0.107-1.noarch.rpm: digests OK java-geronimo-jms-1.1.1-2.noarch.rpm: digests OK java-commons-collections-3.2.1-2.noarch.rpm: digests OK Need to get 7.6MB of archives. java-geronimo-jms-1.1.1-2.noarch.rpm: digests OK java-servletapi-7.0.107-1.noarch.rpm: digests OK java-avalon-logkit-2.1-2.noarch.rpm: digests OK java-commons-collections-3.2.1-2.noarch.rpm: digests OK java-commons-daemon-1.0.15-2.x86_64.rpm: digests OK java-commons-dbcp-tomcat5-1.4-1.noarch.rpm: digests OK java-commons-pool-tomcat5-1.5.7-2.noarch.rpm: digests OK java-eclipse-jdt-4.4.2-1.noarch.rpm: digests OK java-geronimo-spec-jaxrpc-1.1-3.noarch.rpm: digests OK java-jdbc-mysql-5.1.30-1.noarch.rpm: digests OK java-mail-1.4.4-1.noarch.rpm: digests OK java-wsdl4j-1.5.1-3.noarch.rpm: digests OK Executing pm-command.sh --upgrade -vh --root / --define _check_dirname_deps 0... warning: /root/.cache/poldek/ftp_ep09.pld-linux.org.dists.th.PLD.noarch.RPMS/java-geronimo-jms-1.1.1-2.noarch.rpm: Header V4 DSA/SHA1 Signature, key ID e4f1bc2d: NOKEY Verifying... ######################################## Preparing... ######################################## file /usr/share/java/mail.jar from install of java-mail-0:1.4.4-1.noarch conflicts with file from package java-gnu-mail-1.1.2-3.noarch error: BR installation failed + chmod -R u+rwX /tmp/B.1es5mcov/BUILD + rm -rf /tmp/B.1es5mcov/tmp /tmp/B.1es5mcov/BUILD + rm -rf /tmp/B.1es5mcov Begin-PLD-Builder-Info Build-Time: user:5.73s sys:1.17s real:9.35s (faults io:29 non-io:277436) End-PLD-Builder-Info
[Back to list of logs] [View rpm -qa of builder]